Previous 1 2 3 4 Next 46 Replies Latest reply: Jan 24, 2012 7:56 AM by Phil1950
davidfrommiddletown Level 1 Level 1

Just received my new AT&T phone today.  Set it up with no problems.   Then I get an "invalid sim" message.   After rebooting a couple of times it goes away, but it keeps coming back.   Thoughts?


iPhone 4, iOS 5
  • Andrew Rothman1 Level 1 Level 1

    Same here. Got my 4S at the store. Worked fine all day, but suddenly "Invalid SIM". Back to the store tomorrow…

  • Andrew Rothman1 Level 1 Level 1

    Rebooting the phone seemed to fix it temporarily, but then it decided mid-call that the SIM was invalid. I'm at AT&T now to see about a replacement SIM.

  • neelfromatlanta Level 1 Level 1

    I'm having the exact same issue...re-booting fixes it temporarily, but it goes back to invalid sim after a while. It would be great to hear what the store says, and even better if someone knew a way to address it without going to the store. Thanks for your help!

  • davidfrommiddletown Level 1 Level 1

    I found that if you remove the SIM card, reseat it in its frame, then reinsert it, it seems to solve the problem. 

     

    Turn off the phone.

     

    I got a paperclip and popped out the sim card by putting the end of the paperclip in the tiny hole on the side of the phone (its on the opposite side of the volume controls).  This will pop out the sim card.

     

    Take the sim card out of the casing, blow on it for good luck, then place it back in the casing. 

     

    Push the casing back into the phone until it snaps into place.

     

    Turn the phone back on. 

     

    It's been 24 hours and haven't had any issues since.  Hope this saves you from standing in line at the Apple store....

  • edd13chen Level 1 Level 1

    Posting the same thing here again just to reinforce the fact that this is affecting many customers now obviously.  I have the 4S 64GB model (black) and have the same issue.  Rebooting does seem to help, so I'm very thankful for whoever posted that solution (albeit temporary). 

  • Andrew Rothman1 Level 1 Level 1

    The AT&T Store tech installed a new SIM. Seems to be working stably so far!

  • neelfromatlanta Level 1 Level 1

    Thanks to all. I ended up going to the AT&T store as well, to get a new SIM. After I tried popping out the original SIM and putting it back in, the error message went from Invalid SIM, to SIM Failure, to eventually No SIM. So that was that. New one seems to be working fine so far.

     

    The guy at the store thinks that the activation server issues Friday night may have some impact on SIMs activated during a certain window. No idea if that makes any sense, but it was his theory.

  • cfunk1984 Level 1 Level 1

    Also having this issue... So it looks like the fix is a new SIM?  I've tried the reboots and pulling the card several times.  The issue has been coming back over and over again.  I've had to reboot the phone everyday.

     

    Has anyone with a new SIM card had the error come back?

  • Andrew Rothman1 Level 1 Level 1

    I've had the new SIM since Saturday morning and zero trouble. I think it was just a bad card.

  • Bella4211987 Level 1 Level 1

    GRRRR... me too! I can't take the SIM card out, I need to go to the store!... very annoying

  • R. Matt C. Level 1 Level 1

    I got my iPhone 4S on 10/15/2011.  The Invalid SIM error first occurred 10/23 and was corrected with hard reboot.  The same error occurred today, 10/24, and again reboot fixed it.   I'll probably take it in to the store this evening and see if they can replace the card.

  • oneontagrace Level 1 Level 1

    My iphone4s at&t first showed SIM failure message on Oct 19 the day after I bought it at the SF apple store where they activated it for me. My son corrected it somehow wirh a paperclip. Now, one week later I get the message sim failure and then it changed to invalid sim. I do not live anywhere near an apple store, so I'll take it to at&t. Annoying.

  • mkupe22 Level 1 Level 1

    SIM card removed, then replaced.

    Works so far. 10 min.

  • dffdce Level 1 Level 1

    Got my 4S on Monday 11/7. This morning (11/10) got an invalid SIM warning.  Power cycled the phone, now it's stuck with No SIM.  Removing and re-inserting the SIM card hasn't helped.  Oh well off to the AT&T store.

Previous 1 2 3 4 Next