Previous 1 2 3 4 Next 46 Replies Latest reply: Jan 24, 2012 7:56 AM by Phil1950 Go to original post
  • dffdce Level 1 Level 1 (30 points)

    Wow - had a very good experience in the AT&T store.  In and out in like 3 minutes with a new SIM.  So far so good.

  • caryn_sian Level 1 Level 1 (0 points)

    I got a brand new Orange contract this Monday. By monday night I had this error. Turning the phone on/off/removing and replacing sim both worked temporarily.

     

    Went back to Orange Wed, got a new sim card. Worked fine for the evening but by Thursday got the same error so am now thinking its something to do with the phone.

     

     

    I read somewhere else that it may be a software issue, in which case I should try a complete system restore to original settings and try and re-install the iO5? Im not sure how to go about doing this though, have to wait until sunday to have my Genius store appointment

  • ulkerarif Level 1 Level 1 (0 points)

    Donno why but I had the same problem on my brand new 4S after I updated with 5.0.1. it seems I need to have a new sim card. I will do it tomorrow morning.will see that will happen

  • Divine Retribution Level 1 Level 1 (0 points)

    Hi guyz. I got an iphone4s at&t... I had no problems in my first week and a half.. Then one day i woke up with invalid sim error.. I just turned it off and on.. And it was fixed right away. But every morning i still get the error.. After 4 days f error it just went away.. I have no problem since then.. There are only 2 things i can blame for the incident.. First is "charger" i started using iphone 4 charger on my 8th day coz i think they're just the same with 4s.. After i got the error i tried to used 4s charger and it took 2-3days to fix it... Second thing i noticed is the temperature... All those errors happened on the coldest part of the day around 2-3 am ( i woke up 2am there was no error, then i just drop a deuce and when i came back, there was an error).. The temperature at that time was 38-43F.. Then when the weather went up to 52-70F daily and i had no errors... Both are kinda stupid but that's what i noticed.

  • deeks1974 Level 1 Level 1 (0 points)

    Same thing on my orange upgrade to iphone.  Received new microSIM and phone on Monday 7th Nov.  Registered microSIM and activated iphone with no problems.  Come Thursday in work, I get "SIM failure" message.  Rebooted the phone which resolved the issue.  However, when I got home that night I synced with itunes and updated to 5.0.1 as prompted.

     

    Phone kept saying "SIM failure", "no SIM", "no network" etc etc

     

    Only time I could get the phone to work was when I rebooted whilst connected by USB to my laptop.  Even then it only lasted about 10 minutes max.

     

    Called Orange on Friday (call centre closes at 10.00pm), who have never even heard of the issue.  Said they would send a new microSIM out.  Foolishly I agreed as I should've just went to the store. 

     

    Anyhow, went to the Apple Store in Glasgow on Saturday who assured me the phone and software update were not the cause but the micorSIM.  They showed me that the microSIM card's gold contacts were not clearing the edges of the microSIM holder tray and, as it was touching the contacts, had damaged the microSIM by shorting it.  Incidentally, since leaving the store, my phone has refused to connect to my network completely.

     

    Get the new microSIM tomorrow which will hopefully resolve the issue.  Out of interest, I tried shaving some excess plastic off one side of the microSIM so as it cleared the tray's sides, which did't work.  I'm now apprehensive as to how this is going to go tomorrow.

     

    Thought I'd post as I couldn't see similar problems or Apple Store advice resolving this issue apart from tedious setting changes (airplane mode on and off, change carrier setting to manual, remove SIM etc) and frequent rebooting.

     

    Just check your microSIM dimensions once in the tray.  If you can't see a gap between the microSIM and the tray, then this could be the problem.

  • raynerfromsingapore Level 1 Level 1 (0 points)

    I am fr Singapore and I have the same freaking problem. And my stupid telco knows nothing about it ... Stoopid Singtel!

     

    I made countless calls to the hotline and asked me to perform redundant procedures.

     

    Finally, decided to change the micro-SIM cards. Inserted the new ones and within 1 hr, same error 'Invalid SIM".

    On-off and try again.... it's been 2 hours... still fine....

     

    Background: iPhone 4s, I've 2 numbers. 1 number comes with the phone and the SIM card was ok. The problem is when I used my the other number with multi-SIM function (ie. multiple SIM cards using 1 numbers), that's when the invalid SIM appears. So must be SIM card issues right or the multi-SIM function conflicting with 4s. 

  • Ege Altuner Level 1 Level 1 (0 points)

    Hi everybody,

    I bought my Iphone 4S on this monday.Since monday I got 7 invalid sim error.It makes me cry as much as you.I click to aircraft mode but it does not fix the problem, I need to swtich off and on every time when I get this error.We definitely need a official explanantion as much as quick

  • melopez Level 1 Level 1 (0 points)

    The apple server has been swamped with activation request due to high updating since IOS5 ,for some it has been succesful but for others not.I have the same problem and took my Phone to the apple store and they did the update for me.I suggest you return your phone and get a new 4 s .

  • rogerfromsingapore Level 1 Level 1 (0 points)

    Same here, am from Singapore, got my phone from M1 Telco just yesterday. I have rebooted my phone 6 times since and it is still happening.

  • rbtwrld Level 1 Level 1 (5 points)

    I have the same issue with my iphone 4S and the solution was easy, go to my carrier and ask for a new sim, after I insert the new sim my iphone 4S works without issues.

     

    I have never received another time the invalid sim error with my new sim card.

     

    This issue is not a problem if the iphone this issue appears because your carrier blocks the sim for some reason, and after you restart your phone it works again.

     

    Go and get a new sim to avoid having to restart your iphone a lot of times every day.

     

     

    * My iphone 4S is unlocked and I can use it with any carrier.

  • sandeepfromfaridabad Level 1 Level 1 (0 points)

    This same happened to me as well I bought 4s 32 gigs unlocked in US. Now I brought back to India for use it is showing invalid sim when kept in night. I think if I stop using it for hours together it happens. But it is really painful to see such a error every morning. Please let me know if you find any solution. As we don't have 4s yet in Indian stores I  worried that I will not be able to replace it as well.

  • yongmongrong Level 1 Level 1 (0 points)

    raynerfromsingapore wrote:

     

    I am fr Singapore and I have the same freaking problem. And my stupid telco knows nothing about it ... Stoopid Singtel!

     

    I made countless calls to the hotline and asked me to perform redundant procedures.

     

    Finally, decided to change the micro-SIM cards. Inserted the new ones and within 1 hr, same error 'Invalid SIM".

    On-off and try again.... it's been 2 hours... still fine....

     

    Background: iPhone 4s, I've 2 numbers. 1 number comes with the phone and the SIM card was ok. The problem is when I used my the other number with multi-SIM function (ie. multiple SIM cards using 1 numbers), that's when the invalid SIM appears. So must be SIM card issues right or the multi-SIM function conflicting with 4s. 

     

    Indeed, Singtel knows nothing of what's happening around the world. I swapped a SIM card today and within hours the error returned. I'm trying a fix online that says turning off location services will do the trick. Any of you have location services turned on?

  • jray17 Level 1 Level 1 (0 points)

    Just to reiterate so Apple may acknowledge the problem...I activated my new 4s about 5 hours ago and have had invalid sim messages 6 times already.  Rebooting is a temporary fix, but will recur shortly thereafter.  The ATT store in the US said Apple is the only one who can fix it and refused to help me.  Off to stand in line for hours at the Apple store I suppose....

  • raynerfromsingapore Level 1 Level 1 (0 points)

    FREAKING SINGTEL!!!! Now they says it's a bug with iPhone 4S when I went to ComCentre. WHY CAN"T THEY TELL ME THAT OVER TEH HOTLINE?!?!?! ARGGHHHHHH.... Need to wait for OS 5.0.2 according to them.

    Apparently, the bug affects multi-SIM users. Pls confirm if you guys are multi-SIM users?

     

    STOOPID STOOPID SINGTEL:

    1) Took so long to realise the multi-SIM issue! I feedback to them that when I first called them about the issue! (Coz I have 2 lines -one is single SIM and the other multi-SIM)

    2) Wasted so much time explaining and re-explaining and re-explaining the issues to the hotline everytime I call in.

    3) Ask them so what I can do, tell me just have to turn on/off  several times per day.... ARRRGGGHHHH...can you believe it!!!! 

  • yongmongrong Level 1 Level 1 (0 points)

    Yes, am on Multi-SIM Singtel too.