14 Replies Latest reply: Mar 19, 2012 11:58 PM by impious-rocker
jakudo Level 1 Level 1 (0 points)

After upgrading my iPhone 4 and iPad 2 (Wi-Fi only) to iOS 5, the Personal Hotspot doesn't work the same way as it was in iOS 4. In iOS 4, I had the Personal Hotspot always turned on on iPhone and whenever I took the iPad and wanted to connect to internet, it connected almost immediately and automaticaly to the iPhone. Now (in iOS 5), I have the personal hotspot turned on again, however, the iPad even doesn't see the iPhone wi-fi. I have to unlock the iPhone, go to the settings (change nothing!) and than the iPad see the wi-fi. It is not automatical. Personal Hotspot was the reason, why I bought only wi-fi iPad and now it doesn't work well. Do you have any idea what to do?



iPhone 4, iOS 5
  • barbarafromlincoln Level 1 Level 1 (0 points)

    I am having the same problem and it creates a new home network so now I have like 12 home networks.  If you come across any answers please share.

  • Ferg633 Level 1 Level 1 (0 points)

    I am having a similar issue; I do not even have the option of turning on the personal hotspot in the iPhone 4 preferences pane anymore after upgrading to ios 5. I have a big enough data plan to do it through my carrier, and this is the only reason that I bought the Wifi only ipad2. I am hoping this is just a glitch that will be corrected with the next update and not anything else.

  • jakudo Level 1 Level 1 (0 points)

    You can turn it on in Settings - General - Network - Personal Hotspot. After you turn it on in here, it appears in Settings (it should appear).


    iPad 2 wi-fi only without working Hotspot on iPhone is usless...

  • Ferg633 Level 1 Level 1 (0 points)



    I have no option anywhere in setting to turn personal hotspot on (not under network, and not in the main window). The option is completely gone. That is my concern, it does not seem to be a temporary glitch, or a new location in the menu tree for the item, it seems like it is a deliberate ommision from the Settings.


    I have looked at other support forms, and there seem to be a few other people reporting the issue, all coming from non-unlocked phones. This option always used to be in the menu on my carrier, and if an individual did not have a sufficiently large data plan then it would just prevent the user from actuall turning the hotspot on. Now the option is completely gone for everyone, including those paying for the option on their plan.


    Good try, but sadly didn't help

  • jakudo Level 1 Level 1 (0 points)

    mm, i see. Sorry it didn't help. It helped to me... however even I found the Personal Hotspot, it still doesn't work well (actually very bad:/ ).

  • Ferg633 Level 1 Level 1 (0 points)

    On further investigation I seem to have found a solution, and it may help the rest of you too.


    Under Settings - General - Reset, select the "Reset Network Settings" option.


    My hotspot option is now available again (still only under General - Network initially and after turning it on it came back to the regular location).   Also, it is working very well, and it may therefore be an issue of a "dirty" installation with fragments of settings from the old iOS now talking nicely to the new one.


    Anyhow, the reset only takes about 2 minutes and doe NOT affect anything else on the phone, it may help the rest of you out with you bad connection issues ect.



  • freddyfromsitiawan Level 1 Level 1 (0 points)

    I have similar but mind bobbling issue. Using iPhone 4s with os5.01. Turned on hotspot, on the cellular data, tried reset network setting to factory default but my hotspot signal is not discoverable by my ipad2, laptop and other wireless devices.


    Went to office, get my friend using iPhone 4 running os4.35 to turn on hotspot. Immediatedly found his hotspot in my ipad2 and the funny thing is that my hotspot signal from 4s suddenly pop up in my ipad2 wifi network, appeared in my laptop and other nokia phone without me touching anything on my 4s. Able to connect and work well. But as soon as I turn off the hotspot, it became not discoverable again when turned on. Tried resetting the network setting but nothing worked.


    The next day, the hotspot signal become discoverable again as soon as my friend turn on his hotspot. It seemed that my hotspot signal need a another hotspot signal to appear. This is ridiculous. If my friend is not around, I will never get my hotspot connected to my iPad2 or make use of this capability.


    Sounds funny but this is true and proven. It has been a week now that I keep repeating the same thing in office. I tried not turning off the hotspot after it is discoverable but it is draining off the battery faster.


    Any tips you can share....

  • Medialook Level 1 Level 1 (0 points)

    I have simillar problem - after updating to ios5 my hotspot signal is not discoverable by all devices via wi-fi.

    I can connect thru bluetooth with my macbook pro - didn't chek how it works with cable.

    I tried restetting network setings but it didn't fix the problem.

    Any ideas?

  • badtz Level 2 Level 2 (250 points)

    Unfortunately, according to Apple, http://support.apple.com/kb/TS2756 ... the hotspot turns itself off after 90 seconds of inactivity while asleep. The only way to "turn it back on" is to go into the settings


    I assume they did this for battery reasons? Maybe there's a method to keep the hotspot active?

  • jakudo Level 1 Level 1 (0 points)

    Sounds interesting, however, not in my case. When I turn on the personal hotspot and lock the iPhone, it's not discoverable immediately not after 90 sec...

  • troyofsd Level 1 Level 1 (0 points)

    I had this same problem with the iPhone 4 Hotspot and my New iPad WiFi (3rd Gen) and I was able to fix it by going to Settings --> General --> Bluetooth on both devices. Letting them set on this screen till they both discovered each other. Then I did a Bluetooth Pairing between the two and now the tethering works great.

  • Medialook Level 1 Level 1 (0 points)

    That solved my problem (discovering hot spot in hot spot screen menu in settings) + i had to call my mobile operator and ask for reseting my personal hotspot settings. Now it works perfectly as it should



  • impious-rocker Level 4 Level 4 (1,195 points)

    Try staying on "Personal Hotspot" screen during the entire time you are using it. Also, make sure your phone doesn't go in to sleep mode (set auto-lock to "Never").


    I encountered this problem a couple of times and then I remember reading it in some thread that if you leave the "Hotspot" screen while you are using it, it will automatically stop broadcasting signals after 90 seconds. Ever since I have been sticking to that screen and I have been able to use it for hours (literally) without a glitch.


    See if it helps. 


    Message was edited by: impious-rocker

  • impious-rocker Level 4 Level 4 (1,195 points)

    If your phone goes in to "sleep mode"; it will stop broadcasting signals regardless of the time. Set auto-lock to "Never"