Skip navigation

The iPhone “iPhone” cannot be used because it requires iTunes version 10.5 or later

2626 Views 6 Replies Latest reply: Oct 15, 2011 7:57 AM by thaynelance RSS
kevin from hammonds plains Calculating status...
Currently Being Moderated
Oct 15, 2011 12:50 AM

I just purchased the iphone 4S and want to connect to itunes to move my backup onto the new phone but when I plug the new one in it says - The iPhone "iphone" cannot be used because it requires itunes version 10.5 or later. The iphone 4S has the latest everthing??? Why am I not able to connect to itunes?

My MAC is app. 2yrs old.

iPhone 4

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.