Previous 1 2 3 4 Next 1,365 Replies Latest reply: May 5, 2014 6:46 AM by marcus_30 Go to original post
  • mandyfromhouston Level 1 Level 1 (0 points)

    I have a 64GB iphone 4S and have had to reboot it at least six times since activating it 24 hours ago.  Thankfully that has been working.  Has anyone been successful in fixing the problem with a visit to AT&T.  Trying to determine whether i need to visit the Apple store or the AT&T store tomorrow.

  • racyb Level 1 Level 1 (0 points)

    I also have the same issue.  Dialog popped up and said sim failed.  No service on my white 32 GB 4S on Verizon.  Did a shutdown and went into searching mode and finally found Verizon again after 1 minute.  What is going on?  I have both a black 16GB and 32GB 4S and no problems from those yet.

  • Entro Level 1 Level 1 (0 points)

    I've had my AT&T 64gb White 4S for about 4 hours now and just that the "No SIM Failure" message. I restarted my phone and it was fine, will have to wait and see.

  • jordyfrommelbourne Level 1 Level 1 (0 points)

    I am also having this problem & im from Melbourne Australia. I think this is going to be a big problem just like the antenna on the original 4.

  • JinkysOars Level 1 Level 1 (0 points)

    I got issue's with sim card here in UK! I bought 2 handsets one for my other half and hers is fine but my one keeps giving me the no service message and needs reboot! Only reconnects for a short time if at all then goes again. I have checked with the network provider and no problems there so I am suspecting this is some thing to do with the sim contact points though the sim is rock solid in my partners 4s! I should add that I don't think this is a shielding issue like the dreaded Death grip! I will be ordering a replacment sim and if it is no better will be returning the handset!

  • SeattleMacUser76 Level 1 Level 1 (0 points)

    Same here, just got my 64 gb and at first it said invalid sim. Now it just says no sim. Tried what other people suggested to no avail. Gotta pinch some Mac genius's ears tomorrow, I need a phone to work.

  • ukflyer Level 1 Level 1 (0 points)

    I am in the UK and got an unlocked iPhone 4S delivered on the release day. I know Virgin Mobile do not support the iPhone family, yet, for over a year, I have been using an iPhone 4 very successfully with my Virgin Mobile sim card. I used a micro sim card cutter to trim it to the required size and it has worked fine until now.


    On the iPhone 4s release date I had been waiting, excitedly, for the phone to arrive, having ordered it a week ago. Why? The faster processor and the virtual assistant, Siri.


    I followed the instructions to transfer everything from the old iPhone 4 to the new iPhone 4S. Took out the old sim and put it in the new phone. For a moment everything worked fine. I made a test call, no problem. After five minutes the message SIM FAILED appeared and then, in the provider space INVALID SIM.


    Has anyone else had this issue? There must be others using iPhones on Virgin, here in the UK.


    I called Apple. They had no clue what might be wrong. I called Virgin Mobile, who said my sim card may be too old and they will send me a new one.


    I tried another Virgin (known to work) sim in the phone and it did the same thing. I wonder if all new iPhone 4S's are going to have this incompatibility or do I just have a duff one?


    To recap, the sim still worked perfectly in the old iPhone 4 and I have not jailbroken either one.


    Virgin then cancelled my old sim card, so I went out and bought a 'pay as you go sim' until the new one arrives. Latest design and it does the same thing. It did work a bit longer (about 25 minutes) and I had time to make a call and send a couple if SMS messages before the phone said invalid sim.


    Took it out and put it in the old 4 and it works fine.


    This is too much aggro and taking up so much time, I may just keep using the old one and send the 4S back. Not decided yet.

  • Sandykt Level 1 Level 1 (10 points)

    Got my iphone 4s black 32gb on day of release, activated SIM and within 2 hours of setting up phone, I had "SIM failure" message on my screen.  Switched phone off and on and worked for a while.  I have now reset phone (on Apple's advice) and a replacement sim is on its way from Orange.  Will see if another sim causes the same problems and, if so, I am going straight back to the store next weekend.  For £600, I do not expect this kind of hassle. 


    I think this problem is more widespread than we realise and its probably a software issue.  Apple needs to act fast on this one.


    I would be interested to know if others have taken their phone back to Apple and the explanation given. 

  • iHujanen Level 1 Level 1 (5 points)

    An update on my NO SIM message... I went to my local AT&T store and they simply replaced my SIM card with a new one and it fixed the issue.  It took them two minutes to do this and I was on my way... no issues since.

  • gadgetmax Level 1 Level 1 (5 points)

    Add one more. 32G, worked for 24 hours before the first failure. At first reboots solved the problem temporarily, then removing and reinstalling the sim worked for awhile, now nothing fixes it. Time for a replacement phone?

  • sopersan Level 1 Level 1 (0 points)

    Mine appears to be working now. Apple phone support suggested removing the sim card altogether - I'm on Sprint which is CDMA so the sim card is only for use outside the US. If you have a CDMA iPhone try yanking the sim, is your iPhone is GSM then you probably got a bad sim card.  

  • ukflyer Level 1 Level 1 (0 points)

    @Sandykt. I agree! I think it may be a software or hardware issue. I am not convinced the old sim card answer is right, especially as we have all had no problems with using them in the 4. Perhaps we should start calling the issue SIMGATE!!! Very frustrating, especially having shelled out £600. I do not have an Apple store anywhere near me, so will have to phone the customer support team again tomorrow to see if they have any updates on this. BTW, has anyone found out if and when SIRI will be as functional in the UK, as in the USA? And if we will be able to change the voice... I really do not like the bloke's voice.


    @sopersan. We do not use CDMA in the UK. All service providers are on GSM (or at least all use sim cards) so your solution does not work for us. I am glad it is resolved for you.

  • imcommon Level 1 Level 1 (0 points)

    Had to take sim card out twice, and reboot several times and redownload the os and maintain to factory settings, but it's been working again with no problems. Cancelled genius bar appointment, and hoping for the best. Maybe the sim card got jostled in shipping.

  • Joe Low Pro SB Level 1 Level 1 (0 points)

    Yup... 32GB ATT Black. Same problem. Acitivated on Friday. Invalid SIM w/in 24 hrs. Power cycle fixed for several hours. Then power cycle didn't work. Left it off for a while, turned it back on and it worked for about 5 min... then Invalid SIM again.

  • SeattleMacUser76 Level 1 Level 1 (0 points)

    So I just popped off the SIM and as I inserted it back I made sure that the sim card was flush and centered in the tray ( seems that the sim card is slightly thicker than the tray. So it might cause it to unseat. Anyway the phone worked again instantly. I'll post again if it goes back go the error, otherwise it hasn't gone back to "no sim". We shouldn't have to deal with this obviously... It is a **** brand new phone.

    Update after: 14 hours I haven't gotten an error, seems to work fine.

Previous 1 2 3 4 Next