1 2 Previous Next 16 Replies Latest reply: Jan 7, 2013 10:49 AM by haroldk51
DaWnKiLLa Level 1 Level 1 (15 points)

Since I updated to iOS 5 the WiFi personal hotspot doesn't work. I turn on WiFi as usual, then turn on the personal hotspot. Going back to the main settings page, instead of WiFi turning to "On" it still says "Not Connected" as if I'm trying to connect my iPhone to a WiFi. I'm on the 3 UK network, but I don't think they've changed anything at their end because I can still connect via USB.

 

Is anyone else experiencing this problem/have a solution?


iPhone 4, iOS 5
  • 1. Re: WiFi Personal Hotspot not working
    lquesada1975 Level 1 Level 1 (0 points)

    Just to say that I am also having problems with the Personal hotspot feature. After installing iOS5 in my iPhone 4  the Personal hotspot feature does not seem to work anymore... It seems the phone is no longer discoverable.

  • 2. Re: WiFi Personal Hotspot not working
    lquesada1975 Level 1 Level 1 (0 points)

    Well, it is working for me now. I did not do anything; I just tried again and the issue was gone.

  • 3. Re: WiFi Personal Hotspot not working
    Wolftrapme Level 1 Level 1 (5 points)

    Right I've found the problem, well a work around at least. Simply unplug the iphone from the dock cable and then I can see iPhone pop up in my iMac's wifi networks. Seems to be a bug!

  • 4. Re: WiFi Personal Hotspot not working
    DaWnKiLLa Level 1 Level 1 (15 points)

    How weird! Works though. Thank you

  • 5. Re: WiFi Personal Hotspot not working
    veshman Level 1 Level 1 (0 points)

    I have been having similar problems since upgrading to iOS 5 as well. I don't use tethering very often, but have been paying for it since I got the Verizon iPhone 4, iOS 4.

     

    Previously, when I wanted to connect via WiFi, it just worked. At $20 / month, for sporadic usage, that's exactly what I want to be able to do. Just connect to the phone in a pinch and move on with my day.

     

    Since iOS 5, I'll turn the Personal Hotspot on, and my Macbook Air (SL 10.6.8) doesn't see the iPhone for a long time, if at all. Then I have to turn the Hotspot on/off, WiFi on/off, etc and go through a fair amount of frustration to finally get it to work. If I get a call or some other phone interruption, it seems I have to go through the process again.

     

    There definitely seems to be a change/bug introduced in iOS 5 that needs to be corrected.

     

    Bhavesh Patel

  • 6. Re: WiFi Personal Hotspot not working
    dzeibin Level 1 Level 1 (0 points)

    I don't know if this is a new thing in iOS5, since I only recently got my iPhone 4s, but the note on this page seemed to help: http://support.apple.com/kb/ts2756 (under the "Wi-Fi Troublehsooting" section):

     

    Note: If you leave the Personal Hotspot screen or put iPhone to sleep, iPhone only broadcasts the Wi-Fi network for an additional 90 seconds. If no devices join the Wi-Fi network during that time, iPhone stops broadcasting your Wi-Fi network. You can start broadcasting your Wi-Fi network again by tapping Settings > Personal Hotspot.

     

    I've been having problems, but opening the Personal Hotspot screen, then connecting the computer to it, THEN putting the phone to sleep after the connection is established seemed to work just fine.

  • 7. Re: WiFi Personal Hotspot not working
    siam007 Level 1 Level 1 (0 points)

    I get the same thing as the OP. Ever since I upgraded to ios5 the personal hot spot is not discoverable. It's like the SSID is just not being broadcast.

     

    I have tried:

    • disabling/enabling personal hot spot
    • resetting the network settings
    • power cycling the iphone
    • turning wifi on off (moot point since I am not near a router nor does it have anything to do with personal hot spots)

     

    Using it tethered to my laptop I can connect ok.

     

    One time out of 100 it will just work, but there is no rhyme or reason for why it decided to work.

  • 8. Re: WiFi Personal Hotspot not working
    siam007 Level 1 Level 1 (0 points)

    I was able to resolve it. The problem is that you MUST keep the menu on personal hot spot while clicking to refresh the network list on your PC/Mac. (not sure if Mac has a refresh) Once I did this, it worked every time.

     

    In iso 4, you just needed to go to personal hot spot and could go back out of the menu. If you clicked refresh within the 90 second broadcast time, it worked no matter where you were in the settings (as long as you navigated to personal hot spot and back out).

     

    Strange that you can do anything in the personal hotspot or wifi, but it will never work unless you are on the actual hotspot option.

     

    Hope this helps others

  • 9. Re: WiFi Personal Hotspot not working
    Frank_Renner_2011 Level 1 Level 1 (0 points)

    This is not a true solution to the subject.

     

    I have MacOS 10.6.8 and iOS 5.0.1 and since I updated iOS from 4.x to 5.x, I can't connect to the Personal Hotspot WiFi on the iPhone.

     

    Your statement as true and helpful as far as we talk about visibility of the iPhone SSID, but my Mac still does not connect.

     

    If I try via Apple->Settings->Network, I get an endlessly repeated "Enter Password" dialog and when I try directly via the Airport-Menu, I mostly get a timeout message but also some rare times a "wrong password" message while still in the password dialog (which means I can quickly try to connect repeatedly). When the latter happens, I shortly see the hotspot message bar on the iPhone, which quickly disappears again before the "wrong password" message is displayed on the Mac.

     

    This is surely a bug of iOS 5. But as I am still using Snow Leopard, I would also be interested if users of Lion have the same problem.

     

    Thanks for all your helpful postings here.

  • 10. Re: WiFi Personal Hotspot not working
    Frank_Renner_2011 Level 1 Level 1 (0 points)

    Now I have resolved the problem with the help of the Apple hotline.

     

    I did a reset of all contents and settings (Settings->General->Erase all contents and settings) and re-installed by only answering the questions of the assistant and not reinstalling any backups or resyncing.

     

    After that I found when restarting the Personal Hotspot feature that because of the absence of any settings, the Personal Hotspot settings were suggesting a new randomly created password. I tried to connect by using this...and it worked!

     

    Then I re-installed the backup of my iPhone and as expected, the Hotspot feature had re-installed my old password as well. Tried it and...it didn't work anymore once again. So I had the idea to simply change the password to "abcabc" and...it worked again! Then I retyped my former password and...it still worked!

     

    All in all, something seems to have been wrong with the password, although I already had checked that there were no leading or trailing blanks and things in it. As I initially typed it in with the iPhone keyboard, it is also impossible that there were any gremlins or things contained. I simply don't know what it was. But in the end and after loads of effords, it seems that retyping the password has solved my problem.

  • 11. Re: WiFi Personal Hotspot not working
    Edward240 Level 1 Level 1 (0 points)

    Hi 007, Yes this certainly did help others, me. I did exactly as you said, stayed on the personal hotspot screen and my phone then was discovered by my notebook. fact here Thank you so much.

     

    Lets review one fact here:

     

    You have to have your phone Wifi on, but you cannot actually be connected to anything else while you attempt to discover your hotspot signal. Many of us have our notebooks set to automatically connect to home or work wifi's.

    If this is the case you must disconnect from your notebook wifi connection while leaving your iphone wifi on. Then stay on the hotspot screen after turning on hotspot and then look at your notebook to see if iphone is discovered.

     

    Yes, it seems to be much more difficult after the ios5 update, but progress is always difficult......

    Thanks

  • 12. Re: WiFi Personal Hotspot not working
    Sat 1 Level 1 Level 1 (0 points)

    @ Siam007: I did exactly as you did and it worked for me too.. thanks. Unable to fathom the cause for it not workign earlier though...anyways thanks for your help.

  • 13. Re: WiFi Personal Hotspot not working
    AdnanB Level 1 Level 1 (5 points)

    I've been having this issue too. It's a big pain now to get it to work while in iOS 4 it would work from the first try.

     

    Please report this to Apple to bring attention to this:

    http://www.apple.com/feedback/iphone.html

  • 14. Re: WiFi Personal Hotspot not working
    Sceptique Level 1 Level 1 (0 points)

    Bless you, Siam007. This is working for me. At least for the time being. Other maneuvers, mostly in the 'recycle everything' approach, seemed to work too but only for a while. Fingers crossed.

1 2 Previous Next