9 Replies Latest reply: Mar 7, 2012 11:33 PM by rsgl
RáNdÓm GéÉzÁ Level 2 Level 2 (195 points)

Since installing OSX Lion. My finder will not keep the preferences set, for example: "New Finder Window Opens" randomly reverts back to the home folder, even though time and agin I have set it to Applications.

 

I have deleted the plist and reset the parameters but again it keeps changing itself.

 

Any suggestions, anyone else experiencing this issue? Any help or advice would be appreciated... Thanks in advance.


MacBook Pro 17, Mac OS X (10.7.2),  2.8 GHz IC2D - 4G 1067 MHz DDr3 - 500G HD
  • Robert Sandhaus Level 1 Level 1 (5 points)

    Same here -- came looking for answer to this.

     

    Sandy

     

    OSX 10.7.2, 17" MBP (2009)

  • softwater Level 5 Level 5 (5,370 points)

    Did you do a restart or 'killall Finder' in terminal after you deleted the plist?

     

    If not, delete that plist file again, then open a Terminal session and type in

     

    killall Finder


    Then press 'Return' and try setting your prefs again.

  • RáNdÓm GéÉzÁ Level 2 Level 2 (195 points)

    Yes, I did relaunch Finder. Same results.

     

    I'm wondering if it's something to do with the model and make. I have the same MBP as Sandra.

  • RáNdÓm GéÉzÁ Level 2 Level 2 (195 points)

    I'm breathing life back into this thread, my reasons being...

     

    Since noticing the issue with Finder, other preference settings and their failure to save have now become apparent.

     

    As above, Finder will not save my preference of opening on Applications, it repeated deafults to Home Folder... no matter how many times I change it, save it, repair it, delete plist, attempt a terminal command etc.

     

    Another issue I noticed is my Dashboard clocks keep changing. Eg. I set it to London and I go back to it, and for some reason it shows Amsterdam...?

     

    And, a further issue that I noticed is the icons on Lauchpad, I set them and move them alphabetically so the order corresponds with my Applications list and everytime I go back they have moved.

     

    My OS is a clean install of Lion and, given that my partner also has a clean install of Lion on their machine and is suffering similar issues with preferences, I feel justified in presuming that this is a Lion issue and not my hardware.

     

    Anyone else experiencing the same, or do you have a fix for this...?

     

    Cheers.

  • softwater Level 5 Level 5 (5,370 points)

    RáNdÓm GéÉzÁ wrote:

     

    Another issue I noticed is my Dashboard clocks keep changing. Eg. I set it to London and I go back to it, and for some reason it shows Amsterdam...?

     

     

     

    Well, I had that issue even in SL. Have you tried unchecking this in System Prefs > Date & Time?

     

     

    location.png

  • RáNdÓm GéÉzÁ Level 2 Level 2 (195 points)

    Yes, My 'Auto Set Time' is unchecked as per your suggestion and has been for a few months now due to my moving about regularly...

     

    I'm stumped on this one at present...?

  • banksfromazusa Level 1 Level 1 (0 points)

    Has anyone figured this out?

     

    I've been experiencing the same issues on a Mac Pro 2 x 2.26 GHz Quad Core Intel Xeon for a long time now (ever since I installed Lion). I've tried all the tricks, even reinstalled Lion, and nothing worked.

     

    It's driving me nuts. Sometimes my settings reset randomly. But almost every time I reboot, all settings revert to the way they were when newly installed. It's only OSX related stuff. My apps and everything else retain settings.

  • RáNdÓm GéÉzÁ Level 2 Level 2 (195 points)

    Just to update on this; I still have the same issues. And it seems so random. Sometimes they stick other times they reset...?

     

    And it appears no fix or suggestions are available.

     

    I think we'll have to ride this one out until a time as a fix is available.

  • rsgl Level 1 Level 1 (0 points)

    I've been experiencing this issue too.

     

    The following appears to have solved it on one computer for me, but not on another:

     

    1. Open up Terminal (/Programs/Utilities/Terminal.app)

    2. Enter "chmod -RN ~/Library/Preferences" (without the quotation marks)

    3. Hit return.

     

    The above is taken from Mark23's post here:

    https://discussions.apple.com/thread/3219909?start=15&tstart=0