Previous 1 2 3 Next 41 Replies Latest reply: Jul 21, 2012 4:49 AM by ch4r1ie Go to original post
  • how12 Level 1 (0 points)

    I have the mobile documents folder, but in it I only have a pages and an iworks preview subfolder in the pages folder.


    I ahve tried placing it there byt the cync is not happening.


    What should I do?



  • stephen.bradley Level 1 (20 points)

    You're correct that right now none of the iWork programs support direct reading or writing from iCloud. I expect that will change soon when new versions are released that can directly read the file structure that iOS uses (right now the desktop and mobile versions use completely different file structures).


    In the meantime, the right way to do all this is by using the iWork web site. Go to, log in, click on iWork. Click on the Pages tab and drag your Pages (or Word) document into the browser. It will upload and be converted to iOS format where it will instantly appear on your iPad in Pages.


    If you make changes on the iPad, just go back to iCloud on your desktop and download the document. It will be converted to the desktop file structure automatically.


    All the talk about using the Mobile Documents folder to sync is interesting, but ultimately unecessary and as people have pointed out, frustrating if you edit documents on iOS, because of the difference in file structure. It works much better if you just use the website.


    The Mobile Docs folder can be useful to sync things not supported by iWork, say video files, which you can then access from your iDevice using a program like QuasiDisk

  • Gentry McColm Level 1 (10 points)

    Hello. Been using the drag and drop method for months, with no problem. Today, not working at all. I drag a pages file into icloud pages tab, and it immediately starts downloading what I am dragging in! Strange. It does not upload it at all. I have to go through the manual steps of uploading through the gear button at top right of page. Any help? Thanks.

  • iwork mac Level 1 (0 points)

    Hi Gentry McColm

    I had the same problem before, but it's Ok from the next day.

    Not sure why, but maybe just happen when apple doing maintainance on the icloud.

    Try again the next day.

  • tsattaba Level 1 (0 points)

    I hav the same problems with all of you . I must use Numbers file every day and will update my new data in old spreadsheet . I upload from my Mac to icloud and then to my ipad. when i update new data in ipad and then in icloud. when i back home , i must download from iclound and then save to my Mac to see spreadsheet .   . if i update new data in my Mac and then upload to icloud , it change my filename to ***1.numbers and then send to my ipad. That's mean my filename will change bored . i not understand why Apple not correct this problem ???

  • angrysnake Level 1 (0 points)

    Is there a fix to show the mobile documents folder? I have googled until my fingers bled. Nothing has worked.

  • iwork mac Level 1 (0 points)

    Hi Angrysnake

    You can try the way other people mentioned to go to mobile documents folder.

    If you are using the latest version, you won't see your document folder right away.

    You might need to use icloud for a week or so.

    And try again the library (hold the option key when you click Go on finder, you will see the library)

    And you should be able to see the mobile document folder.

    The reason to have the ****1 file name if you upload from mac to icloud is because you have a previous file uploaded and edited on ipad. Icloud will create ****1 for you incase your delette the file that you need with a same file name.

    It happened at mac too, not just icloud.

    ICloud happen more often as icloud need to talk to your mac mobile document. First even if you drap to icloud.

    It work very similar to mobile me when you have a local folder on your mac.

    If for some internet delay or icloud service delay. It will happen.

    As you will find when you upload document to icloud, it will show the icon only. Which tell you the document is last updated from mac.

    Once you edited on ipad or iphone, the document icon will change to the first page of the document to tell you its been edited.

    The new mountain might have a solution for this, but I dull it will be perfect due to 2 different software of iwork on mac and iwork on IOS.

    And as long as it need to go through cloud service, it will not be perfect for saving document avoiding ***1.

  • stephen.bradley Level 1 (20 points)

    It seems to appear when needed, but I haven't found a surefire way to trigger it's creation (creating it manually didn't cause it to populate with items). I have new installs of both 10.7 and 10.8 on my MBP. The 10.8 install has the directory, the 10.7 install does not, even though I've been using them in the same way.


    If you're looking for a syning soluton, this is not it. The reason Apple has you go through the website is so documents get converted on the way up and down - file structure is different between the iOS version and OSX version of most documents. If you're using iCloud to get docs to and from iOS, the website is the most reliable method. If you're trying to sync multiple computers, Dropbox/Sugarsync are the most reliable methods. They're just as free (more free actually, since you can earn extra free space), and so much more reliable because that's what they were made to do!


    There's also no guarantee Apple will continue to use this method of syncing, so why start getting used to it?


    In a few months 10.8 will be out, and it allows desktop apps to save and load directly from iCloud via standard dialog boxes. The data is still restricted to the app that uploaded it though (so far), so it's still not a "sync all my docs and access them from anywhere" solution, but if you work only in iCloud enabled apps, it could be a complete solution for you. If you need easy folder or file sharing or want to use the same document across multiple apps (say, a JPG file) you're still going to be better off with Sugarsync, iCloud has none of those features.

  • angrysnake Level 1 (0 points)

    Hello iwork mac.

    I have gone to the library folder. Both manually anf by terminal to always show library folder. The mobile documnets does not exist. I tried signing out, restart and signing in restart. I tried making the folder. It will still not populate. I even deleted the 09 numbers and bought the version from the app store. I upgraded to Lion just to have the feature. I regularly start spread sheets on imac and then finish them in the "feild" on the iPad and vise versa. So I begain to question why did I even bother upgrding to Lion? I am not finding any features in Lion that are an improvement. The mail app included in Lion give me frustation every day. SL mail worked so much better for me.

    Thanks for the reply.

  • stephen.bradley Level 1 (20 points)


    Listen, do NOT WORRY about the Mobile Documents directory. That is NOT the correct way to be syncing docs to your iPad. Just use the iCloud website. The Mobile Documents folder will create itself if it's needed. The reason why it's in a hidden folder is because it isn't the intended way of using the service.


    Start your document in Numbers. Go to and upload it. It will appear on your iPad. Edit it, save it. Back at your computer, you can go to and download it again.


    Instead of frustrating yourself trying to make the unapproved workaround function for you, just do it the normal way and it works fine. I do it several times a week.


    The iOS Numbers and OSX Numbers use different file formats, so once you edit the file on your iPad, you wouldn't be able to just go grab it out of Mobile Documents and use it anyway. Sending it through ensures that it is converted to the proper format for OS X during download.

  • innerwealth77 Level 1 (0 points)

    Hey guys, this is a long thread but there's a really easy fix, just work on the keynote - pages - numbers, go to itunes, click the device - ipad etc - then click apps, then find the app and click add. Sure, it's not synch and it could be better but this way, your desktop latest version can be sent to the mobile device, worked on and then sent via icloud back to your desktop computer... once you work on a file on the desktop you're basically sending the latest version out to the mobile world the only downside is that the mobile device needs to be in sych range of itunes desktop ... but with a phone etc .. it's easy and works just great

  • ch4r1ie Level 1 (0 points)

    This is a long thread so can't remember if this has been mentioned.  To find your hidden library, click on the 'Go' menu in Finder, hold down the 'alt/option' button and the library appears.  Then follow the original instructions to find your Mobile Documents folder - worked for me.


    However, whilst documents created on my mac upload properly to icloud & appear instantly on my iPhone (albeit in a different format - it asks whether you want to change the format to iOS or open a copy) and you can work with them, it doesn't work the other way - I cannot download useable full documents from iCloud to my mac - I only get previews of those from my iPhone on my mac, which are useless.


    I'll try the online uploading via the web or Dropbox.  Shame it isn't "seemless" as Apple claim.

Previous 1 2 3 Next