Skip navigation

WiFi keeps dropping after iOS 5 upgrade

3626 Views 11 Replies Latest reply: Jan 24, 2013 4:20 PM by drewcur RSS
riversen Level 3 Level 3 (675 points)
Currently Being Moderated
Oct 15, 2011 5:48 AM

We are really frustrated.  We upgraded the iPad 1 along with a bunch of Apple products to iOS 5 and they keep dropping the internet.  We reset the router and the phone, iPod, and iPad to no avail.  Has anyone else experienced this?

iPad 64GB 3G and iPhone 4 32GB Black using Shure SE420 earbuds, Windows 7, ASIs N53JQ 8540p i7 processor
  • techipaduser Calculating status...
    Currently Being Moderated
    Oct 18, 2011 7:50 AM (in response to riversen)

    I've got the same problem with the ipad 2.  everything was fine before iOS5 upgrade.

  • techipaduser Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2011 5:03 AM (in response to riversen)

    I've found a fix to my issue.  I switched the security from WPA TKIP to AES on my router and since then it's been rock solid with the ipad 2 and iphone 4.  Hope this helps others fix there issue also with the wifi constantly dropping connection.

  • SharatM Calculating status...
    Currently Being Moderated
    Oct 21, 2011 3:06 AM (in response to techipaduser)

    Changing the security can be considered as a temporary workaround..but is there a real fix for this?

  • simon231 Calculating status...
    Currently Being Moderated
    Oct 24, 2011 2:31 PM (in response to riversen)

    I'm also having connection problems since updating iPhone 3GS, iPhone 4 and iPad1 that we have... all of them now have wi-fi connection problems and I'm having bluetooth connection problems on the iPhone 3GS.

     

    Reassured to see on these forums that I'm clearly not alone.

     

    But doesn't seem to be a solution except I see someone has suggested changing the security settings from WPA TKIP to AES. 

  • NSDrT Calculating status...
    Currently Being Moderated
    Oct 28, 2011 6:26 PM (in response to simon231)

    what is AES (my time capsule options are WPA2 personal and WPA2 ENTERPRISE or WPA/2WPA)?  I Have similar issues since iOS5 upgrade.  Have 3rd Gen Time capsule plus AE to extend network.  Iphone 4 upgraded to iOS5 and new iphone 4S.  Even read I should change DNS to 208.67.222.222 which seemed to correct problem for about 48 hours, now back to reseting network every 24 hours!  Terrible!!!!

  • tim164 Calculating status...
    Currently Being Moderated
    Oct 28, 2011 6:43 PM (in response to riversen)

    just updated today and now can't connect to my wireless.  My laptop connects just fine.  The ipad says i am connected, but i'm not.  I have tried forgeting the connection and reconnecting but it does not work.  AARRGGHH

  • mszypko Calculating status...
    Currently Being Moderated
    Nov 17, 2011 1:01 PM (in response to riversen)

    Changing the router settings doesnt really help if you travel a lot.  I connect through wifi at my hotel often, especially when travelling internationally to keep the data costs down.  Since the OS5 upgrade, my beloved iPhone is nothing more than a paperweight outside of the country!!! 

  • mszypko Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 17, 2011 6:51 PM (in response to mszypko)

    UPDATE......Called tech support and they essentially told me that the issue was with my router .... even though it happened not only with my home router, but also with the router at 2 airports and 2 hotels.  Guess we have to fix a whole lot of routers out there.

     

    After I convinced them that the this could not be the case they gave me the number of a local Apple store ( I am travelling on business) of course I called the number given and got a recorded message that "you have dialed an unassigned Apple telephone number".   GREAT!!! So I quickly called Apple tech support and lo and behold they were closed for the evening (9PM eastern US time).

     

    So I leave for the airport tomorrow AM back home and it looks like my Saturday morning will be spent at the Apple store near home before I leave on an international business trip Saturday afternoon!  Maybe I can take a picture of myself and send it to my wife!!

     

    This is ridiculous.  Support tells me how sorry they are.... but are they really? 

     

    Glad I upgraded the OS 5 update.... NOT!!!!  Of course they will not admit there is a problem.  I mentioned that I have seen a number of folks that seem to have an issue on the discussion boards.  The support guy tells me that he doesnt read the boards since he is too busy handling customer issues.  This is how we handle issues????  Maybe they should spend some time reading the discussion boards!!

     

    Sorry for the rant, but yes I am upset.  If someone from Apple is actually paying attention and actually cares, let me know.,  Happy to post a retraction.  In the meantime I am carrying my Apple iPaperweight!!!

  • bobsil1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 27, 2011 3:42 PM (in response to riversen)

    Worked around this iOS 5 bug by downgrading router from WPA2 Personal to WEP encryption. WiFi connections now stable.

     

    Network config is D-Link router used as WAP with routing turned off, connected via wire to TPLink router, connected to cable modem. Symptoms were iPhone 4S, iPhone 4, iPad 2, iPad losing WiFi connection every 5-10 minutes even though physically close to router, while Android, Windows and OS X clients worked fine.

  • RockM66 Calculating status...
    Currently Being Moderated
    Jan 20, 2012 1:40 PM (in response to bobsil1)

    In my case the WiFi remains connected, but somehow network traffic comes to a halt

    every minute or so for 10-30 seconds, rendering my iPad2 pretty useless. My details:

     

    * I have an iPad 2 running iOS 5.0.1.

     

    * My wireless router is a Motorola SBG6580 router/modem.

     

    * I had no WiFi problems until after the iOS 5.0.1 upgrade from iOS 4

     

    * I have no problems with other wireless devices

     

    * I used the "IT Tools" App on my iPad2 to test the network connection.

    When pinging an IP address other than

    my router, such as one of my ISP (Charter) DNS

    servers, or a domain name such as google.com,

    the ping test works normally for about a minute (about 40ms response every second).

    After that the ping test gets no reponse for 10-30 seconds and

    then goes back to normal. This repeats:

    the per second ping test fails every minute or so for 10-30 seconds

    (which is catastrophic for this device). I tried this for 10

    minutes at a time. Overall loss is around 40% for the ping test.

     

    * I did the same test using "IT Tools" with my router's IP address

    and all the results were normal, showing that the WiFi remains

    connected (the wifi icon was also at full strength (4 "bars")

    throughout these tests).

     

    * I tried using alternative DNS addresses (like OpenDNS) to no avail which is

    not surprising given the ping results.

     

    * In regular practice things like Safari constantly stall.

     

    * I used PingPlotter on my laptop to do the same ping test,

    all results were normal on the laptop, so it's not the router.

     

    * On my router I disabled all encryption, n-mode, and WMM support to no avail.

     

    * I tried using Settings/General/Reset/Reset Network Settings

    on the iPad to no avail.

     

    * I tried disabling as many network-related things as I could

    find on the iPad, including bluetooth, iCloud, e-mail checks, etc.

    This did not work.

     

    In summary my iPad2 is pretty useless after upgrading to iOS 5, which

    is probably due to a bug in the iOS network software.

     

    Can anyone reproduce the ping results?

  • drewcur Calculating status...
    Currently Being Moderated
    Jan 24, 2013 4:20 PM (in response to RockM66)

    Hopefully if anyone with Motorola SBG6580 router is experiencing something similar to this (mine happened from iOS 5 to iOS 6, login to the modem and turn off the firewall. That did the trick for me.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.