3 Replies Latest reply: Oct 16, 2011 6:59 PM by BDAqua
shannonadams Level 1 Level 1 (0 points)

Trouble with DNS when connecting using Mac VPN client.

 

Our VPN access is setup on a Cisco ASA 5510 firewall.  When using Snow Leopard's built-tin VPN client, DNS is not being pulled correctly from the firewall. It connects fine, ssh/telnet and browsing to specific IP addresses works, but DNS does not.   VPN connections via Cisco VPN client (Mac and Windows) going through firewall is pulling DNS from 10.9.10.191 correctly.  VPN connections via built-in Mac OS VPN client using local IP gateway for DNS and not pulling from 10.9.10.191.  Any suggestions?  Is this a problem on the SL end of something in the firewall settings?  I suspect it is a built-in VPN client issue on the Mac since it works fine using the Cisco VPN client in Windows and Mac OS X.  Thanks for any help.


MacBook Pro 15", Mac OS X (10.6.5)
  • BDAqua Level 10 Level 10 (120,660 points)

    Have you tried adding 10.9.10.191 to the DNS list for the interface you're using in the Network pref pane, highlight Interface>Advanced button>DNS tab>little + icon.

  • shannonadams Level 1 Level 1 (0 points)

    Would that be the interface (in this case, Ethernet) I am using to connect to the Internet or the VPN interface that I need to add the DNS server (10.9.10.191)?  I added it to the VPN interface DNS list, but it still doesn't work.

     

    Screen shot 2011-10-16 at 8.30.55 PM.png

  • BDAqua Level 10 Level 10 (120,660 points)

    Sorry Shannon, that is what I was recommending, but no exprience with Cisco, I'd personally still think that should work, hopefully we'll get more helpers in on this.

     

    Just wonedring, perhaps the DNS Caches need flushing!?

     

    How to Flush DNS in Mac OSX using Terminal...

     

    In Mac OSX Leopard, you can use the command dnscacheutil -flushcache to flush the DNS resolver cache:

     

    dnscacheutil -flushcache

     

    In Mac OSX versions 10.5.1 and before, the command lookupd -flushcache performed the same task:

     

    lookupd -flushcache