Previous 1 2 3 Next 43 Replies Latest reply: May 12, 2012 6:47 AM by CPTodd Go to original post
  • kjullion Level 1 (0 points)

    Same problem here.  I can be sitting and reading a blog and while reading the WiFi connection will go from 3 bars, down to 2, down to 1 and then flip over to 3G (i.e. no WiFi).  Very annoying...then I can go out of Safari into Settings and just by staying on the Settings screen for a few minutes my WiFi connection will re-establish itself, but it won't re-establish unless I go into the Settings screen.


    C'mon Apple...what's up with this?

  • rs1n Level 1 (30 points)

    Has anyone here tried resetting their network settings (on their iPhone, not router)?

  • BigMcGuire Level 1 (0 points)

    Yes, I tried resetting network settings and it didn't help me at all. But here is what did - see my last post here:


    I've come to the conclusion that it was my Verizon Fios router that was causing the problems as at work/parent's house/college I have 0 problems with WiFi - just at my house. After fiddling around with some settings (as you see in the post on that thread) I now have WiFi at home without a problem. Either restarting the router or setting it not to change channels was the trick.


    But it seems like there are various problems so my issue may not be related to this particular thread. I've never had a problem with my WiFi dropping connection, just not having internet access while having WiFi.

  • Neetsie1 Level 1 (0 points)

    I live in an average size 2 bedroom flat. My router is in the lounge and my iPhone 4s drops out when I move out of that room! Currently in bedroom posting this via 3G (which isn't particularly fast despite NOTHING being changed on my phone plan other than the phone!).


    I have not had this issue with my previous 3Gs, 3G or 2G for that matter (all of which have had remarkably better battery life compared with this 2 day old phone). And it doesn't appear with the router as my iPad 1 will connect anywhere in or outside of the flat. Is it just OS5 (iPad OS has cobwebs - long time since I've plugged that in for an update!) or is it the phone itself? And besides throwing it against a hard surface (preferably concrete driveway 2 storeys below), is there any fix?!

  • Friedeggman Level 1 (0 points)

    4S came today. So excited - but same exact problem - jumping in and out of the network. Should I return the phone? My old 3G still picks it up fine, so I know it is not a problem with the network.

  • waditz Level 1 (0 points)

    saw this on another thread and it worked for me




    (I did a "forget" of all my networks and started from scratch.  So far things have been stable.  Two networks that I used for test purposes at work had the same password.  Not sure if that caused an issue or conflict.  I can't imagine why it would as the SSIDs were different.


    Anyway, I haven't noticed any problems since yesterday.)

  • Willbilly Level 1 (0 points)

    I have had my 4s since November 5th, with no problems until last night.  It froze-up for about 10 minutes, so I plugged it into itunes and reset it to factory settings.  It worked great after that until now... I am at work and the wifw is not accepting the PW no matter what; turning the phone off, reseting the networks, reseting the router, switching the chan..., nothing. 


    What hope is there?!!

  • Willbilly Level 1 (0 points)

    I have no idea what happened, but the wifi is back...  All i did was plug it back into itunes and its working again...

  • Richard Caughlan Level 2 (165 points)

    I have had this happen but usually forgetting the network then re-entering the password fixes it.  Unfortunately, I must report back here that the Wifi is by no means stable.  Just when I think it is, it drops again.  Such a pain.  After 4 years, it's now come to this.  Why is it ALWAYS something? 

  • Piter_271 Level 1 (0 points)

    Login to your Access Point and switch off all params related to 802.11 n-mode

  • karenfromruncorn Level 1 (0 points)

    I have the exact problem you have.  Have you got a fix from Apple for this? I have already almost used all my data for this month before I even noticed the problem.  I suspect my problem started after I ran the last update about a month ago.  I love my iphone but this is driving me nuts!

  • psw249 Level 1 (0 points)

    I did not notice the issue until my data was getting throttled back by AT&T for excessive data use. Oddly enough I have their "unlimited" plan. (search "Spaccarelli vs ATT" for more on that issue) After much searching and arguing with AT&T (who also provides my internet service) and Apple Support, it looks like that dispite the fact that both companies are aware of the issue, AT&T does not care and will charge you for going over your data limit (or throttle the speed down to the point everything times out and nothing works) regardless of the issue being out of the customers control and a result of a defective operating system that they sell; and Apple Support either states they are aware of the issue and are working on it, or claim that there is no issue and its a defective phone. Funny thing is that I restored my OS to 4.3 and the issue was resolved. When I put 5.1 back on the phone, the issue returned. I'd say that rules out a hardware issue!

  • jada22 Level 1 (0 points)

    I had the same problem twice after a power outage. I went to check the settings on the router and did these three things and it took care of it. The router time was off compared to the pc, so I selected to manually set it to the same. I changed the network name with just adding an additonal letter and then changed the preshared key password. It worked both times. This situation was when both iphone 4s and laptop wireless quick working the same time. Hope this helps somehow.

  • CPTodd Level 1 (100 points)

    I have this same problem with my iPhone 4. I too have the same setup as you (average two bedroom) and my iPad will connect to the router (and another one in the area that is unsecured) but the iPhone will be able to connect to my router when I am in teh same room with it but when I go to the bedroom I go to 3G (It also can't see the unsecured network that my iPad and computer can see). Not sure what is going on but it is a problem.  Oh and the same thing happens when I am at my mother's house as well.

Previous 1 2 3 Next