Skip navigation

iMessages not syncing to iPad 2

1909 Views 9 Replies Latest reply: Aug 15, 2012 6:06 AM by bonzabuy RSS
leanderuk Calculating status...
Currently Being Moderated
Oct 15, 2011 7:45 AM

Having a problem with my iPad 2 and iMessage.

 

iMessage seems to be working fine on my iPhone 4, but the messages arent appearing on my iPad 2.

 

Both devices have iMessage setup with the same apple id, the iphone 4 has recieve at the email and mobile number and the iPad has recieve at the email address.

 

If i start a conversaton with someone from my iPad the messages mostly appear on the iPad, but if i start the conversation on the iPhone nothing appears on the iPad.

 

Its very confusing, im assuming its a big with apples side unless anyone knows anything different or has any ideas?

Mac OS X (10.7.1)
  • rbbcpa Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 15, 2011 6:28 PM (in response to leanderuk)

    Apple's much-anticipated iOS5 has a lot of cool features, one of which is the iMessage platform.  What I've discovered is a lot of confusion among the masses on how this platform works.  I, myself, have been confused on how to set this up so that I can maintain iMessage convos on both my iPad2 and iPhone.  Last night, I set out to figure this all out and post my findings here.  What I am about to outline has worked for me and I feel is the way Apple intended it to work.  For good or bad, I don't plan to discuss the merits of how Apple has designed this platform.  I am simply sharing what has worked for me.

     

    In order for me to test my theories I used my iPad 2, iPhone 4S and my wife's iPad and iPhone 4.  This allowed me to test the iMessage platform as if I were messaging one of my contacts who I know had installed iOS5 but theoretically doesn't live under my roof, so to speak.  My example will center around my particular situation:  someone who has both an iPad (or other non-iPhone device) and an iPhone 4S (or 4 or 3GS) AND wants to keep iMessage convos in sync across all my devices.  After all, this is one of the main benefits of iMessage that Apple touts.

     

    First and foremost, it is important to activate iMessage on all your iOS5 devices using the same Apple ID.  This will "link" all your iOS5 devices in the Apple ecosystem and keep convos you initiate in sync across your iOS5 devices.  Some of you may run into a situation like I did where our PRIMARY Apple ID is the one we use as a family to purchase music, apps, etc.  In the case of iMessage, every family member should have their own unique Apple ID (a secondary ID to your primary ID) to use on their own iOS5 devices.  This will keep all your iMessages separate and distinct from other family members' iMessage convos.  The next important setting, and the one that causes a lot of confusion, is the "Receive At" setting.  On your iPhone this is your cell phone number, by default.  You will also want to add an e-mail address as another "Receive At" location.  If you have an iPad or other non-iPhone iOS5 device, you will want to choose an e-mail address (on my devices my Apple ID is the same as my e-mail address I am using on the "Receive At" setting) as your "Receive At" setting.  The important thing to note is that if you have both an iPhone and iPad (or any other non-iPhone device) you will want to use the same e-mail address on both devices.  This will help keep your convos that others have initiated to you in sync across your iOS5 devices.  Finally, the Caller ID is the next setting to consider.  You have two options here:  (1) your cell number, or (2) the e-mail address you entered in the step above.  Your choice depends on how you want others to see your contact info and whether or not keeping convos in sync across your iOS5 devices is important.  My example below will illustrate this.

     

    EXAMPLE:

    Keeping messages in sync across my devices is important so I have provided my Apple ID that I used above to all my contacts who use iOS5 devices and I have asked them to use this to iMessage me.  This is the only way that an iMessage convo initiated by one of your contacts to you will stay in sync across all your iOS5 devices.  If they use your cell number, then the iMessage convo will only show up on your iPhone.  Even though the Apple ID you used to activate iMessage in the Apple ecosystem links your devices, a reply from your iPhone to an iMessage sent only to your cell phone will not "push" the reply to your non-iPhone device.  Long story short, give all your iOS5 contacts the e-mail address you entered above in the "Receive At" setting and all your convos will stay in sync.  This is very similar to the BlackBerry Messenger protocol and the PIN that BBM users need to provide other BBM users so they can message each other.


    I commandeered my wife's iPad and iPhone and began sending iMessages back and forth between my and her devices.  Step 1, I sent an iMessage from my iPad 2 to her cell number.  Because I initiated the iMessage to my wife and my devices were both activated in the Apple ecosystem using my Apple ID, the convo appeared on both my iPad and iPhone but she received my iMessage on her iPhone but NOT her iPad.  This is because her iPad is connected to the iMessage platform through her "Receive At" email address; there is no "link" between her iPhone cell number and her iPad.  When she responded to my iMessage, the convo continued to appear only on her iPhone but appears on both my iPad 2 and iPhone.  Step 2, I sent her an iMessage to her "Receive At" email address and she received the message on both her devices.  As in the first scenario, the convo appears on both of my devices.  At this point, because I used her "Receive At" email address, the convo is in sync on both of her devices. Here is an important tip:  when you type in a contact name on the "To:" line of an iMessage, their available iMessage "Receive At" email addresses and cell phone number will appear with a little blue balloon next to them.  The opposite of the above occurred when my wife initiated the iMessages to me as described in Step 1 and Step 2.

     

    In summary:

    First, make sure you activate iMessage on all your devices using your unique Apple ID.  This links your devices in the Apple iMessage ecosystem.  Second, choose a "Receive At" email address that you can provide to your contacts that use iOS5 so that convos that they initiate to you will be in sync across your iOS5 devices.  Lastly, I recommend setting your Caller ID to your "Receive At" email address.  This will prompt any users that don't have your "Receive At" email address to add it to their contacts.  It may go without saying, but if your iOS5 contacts have multiple iOS5 devices and they are interested in keeping their convos in sync across their devices they will have to provide you their "Receive At" email address as their preferred iMessage contact.

     

    Hope this helps.

  • JawnU Calculating status...
    Currently Being Moderated
    Oct 16, 2011 8:13 AM (in response to rbbcpa)

    Thanks for the info rbbcpa. I finally got iMessage to sync. It seems Apple should be able to cross reference phone numbers and Apple ID's to make the whole process "just work".

  • rbbcpa Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2011 11:30 AM (in response to JawnU)

    I agree.  Apple may have taken this approach to focus on the "Receive At" email address as the "link" since email addresses don't change as often as a cell number might but in this day, cell numbers can easily be ported from one carrier to another.  Cross-referencing on a cell number seems logical.

  • uesjd Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 22, 2011 2:52 PM (in response to rbbcpa)

    rbbcpa wrote:

     

     


    EXAMPLE:

    Keeping messages in sync across my devices is important so I have provided my Apple ID that I used above to all my contacts who use iOS5 devices and I have asked them to use this to iMessage me.  This is the only way that an iMessage convo initiated by one of your contacts to you will stay in sync across all your iOS5 devices. If they use your cell number, then the iMessage convo will only show up on your iPhone.  Even though the Apple ID you used to activate iMessage in the Apple ecosystem links your devices, a reply from your iPhone to an iMessage sent only to your cell phone will not "push" the reply to your non-iPhone device.  Long story short, give all your iOS5 contacts the e-mail address you entered above in the "Receive At" setting and all your convos will stay in sync.  This is very similar to the BlackBerry Messenger protocol and the PIN that BBM users need to provide other BBM users so they can message each other.



     

    I experienced this phenomenon this morning (someone iMessaged me using my cell phone number and the convo showed up only on my iPhone, not the iPad) and it puzzled me. It's reassuring to know that it works that way for everyone else. However, do we know for certain that this is how Apple intends for it to work?  That is, is there a possibility that even in this situation, the convo is supposed to appear on all devices using the same Apple ID but for some reason (e.g., a bug in iOS 5.0) it does not when a message is initiated by directing an iMessage to a cell phone number?

    iPhone 4, iOS 5, Win 7 64-bit
  • sdailey874 Calculating status...
    Currently Being Moderated
    May 8, 2012 7:39 PM (in response to uesjd)

    I'm having this same problem.  Sure wish Apple would address this issue.

  • saifulfromca Calculating status...
    Currently Being Moderated
    May 9, 2012 2:31 AM (in response to leanderuk)

    Go to your iPhone/settings/messages/receive At/Add Email.

    Now all your devices with your email address will receive imessages.

    iPhone will receive messages via both mobile phone number or email address.

  • gawgagirl Calculating status...
    Currently Being Moderated
    May 16, 2012 10:51 AM (in response to saifulfromca)

    I had all of this set up correctly and all imessages were syncing until I updated to 5.1.1 a couple of weeks ago.  Now no imessages show up on my ipad unless I start the imessage on my ipad.

  • bonzabuy Calculating status...
    Currently Being Moderated
    Aug 15, 2012 6:06 AM (in response to saifulfromca)

    As rbbcpa stated this does not make the message show up in imessage on ipad or Mac (Mountain Lion) if someone else starts the conversation by sending a message to your mobile number.

     

    I find this most annoying as I do not want to use my email as caller ID for privacy reasons but most people who text me do it to my mobile number. Even my wifes messages only show up on my phone despite the fact they are imessages.

     

    The one thing I have not tried is deleting the conversation threads - which I will try now...

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.