10 Replies Latest reply: Aug 2, 2013 2:05 PM by Technosorceror
jadeiijr Level 1 Level 1 (0 points)

I downloaded and installed ios5 to my iphone 4 successfully.  Then I went through all the apps on my phone and there were more than 50% apps missing.  Then I went back into iTunes and realized that they were there to dl again, which I did.  Now I'm stuck at syncing my phone with iTunes with all the re-downloaded apps.  I'm stuck at the message that says "Waiting for changes to be applied".  I've already ejected my iPhone once to restart, but same message from iTunes.  It has already been 8 hours being stuck at the same message from iTunes.  What should I do?  Any suggestions?


iPhone 4, iOS 5
  • jadeiijr Level 1 Level 1 (0 points)

    Okay. Solved my own problem. On iTunes, I clicked sync videos and photos off. And I also did a hard reset on my iPhone 4. And voila!!! It worked. Hope it works for you too. I'm so happy with ios5.

  • Pilates-Contrology Level 1 Level 1 (35 points)

    Please try this. Worked for me:

     

    1. Quit iTunes.

     

    2. Start Menu -> All Programs -> Accessories -> Right Click "Command Prompt" -> "Run as Administrator"

     

    3. In the command prompt type "netsh winsock reset" and hit ENTER.

     

    4. Reboot your machine.

     

    5. Restart iTunes.

  • loulou123 Level 1 Level 1 (0 points)

    I hope this helps as it sure solved my problem.  After restores, and reinstalling itunes (none of which worked), it occurred to me that we have two user accounts on our computer - my account and my husband's.  I was on my husband's side and my original install for the ipod was on my side.  You must be on the user account where you originally installed the ipod and store your music, apps, etc.  I got it all back by being on the right side (after numerous hours of useless trials).  I also was receiving the error message that the pairing record was missing.  Everything is back in order now!!!

  • msaxman Level 1 Level 1 (0 points)

    I am having the same issue but I tried everything suggested here and nothing has resolved it.  It still sits there saying "Waiting for changes to be applied", and nothing happens.  Please help!!

  • lauprellim Level 1 Level 1 (0 points)

    Same problem....OS lion and iphone OS 5, phone version is 3gs.  It gets stuck on "Step 6 of 6: Waiting for changes to be applied".

     

    I really hope Apple fixes this !!!

  • AndyLeesES Level 1 Level 1 (0 points)

    The actual issue seems to be the iPhone blocking the sync due to apps running in the background. I had this same issue (and can recreate it by leaving 'Settings' running).

     

    To fix: (I'll keep it simple)

     

    Press Home button twice quickly.

    Press and hold a running app.

    When the red minus sign appears simply press, close them all.

     

    Then sync with iTunes. It seems the phone blocks access.

     

    Hope this works for you all.

  • Gaviotica2011 Level 1 Level 1 (0 points)

    Hi AndyLeesES, I tried your solution but didn't work for me, it's still stuck at step 6 of 6 I have an iTouch 4th gen with iOS 5 and a MBP, I haven't had this issue until three days ago, and I already have downloaded iOS5.

    I hope Apple can answer this and give us a solution...

  • J_a_me_s Level 1 Level 1 (0 points)

    I tried this while it was stuck for 1 hour. After trying this it just simply continued with the sync. Excellent

     

    iPhone 4, iOS 5, Lion

  • Shubes Level 1 Level 1 (0 points)

    4th Gen iPod Touch started experiencing this recently; the solution that worked for me was to connect the iPod to iTunes, but CANCEL the sync after it starts. (Make sure the Sync has completely stopped in iTunes AND the device.)

     

    Once you've cancelled the sync, right-click your device in iTunes, then select "Transfer Purchases"; once this step completes, then click on "Sync" and let your device run a full sync with iTunes.

     

    Worked for me; seems there was one little application (Fancy Pants Lite) that wasn't transferring from the iPod Touch over to iTunes. Adding that extra step ("Transfer Purchases") seemed to bump the transfer process, and fixed the "Waiting for changes to be applied..." problem.

     

    Hope this helps.

  • Technosorceror Level 1 Level 1 (0 points)

    WAS having this trouble with Itouch3 and 5.1.1 I tried restoring from backups and as a new device, both locked up. Regardless of whether you want to restore as new device or backup, go through the process (the fastest way is to use the IOS you downloaded already by holding shift and left mouse button on Restore button on Itunes device summary page in (windows) and selecting the latest IOS from [C:\Documents and Settings\admin\Application Data\Apple Computer\iTunes\iPod Software Updates] 'admin' is the user that installed itunes, confirm restore.When itunes gets done wiping, reloading the IOS and is asking if you want to use New Device or Restore from backup, that's where you pick up the device and run through all the questions it has regarding logging into wifi, tou, using icloud (I chose no on cloud) and logging into apple with your itunes account. When all the questions are answered and your device is on it's home page looking like it's done, hit home twice to bring up running apps, settings is probably there, hit the red x on it, home button to get back to home page, repeat to make sure apps are shut down, NOW you are ready to proceed with itunes. Now you can choose restore as new or use backup from computer. I think the trouble is that now you can supposedly restore your iwhatever from the cloud with no computer, on the touch it seems to set device to do just that and it conflicts with the itunes restoration. This place should be able to send me email if there is something that didn't make sense. Hope this helps.