4 Replies Latest reply: Jun 11, 2015 3:16 AM by Pistonstone
jeremie_rtw Level 1 (0 points)

Hello all,


I have searched teh forum and found a few similar threads but I believe my case is different.


For all 3 of my SD cards, they appear as read-only in my MBP (running 10.6.8), whether I connect them via the built-in card reader or via my camera (Panasonic GF1) hooked up to my MBP via USB.


I used to be able to import photos into iPhoto and then delete them from the card but this does not work any more (I do not even get prompted any more) as the card(s) is now read-only (Get Info tells me "Sharing & Permissions: You can only read"). Indeed if I try to delete, drag and drop a file onto it or even erase from disk utility, it will not let me.


Now, most threads dealing with this issue point to the card reader being faulty (or even the lock switch being in the wrong position). I am fairly sure this is not the case here as:

1) the behaviour occurs both through the built-in card-reader and the camera connection and

2) the camera does not "think" that the card is read-only, it can take new pictures, delete or format the card (note that I tried to "lock" the card with the switch and in that case the camera complains and cannot do anything with the card).


Moreover this occurs with all three cards.

On the other hand, my IPhone connected via USB is not locked to "read-only" (for example IPhoto asks me and does delete photos after import).


Thanks very much for any help on this - this is very puzzling!

  • jeremie_rtw Level 1 (0 points)

    By the way - I am running 10.6.8 and nothing major was changed since last time I was able to delete photos from the card.

  • DerekCan Level 1 (0 points)

    I have a PNY MicroSD - the card MUST be locked to read/write.  Unlocked means you can only read.

  • CharliePryor Level 1 (5 points)

    If you are using a DSLR camera, like for example a Canon 60D, there may be an option to use a "Low-Level Formatting" on the card. This should make it writable when putting it into the computer.


    To test this (and confirm it works) I did the following:


    Hardware Used:


    Canon 60D camera body

    Sandisk 32GB SDHC Extreme Card

    Macbook Pro 15" (mid 2010 model) with built-in SD card slot.




    Place SDHC card into camera (SD card may work as well). Navigate through menu until you arrive at settings that allow the camera to format the card. There may be an option to format it "low-level", which you would then select.

    -Note that all files on card will be erased permanently.-


    After the camera formats, eject the card from the camera, and place inside the built-in SD slot on the Macbook.


    The card should automatically mount, containing both read and write priviledges.


    Hope that helps.



    Owner/Founder HotTips! LLC


  • Pistonstone Level 1 (0 points)

    Some interesting answers on here but before i began to stab needles into my reader slot i thought i better try something less physical. My card will only read on my macbookpro 10.10.3, this happens intermittantly. putting the lock switch half way made it read and write (unless it was pure chance) but i still couldnt format the card. I eventually put it in an iMac  10.6.8 and erased it. it didnt work in my macbookpro until i worked my way through the options in disk utility (on iMac) to the 7 pass erase. now my card works as normal in the macbookpro reader slot. I dont know if this issue has anything to do with the fact that it was formatted in a camera (Sony NX5), but its very frustrating as i do not want to rely on other peoples computers for basic tasks such as this!