Previous 1 2 Next 26 Replies Latest reply: Jul 14, 2014 7:11 PM by whiskeywilly
sandun Level 1 (0 points)



I preordered two iPhone 4S units - a black 32G and a white 16G, received both units yesterday (Oct 14).


The black unit is fine.  Issue is on the white 16G unit.


The white 16G unit did not have any battery charge out of the box. So we had to charge it so it would atleast power on. (the black unit had partial charge). Going through the setup, it asks for the WiFi info. I can see the available networks, I choose mine (home) SSID, enter the WPA (personal) key.  After doing this, I get the "Unable to join the network" error. I tried this a number of times and was not successful.  Eventually, I decided to setup/configure by connecting the unit to iTunes directly. (I am upgrading from  3GS).


After the intitial setup (and restore of a 3GS backup) + activation, I tried the join the my local home Wifi (out of a Dlink DIR 655). I still get the "Unable to join the network" message.  I also get the same message if I try to join a unprotected network.


Things I have tried so far (and still not successfull in getting this issue resolved):


- Rebooting the router (DLink 655)

- Change the router channel from "auto" to 11.

- On the iPhone: "Forget this network" and attempt to rejoin.

- Rebooted the iPhone 4S (countless times)

- Reset the iPhone Network configuration (again countless times)

- Connect to an unprotected network. (in addition to a WPA).


What currently works on WiFi at home: all othe wifi devices - two 3GS units, a different 4S unit, iPad2, a MBP,  ATV2, a Logitech audio streamer.


Only this white iPhone 4S is giving me issues.


When I called Apple, the automated phone (as well as the online express support) states that I need to purchase an incident support. (really?).  Either case, the automated response told me to call back later as no one was available today (Sat).  (I was not able to purchase AppleCare+ for my preorder yesterday - due to technical glitches on AT&T and/or Apple. I have to call back on Monday to continue with the purchase; I have a case#  for it).


Has anyone else had issues with the iPhone 4S (I know, it just over 24 hrs) and wifi connectivity? If so, did you find a solution?



iPhone 4, iOS 5
  • GeorgeH17 Level 1 (0 points)

    Wow what you have already done, should have fixed the problem.  Another thing to try is going into settings, general, reset, reset network settings.  If that doesnt work, try doing a hard reset.  Hold down the home button and the sleep button on the top at the same time till the apple symbol shows up on the screen.

  • sandun Level 1 (0 points)

    Thanks for the suggestions. I had previously tried the network reset (no luck). Just tried it again along with the hard resets.  I also tried a couple of different wifi routers (access points). Still get the same error message.


    I suspect this could be a iPhone 4S hardware issue (that managed to pass through QA). Looks like I may have to take into a Apple Store (which will be end of the week due to work schedule).

  • Kronkite Level 1 (0 points)

    I've had problems too with new iPhone 4S. My wifi keeps dropping in and out even though my old 3G iphone used to work reliably in the same exact spot. (And so does my macbook.)

  • LuvMusic55 Level 1 (0 points)

    My new iPhone 4S would not automatically connect to my Linksys Wireless N router. Everytime I would enter the password it would say "unable to join". My old 3G iPhone would still connect with no problems as well as my iPod Touch.


    So, just now, I connected into my router from my desktop computer to access the router software and fixed settings as follows: (1) Wireless (2) Wireless Mac Filter (3) Add your iPhone WiFi address to the list. (To find your iPhone WiFi address, go to Settings/General/About and scroll down to the WiFi address. This fixed my connection problem immediately! Hope this helps you!

  • sandun Level 1 (0 points)

    Thanks for the tip. I do not have Mac filtering enabled on my router. (i.e. all mac addresses are allowed at the moment).  In order me to add the mac address of the iphone and enable filtering, I will also need to add (allow) mac addresses of all other devices in my home (so they will not get blocked once filtering is enabled).


    I did however try to assign the iphone a static IP.  That did not work either.


    Also factory reset of the router I use did not help either.

  • Javamunki Level 1 (0 points)

    Same here on out-of-the-box AT&T 16G White purchased at Best Buy tonight. 


    Not very pleased as I preordered both the Black and White a week ago and half of their shipment shows up for launch. The Black was fine but this one choked on initial WiFi set-up.


    I went through the same checkdowns as you outlined above with the exception of logging on to an open network;  I was going to visit Starbuck's tomorrow to verify it wasn't simply my router, but I'll assume it would fail as yours did. 


    It does however connect to my network, showing the WiFi logo in the status bar, but immediately throws up a roadblock on any data moving wirelessly: "Safari isn't connected to the Internet," "Cannot connect to iTunes Store," etc


    Something I discovered while reviewing the router's log is the Phone is reporting a static IP Address, even though DHCP is selected.  I attempted to force it into static and then back to DHCP, dropping and adding the network, but the phone is unresponsive to any network changes.


    Coincidentally or not the White also runs very warm along the right side antenna, noticeably more so than the 16G Black has these last 24hrs. 


    I fear I've bought the wife a lovely paperweight...

  • Wayne Mertel Level 1 (5 points)

    I too have had connectivity issues with the 4S  ATT Black 64GB.  It hasn't been consistent in its ability to connect to the internet both on WI FI and on 3G.   (Actually, my experience has been more inconsistent on 3G.)


    Anyone else have 3G issues?

  • Javamunki Level 1 (0 points)

    Happy to report the phone has corrected itself this morning!


    I went to Starbucks to test the WiFi one last time before going back to BB, shut the cellular services off, and attempted to open Safari.  Service was there but slow. I returned home and found that now it was working with my network and seemed less sluggish.  Thank God!  I was dreading revisiting BB's "Genius Bar."


    Looking at the device from my router it appears the IP Address is in DHCP now.  I did nothing but go to sleep and boom everything falls into place.  I don't get it but I'm pleased.  I wish luck to the rest here.


    And to address above, never an issue with 3G data, only wireless.



  • sandun Level 1 (0 points)

    Update: took the unit to the Apple Store. The person at the Genius bar told me that this is a known issue with iOS 5, and I am not the only one with this problem. So he factory reset the phone (took about 30 mins). He said this should fix it.


    Two hours later (wait time + commute), I get home and try the initial setup/wizard on the phone. Ran into the same problem with wifi. After the 5th or so time, I was able to connect. Looks goods so far. Next, I synched with iTunes etc.   Guess what? The WiFi was gone. Tried multiple times to connect. I managed to connect to the wifi once - but only very briefly. (2 mins or so)


    Now, I am back to square one with the "Cannot join ..." error.  I still feel this is a hardware issue.


    Anyway, I am going  back to the Apple Store (next appointment is on Friday). (And this time ask them to test it before giving the unit to me.)(they did not, today).

  • AdamArt Level 1 (0 points)

    I also purchased an iPhone 4S 32GB Black. I really hope that this is just an OS bug, otherwise I will need to return the phone. Come on Apple, where's the communication about a fix or a new phone?

  • sandun Level 1 (0 points)

    Update: Went back to the Genius Bar again (2nd visit, total). They (Apple Store) tried to connect with their internal network and it failed for them as well.  I am not sure what else they tried in terms of trying to resolve this issue (my wife went this time as I was not able to), but were *not* successful. Per my wife, they really tried hard to find the issue and fix it. (mostly likely everything I tried as well). Wanted to make sure she had a working phone.


    In the end, Apple swapped her 4S with another (new) 4S right there at the store. So, she was back home in a couple of hours with a working phone. (Apple this time made sure, the newer 4S connected to store wifi).  (I guess my wifi was lucky they had a white 16G 4S in stock).


    So, far - (2 days later) the swapped phone is working (even after restoring the data + apps from backup). Works with the home WiFi (WPA2), another AP without security, and at a wifi AP at a friends house.


    edit: I am still not sure if the issue was 4S hardware or iOS5 related.

  • Watison Level 1 (0 points)

    @ sandun


    I have just started having the exact same problem with my 4S as you (where I have a constant WiFi connection but internet drops out after a minute and I have to reconnect, only for it to drop the net again a minute later). Am I really going to have to visit the Apple Store? There's like 2,000 people there at any given time...

  • sirjer Level 1 (0 points)

    I'm having the exact same problem with my new 4s and with my gf's 4 both running ios5. It's to the point now where neither of us can connect to any wifi network, home, work, hotspots... none of them will connect anymore.

  • mat27777777 Level 1 (0 points)

    Hi, my Iphone 4S was exibiting the exact same problem. Initially the phone connected to my home network with no issues, however it did not last more than a day or 2.  After searching long and hard and trying all these suggestions over and over, i came across a forum with the same problem in the Iphone 4.

    The solution for that was to change the router channel to the highest channel possible, which in Australia is channel 13.  My router was previously set on channel 11 but as soon as it was changed to channel 13, bingo, connected straight away and no issues since.

    Now even though i'm happy it is fixed I would love to hear an explanation as to why this has fixed the issue.  Nice if Apple gave some input as to what might be the reason. Maybe they have their wi-fi band set in the higher range of channels instead of giving the ability to use a broad spectrum of frequencies.

    So give it a try, if your router is on auto or a channel lower than 13, log on to your router and change the channel to 13.  Just make sure your devices that connect to the router are set on auto or you'll have to change the channel on them too.

Previous 1 2 Next