Previous 1 2 3 4 5 Next 72 Replies Latest reply: Feb 2, 2015 11:36 PM by Mhmdfhmy Go to original post Branched to a new discussion.
  • Kolikok Level 1 Level 1 (20 points)

    I got this problem after having an application issue and did a reset. After that, my phone went crazy and all notification able applications told me to connect to itunes in order to use push notifications. It drove me mad.


    But, a restore to a back from before the incident occurred solved it.


    Before I got to do a restore, I was very afraid of my phone initiating a backup and thus overwriting a potential good backup. I was surprised to find that Apple store some earlier revisions of backups as well.

  • mauricefromshropshire Level 1 Level 1 (0 points)

    Load iTunes.


    Backup your phone.


    Make sure it is backed up !!


    Run restore.


    This will get rid of the error!


    PS: do the backup. Don't skip it.

  • Milaanilo Level 1 Level 1 (0 points)



    1- Back-up (Last Back-up today)

    2- Restore Iphone 4s

    3- Restore from Back-up (Last Back-up)

    4- Install all Purcashed Apps again from (App store - update - purchased)


    Thats it


    Thanks and goodluck

  • JadaNiv Level 1 Level 1 (0 points)

    I think I just found a simple fix, for this veryanoying problem

    (Background: with my iphone the problem started after I reset my iphone.)

    To solve the problem, I simply went to Settings -> Restriction -> turned it On , and left everyting on (other than Ping on Itunes) - and everything is back to normal ! I hope this helps


  • jaithorpe Level 1 Level 1 (0 points)

    I'm having the exact same issues.


    Everytime I open the YouTube application I get a message saying, "Cannot connect to YouTube" and I am not able to use YouTube at all because of this.


    My iPhone is NOT jailbroken nor has it ever been jailbroken.


    The other app that is giving me problems is Words With Friends and I get the "Connect to iTunes to Use Push Notifications". But I've been connected to iTunes, many times since this started and it doesn't fix anything.


    I just updated from ios 5.0.1 to 5.1.1 last night and it din't fix anything.  I guess I'll do another back-up just to be safe and try a restore.  Ugh.

  • jaithorpe Level 1 Level 1 (0 points)

    Well, I just did another back-up and restored to the original settings and reloaded, and it worked.  As sson as everything was re-loaded onto the iPhone, I entered my username and password and the YouTube app works just like it should.  Everytime.  What a hassle though.


    It also fixed my problem with Words With Friends.  Yay!

  • Buzzron Level 1 Level 1 (0 points)

    Happened to me today.

    Restored from iCloud and boom, all works fine again.

    And yes, backup first!!

  • Foxmartin71 Level 1 Level 1 (0 points)

    This solution does work on the Iphone 5 with that problem. Restored with issues and everything is working. Don't forget to backup.

  • gizbug Level 1 Level 1 (0 points)

    Any concrete fix?


    Just bought the iphone 5.

    Came home, restored my iphone 4 backup, and now getting these popups.

  • Rocky Pope Level 1 Level 1 (115 points)

    I made the mistake of doing a local backup and I then attempted to do a restore from a previous backup.  I stated getting 3014 errors during the restore, so I now have a bricked iPhone 5.  I attempted to enter DFU mode to see if that would help but of course it didn't.  So I am now gong to the "genius" bar to see if I can get a replacement device.  I doubt they'll be able to do anything with it either.


    Applecare to the rescue.  I know I shouldn't have bothered doing the restore.

  • wdgann Level 1 Level 1 (0 points)

    I have a iPod touch, 64gb, model a1421, iTunes 11.0.2 and all the latest updates. I have rebooted, restarted, reinstalled apps, backed up, restored, from iTunes, not the cloud, and NO, it didn't change anything, I still get the message Connect to iTunes to use push notifications. Which, to get out of this mode, double click, switch to another app, then double click again to close the offending app, in this case dropbox, used by millions of users. Looks like I'm going to the Genius Bar, as I work in IT and in a organization that has 1000's of IOS devices. I need to know how to fix this.

  • whreid Level 1 Level 1 (0 points)

    Here is a quick fix to the problem. Without this fix, iMessage and find iPhone messaging will not work.


    All I did was first create a new backup on itunes and on iCloud, then I reset my iPhone, erasing all content and settings. After erasing all of the content and settings, I then restored from the backup on iTunes. After the restore, I had to reinstall all of my purchased apps.

  • fromsouth Level 4 Level 4 (3,575 points)

    These instructions are few years old, but still worked for me.

    TS3305 - Support - Apple

  • RDG62 Level 1 Level 1 (0 points)

    INCREDIBLE!! Thanks SO much Jaithorpe, I did exactly what you said and VIOLA! Got the silly msg about itunes notifications removed! Wrote to Zynga 5x to NO avail. Thank you again!!

  • Donnieftl Level 1 Level 1 (0 points)

    I just upgraded to iphone5. The only time I've had this problem is after downloading the app for Square Up (credit card processing). The app downloaded then that message appeared and wouldn't close or respond to anything. System appeared to hang. I only got rid of it by doing a hard reboot and deleteing that app. I sent acidic messages to Square Inc. who blamed it on Apple, found this thread and sent it to me. Is anyone else trying to use the Square Up app and getting this message? Is Apple trying to do anything about this?