Previous 1 2 Next 26 Replies Latest reply: Jan 3, 2015 6:44 PM by Janelleyfish
daddyvenom Level 1 Level 1

i just got a new email with iCloud and it's working fine

But the problem is that I can't activate my

iMessage ...

Under iMessage says

Waiting for activation.


There are no restrictions at all on my iPhone

Connected over wifi and 3G network...

Rebooted phone

And still no luck

I even did a full restore on it and no luck...

What shoul I do...

iPhone 3GS, iOS 5
  • daddyvenom Level 1 Level 1

    Why GOD WHY!!!!!!

  • hurriyyah umar Level 1 Level 1

    Me Too .. This is so sad !! Maybe our connection not fast enough .in my iphone is same like u ,with 3G network,full !!! But still not luck :(

  • DraganD Level 1 Level 1

    Me too.. I dont know what to do.. I am using Iphone 4 and there is "waiting for activation".. Anybody know how activate it? Pls help....!!!

  • BenVoght Level 1 Level 1

    I am having the same problem with iMessage. I too have an iPhone 3gs and I just updated to iOS 5 yesterday. Everything seems to be working great except for the iMessage feature. I have tried turning  iMessage off and back on (the first time I did that I was prompted to enter my appleID password). I have tried restarting my phone. I went deeper into the options for iMessage and re-entered my appleID and password and confirmed which e-mail address I was going to use, still nothing. iMessage is not working, it is "Waiting for activation". It's getting a little depressing really. My buddies at work have iPads and one even has an iPhone 4 and neither of them are having any issues with this feature. I know its not because we're off the grid (yes, off the grid) bcause we are working a camp job far enough from civilization that there is no cell service at all and therefore no 3g. However, we do have wifi with internet, and that seems to be sufficient for my friends' devices since neither of them has been back to civilization since the release of iOS 5. We all performed our updates here at the camp.

  • edo320 Level 1 Level 1

    hey..actually i have same problem 2 days ago n yesterday my imessage finaly worked..

    in my case i use another sim card/not original bundling,then i use my original sim card/carrier, n it instanly worked..

    so actually carrier does take the problem..

    im sory my english is terrible bad,im from indonesia..thank you

  • RenzokukenJ Level 1 Level 1

    Gak ngerti sih, gw coba gitu juga tapi gak kerja......... aduh!

  • nicolefromcambria Level 1 Level 1

    My iMessage  was working for 2-3 days and now won't work. It also says waiting for activation. When I go into 'receive at' it appears to be trying to verify my number. aaaargh!!!!

  • NFH. Level 1 Level 1

    I had exactly this problem yesterday, both on my iPhone 4 (which had been working on iMessage for months) and on my wife's iPhone 3GS. I spent an hour on the phone to Apple support, but they couldn’t fix it. All they could suggest was an appointment at an Apple store. However, I managed to fix it on both iPhones by using Google's DNS server,


    Using my own proxy server, I found the servers that the iPhone connects to when activating iMessage. There are several, but two of them are deployed regionally with the same hostname but multiple IP addresses (and consequently multiple servers). I am in the UK and when I do DNS lookups, I get the following results: from a UK DNS server from Google's US DNS server at from a UK DNS server from Google's US DNS server at


    The regional differences in DNS resolution are because Apple uses Akamai Technologies to deploy local points of presence, which is intended to reduce latency and intercontinental bandwidth. Therefore your iPhone does a DNS lookup on the hostname and a regional IP address is returned. UK DNS servers return the above 82.96.58.* addresses in Sweden; Google's US DNS server returns the above servers in the US, which I am guessing are Apple's primary iMessage servers. The Swedish iMessage servers seem to be deficient in some way, which is why you sometimes get this problem when activating iMessage outside the US.


    After changing the DNS for your wifi connection to, you may need to restart your iPhone before trying to switch on iMessage again, as restarting will flush the iPhone's DNS cache. Otherwise your iPhone will retain the previous DNS mapping to regional Apple servers rather than to the more reliable primary Apple servers in the US.

  • Night Ed Level 1 Level 1

    Do you mean go into the settings for the individual wifi connection that happens to be active, and adding to the DNS field?


    I have the exact same problem on my 3GS and I just tried that, followed by a restart, and it didn't cure it for me. iMessages wait for activation, then activation fails.


    Is there anywhere else to enter these DNS settings? The Cellular Data Network DNS setting is as recommended by my network provider.


    I've tried all the solutions to this problem I've found in these forums, and nothing has worked for me.

  • NFH. Level 1 Level 1

    Yes, what you say is exactly what I meant, although another thing you can try is adding a second DNS server, i.e., Separate the two DNS entries with a comma; both belong to Google. I tried this again yesterday after swapping SIM cards around, which disabled my iMessage again, and I managed to fix it again using the DNS solution, so it wasn't a fluke the first time.

  • Night Ed Level 1 Level 1

    Thanks for the help, but adding the two servers didn't work either.


    I'm in France today and although I've got a good wifi signal I've just noticed that every time I try and fail to activate iMessage I'm being charged 10p!


    Better stop trying until I'm back in the UK...

  • NFH. Level 1 Level 1

    I was similarly charged when roaming in Spain for multiple Facetime activation attempts when I hadn't even reactivated it. Orange UK refunded me when I complained. At least we UK users have the advantage of not being charged for these iMessage/Facetime activation attempts when in the UK, unlike the rest of the world (even US users) who are being charged for international SMS to the UK. Apple needs to change the activation mechanism to be more like WhatsApp and Viber, requiring an SMS to be received and not to be sent.

  • Night Ed Level 1 Level 1

    Solved this now. I found another discussion here that I'd ovelooked before where users with this problem were advised to make sure their Date and Time settings are on Auto.


    Mine weren't because whenever I come back from France the time doesn't change back for ages. Switched it to Auto and, hey presto, those nice blue messages are working again.


    Here's the page on the other discussion where the fix is offered by fdm1979:


  • adenawild Level 1 Level 1

    Hard Reset the device and see if it reconnects.

Previous 1 2 Next