Previous 1 38 39 40 41 42 Next 627 Replies Latest reply: Dec 4, 2014 6:28 PM by maisam.asif Go to original post
  • H0jj@t Level 1 (0 points)

    I have problem with my iPhone 4S, it have voice echo for my friends(themselves echo) not for me
    I when open the rear panel echo is removed but I close the rear panel echo is back again also sometimes microphone not work than I must reboot the iPhone or use of the speaker!
    Which segment needs to repair or change?

  • Mikeacj Level 1 (0 points)

    I have had my 4s 16Gb for 1.5 years an was working perfectly with the original headset. Now I broke the headphones and bought a new beats by monster and the problem begin. Almost all the time the ohter side keeps claiming about echo on my voice. I tried with a pairs of samsumg headset from an S4 an no problem with this. I even make test calls, and on the same call exchange the headsets and the problems just show up with the monster headset.  I think my case is not a carrier problem.

  • CAEDU Level 1 (0 points)

    My iPhone 4 has the same problem. When I talk with people on my phone connected through my car stereo, the audio quaility is AWFUL for the person on the other end. They complain all the time about echo. The iPhone in this config is worse than my Moto Razer than I used to have. Seems like iPhone noise cancellation when using an aux output is broken.


    Not going to buy a new iPhone until this is fixed!

  • satyajit_ios Level 1 (0 points)

    I am also facing the same issue, using car bluetooth, person at other end cannot hear my voice because of heavy echo, is there any solution for this? I am using Iphone 4, ios 6.1.3 version. Apple are you listening? why this issue is open since such a long time?

  • gnkf Level 1 (0 points)

    I have same problem ( people calling me, hearing echo of themselves while speaking with me )...but..using Iphone 3gs and EarPods headphones&mic. I tried everything to avoid echo effects, but until now, I have not found any solution

    probably i have to buy a Samsung phone ...????

  • iskenderalp Level 1 (0 points)

    if you want to set silent mode your phone (using home botton making double click) while calling echo of your voice listen to caller phone.:))))

  • mrsr71 Level 1 (0 points)

    Problem solved.


    Put a piece of clear tape over the itty bitty

    microphone hole next to the speak headphone jack.


    Worked for me :~)

  • emraan200 Level 1 (0 points)

    I have gone through all the posts and i ve not an iota of doubt that apple knows the issue and they cant fix it.

    And i am truly impressed with their determination of not acknowleding the problme........


    Im never going to buy any **** even sounding like apple.........

  • SQUINTZ76 Level 1 (0 points)

    Personally, I have fought this situation as welll....quite a bit.  I'm another example of the noise echo happening on the other end (the person that I am talking to) and never hear the echo on my end of the line.  It seemingly was happening all the time, I just thought folks gave up on complaining.  I use my iPhone 4s, plus a NoiseHush nx70-11825 and I would still get the occasional complaint.


    I think.  I repeat, I THINK I have it solved by making sure my headset is plugged in prior to making or receiving any calls.  For some reason, I think the mic engages and creates some sort of audio loop causing this echo.  So far, I can also use the 'turn the speakerphone on and off' solution and the echo goes away if I forget to have my headset plugged in prior to the call.


    I'll report back after a couple weeks and let everyone know what I find.....I'm guessing it'll be a combination of all these things to solve it 100%, so I'll try all the case on / off and clear tape options as well to see if I can get the issue to happen / not happen with any kind of consistency.


    There has to be a way to get this figured out through trial and error......that doesn't require buying any new gear.


    Stay tuned!

  • SQUINTZ76 Level 1 (0 points)

    OK - a quick follow up that I've already figured out.


    With 100% certainty, when I call someone, the echo does not happen on the other end whether or not I have the headset plugged in prior to the call.  When I am on a call and take the headset out and plug it back in, the echo does not start happening at all.


    On the other hand, whenever I am called by someone, it doesn't matter whether or not I have the headset plugged in prior to the call....the echo happens.  I have to turn the speakerphone on and then back off.


    Again, this is only when I am called, not when I am calling and happens every time.  The only solution I have so far is to turn the speakerphone on and off.


    Goign to test the tape on the hole theory next to see if it eliminates to use the speakerphone on / off solution in any circumstance.

  • mrsr71 Level 1 (0 points)

    I solved the entire problem by putting a small piece of clear tape over the itty-bitty hole next to to the headphone jack.

  • nathaliedoo1 Level 1 (0 points)

    Seems to be working for me too so far. 


    For information, I get the echo no matter if I'm calling or receive the call, I am not using a one-button headphone (in fact a 3-button Bowers and Wilkins), doesn't make a difference if I plug the headphone prior calling or receiving call or after.  In fact, plugging and unplugging solves the problem for a few seconds.


    But the tiny tape seems to work, as I mentioned, so far.

  • SQUINTZ76 Level 1 (0 points)

    OK, figured out what my issues were.  The small piece of tape trick does not do a lick of good for my situation.


    Here is what all has to be done for me to ensure the end user doesn't hear an echo:

    - My listening volume on the phone cannot be at full volume.  Just a notch below works just fine

    - Once the call is connected, whoever makes the call (me or the person calling me), I need to turn the speaker phone on and then back off after the call is connected.

    - If my phone locks while on the call, the speaker phone on/off step has to be repeated, every time it locks.  The echo returns upon the screen lock.  To prevent this, I turn automatic screen lock off during the day when I'm on the phone quite a bit.



    All this solved my problem. (*****...but works)

  • nathaliedoo1 Level 1 (0 points)

    I have to say that the tape trick works but I had to double it. Just one piece of clear tape didn't do the trick. So I cut another piece and added it in top. Now works. Maybe try to block it temporarily with your finger to see if that works??


    Good luck!

  • goju123 Level 1 (0 points)

    For me the trick with tape is not working. There is still echo on the other end (with person I'm talking with). As I'm, from Bosnia, it is obviuos that this issue doesn't have any connection with mobile network or any other similar. I had in the past 2G and 3GS and no similar issues with these phones in the past. Unfortunately I don't have experience of my 4S with previous iOS as I bought it with already upgraded iOS7, so I cannot say that this issue could be consiquence of upgrading to newer version of iOS.

    Looking forward that maybe Apple will solve this issue with new software as I cannot take another iPhone as I bought it already used.