Previous 1 3 4 5 6 7 Next 240 Replies Latest reply: Oct 2, 2014 7:17 PM by aNsoN619 Go to original post
  • iluvjensen1 Level 1 (0 points)

    This happened to my Mom's iPhone 3G the other night... she uses a Windows 7 PC Desktop and it kept saying the same message you received about iTunes not being able to sync apps. Long story short, I ended up syncing her phone using my Windows Vista Hp Notebook PC laptop and it didn't give me that error message and it synced all her apps to where she could use them again.

     

    don't know why her computer wasn't letting her sync, but mine did... weird, but it worked.

     

    maybe you should try another computer with a different operating system if possible or maybe just a different computer. Syncing an iPhone isn't dependent on having your computer unless you need to back it up or restore from a back up or something.

     

    if trying a different computer or operating system isn't possible, last resort might be A.) unsyncing all apps from phone and then resyncing them or B.) backing up your phone to your computer and then do a restore from back up of your phone

     

    hope this helps

  • hardhit99 Level 1 (0 points)

    I found a solution to this problem that may work for some of you. In my case I am using an iPad, but that shouldn't make much of a difference. After attempting some of the other suggestions in this thread with no success, I decided to take a look at some of the simpler reasons my sync might be failing and what might be different this time. Normally I sync with the Apple supplied USB sync cable, however I had just recently charged my iPad on my Apple iPad dock. My iPad dock is plugged in using Griffin's extended length USB sync cable and I realized that I had never synced with that cable before, I only use it for charging. For the record, I'm not sure if I've ever synced with the iPad dock either, but I'll try that later to see if it causes any issues. Anyway, I decided to see if that might have something to do with it, so I grabbed my Apple USB cable, plugged it in, and immediately my iPad ran through a full sync perfectly. You may or may not be using a third party cable or dock, but if you are, try just using the Apple USB cable. If you are using the Apple USB cable, consider picking up another one from Apple, or borrowing one from a friend to see if there might be a problem with your cable. They tend to get flexed pretty bad and there may be a loose connection that is still allowing the device to be recognized, but not allowing data to flow properly. Hope that helps someone.

  • stestardi Level 1 (0 points)

    All,

     

    Please try the solution at https://discussions.apple.com/message/17218105#17218105 and post the results for all to see.

     

    Thanks!

  • westsidegirly Level 1 (0 points)

    Wow this has helped, I did what W Buchanan said and it was PERFECT!  Never even thought of that!

    W Buchanan wrote:

     

    Confirmed!

     

    I was getting the same error message. After reading your post, I updated all my apps in iTunes. Sync worked as normal after that. Now we'll have to see if this happens again when other apps are updated.

     

    Thanks, jp_ofarrell!

  • WordsFree Level 1 (0 points)

    All I did was delete Words with Friends Free! I saw that every time I synced, it ended up giving me the dreaded message we've all been getting right as it was at "Syncing Words Free". I deleted it - and did not reinstall it!!! - restarted my iphone, did the windows device manager thing from the control panel, restarted itunes, and now the problem is solved!! shame on you, zynga people for corrupting my iphone with buggy programs.

    Hope this helps!

  • markymark8 Level 1 (15 points)

    I found a collection of solutions that you all can try to solve this problem. There is a nice compilation listed out here. Hope that helps!

  • DaveyD1 Level 1 (0 points)

    Struggled with this getting my wife's iphone to sync and after sometime found this worked:-

     

    Update apps in the app store on itunes first, quit out of itunes, open up itunes, plug in iphone, resync.

     

    Disconnect iphone, shut down and restart.

     

    Hope this works for you.

  • gustavo_08 Level 1 (0 points)

    I had the same problem but I have an iPod Touch 4g (iOS 5) and I unchecked the "Sync Apps" on iTunes then I synced and it put my music on my iPod. It warned me saying that it was going to delete all app data in my iPod but it never did.

  • pwrrangerdanger Level 1 (0 points)

    I was able to get everything fixed by ending iTunes and then opening it back up. Hopefully it works for you guys as well.

     

     

    (also, I deleted some apps while leaving the phone charging and on iTunes which may have caused it to bug out)

     

     

    Best of luck, everybody!

  • ann223 Level 1 (0 points)

    thanks for the help.  this worked for me as well!

  • jimhartford Level 1 (0 points)

    I had this problem today when trying to sync my iphone 4s.  I restarted the phone and restarted iTunes and the sync then worked fine.

  • Emdoubleu Level 1 (0 points)

    Hi,

     

    This issue has happened to me a couple of times on my iPad and, after many hours of trying different solutions and much frustration, I have today narrowed it down to the auto download option in Store under Settings. Once these have all been switched to Off, try syncing again.

     

    Using Apple proprietary cables also seems to be a factor...

     

    Hope this helps

  • xyrith Level 1 (0 points)

    For some reason iTunes said my iPhone 4 wasn't registered. I quit iTunes, started it again, and with my iPhone plugged in, iTunes said I needed to register. I re-registered it and my iPhone now syncs.

  • NYC_gal Level 1 (0 points)

    ... update ALL apps within iTunes on computer...  FINALLY!  this worked great... thanks for the post suggestion!

  • Barryinnyc Level 1 (0 points)

    I know this might sound very simple but to ensure you don't get the error message, make sure you do not have any APPS open when you are syncing. I have an 3G (yes I know) and I got the message but when I closed the app which was running, all sync's worked. I hope this helps.

Previous 1 3 4 5 6 7 Next