Previous 1 2 3 Next 34 Replies Latest reply: Jul 23, 2014 2:47 PM by rooster9574 Go to original post
  • Wile E. Level 1 Level 1 (0 points)

    I was having the same irritating grief when all other aspects of iCloud seemed to working properly. That is how I found this discussion. Today I bit the bullet and went to and changed my password. I noticed Apple's requirements for a password were different than what I remembered and definitely my current Apple ID and password did not meet the requirements. I changed my password to meet the requirements and iPhoto worked instantly to share a photo via iCloud email.


    Apple says the password has to be at least 8 characters long, have at least one upper and one lower case letter, must have at least one number and one letter and cannot have three characters in a row that are the same. My old password had no upper case letters. I put some in the new password and everything worked as expected.


    I have confirmed (for me) that iTunes, my iPhone, Apple TV and iCloud in general all now work as expected.

  • FFS48 Level 1 Level 1 (25 points)

    Fixed by resetting my password to Apple's new protocol!  In my case, I had to add a capitol letter.


    Reset here:


  • frusciante29 Level 1 Level 1 (0 points)

    After resetting my password, I also had to remove the iCloud account in iPhoto preferences, and then re-add it. Sending emails from iPhoto now works fine.

  • marekkoznar Level 1 Level 1 (0 points)

    i am new to iCloud and my original password matched the expectations.

    and i still got the error: server cannot recognize my username/password combination.

    i removed the account from iPhoto, changed the password and added again the iCloud Mail account.


    now works just fine.



  • Luke771011 Level 1 Level 1 (0 points)

    So far I had a same issue until yesterday.


    Here are something you should try to fix the problem.


    1) Change your password as Apple requires you to do so.(For me, I changed it with one capital character)

    2) If you have mobileMe gallery account connected with your iPhoto, delete it first then add you iCloud account again.


    this one worked for me, I am not sure it will work for everybody who have the same problem but worth try though.


    Good Luck!!

  • Mac_Phantom Level 1 Level 1 (0 points)

    I really don't want to have to change my password.  I meet all Apple's creteria as it is and I think that the right thing for the customer is to fix this issue.  I really hope there is a real fix where I am not forced to be inconvenienced becuase I was forced to migrate to iCloud.  Especially after knowing that things like Gallery are going away come June.

  • Sergei Gnezdov Level 1 Level 1 (5 points)

    This solution does not work, so don't bother. I wish I could delete it.



    I had exactly the same issue and I also did not want to change my existing password. I had to do the following:

    1. Delete MobileMe account and iCloud account in iPhoto preferences. That's just in case.
    2. iPhoto Account preferences: create new Mail account, select iCloud option. Type all of the required information.
    3. Try sending email photo. It fails at this point in my case. I had to adjust settings in iPhoto preferences. The following steps attempt to do so. First of all, iCloud tries to hide the fact that it still uses SMTP servers. The default server is incorrect as well as the user id. We use Mail application to locate proper SMTP server.
      1. To locate SMTP settings you need to use Mail Activity. It is in your right bottom corner. Here is OS X documentation on the topic: Display the sidebar, if necessary, and then click the Show Mail Activity icon (looks like an up arrow) at the bottom to open the Mail Activity pane in the sidebar. To close the Mail Activity pane, click the Hide Mail Activity icon (looks like a down arrow).
      2. Click on Get Account Info at the bottom. It is under gear icon.
      3. Select Summary Tab. On this tab you should see Outgoing Mail Server. Mine is Yours is very likely to be different. Copy your value for outgoing SMTP server.
    4. Go to iCloud email preferences in iPhoto and paste copied SMTP server value into "Outgoing Mail Server" field.
    5. My user name was created without Change your user name so it includes


    Close preferences dialog and save changes.


    Try sending email.


    Message was edited by: Sergei Gnezdov

  • shawgofam Level 1 Level 1 (0 points)



    Thanks for the detailed instructions.  Unfortunately, it still doesn't work.  In my case, the SMTP server was different than yours, and even after inserting it, still no luck.  I tried every possible combination of fixes such as adding the "" to the username, and changing the SMTP name.  No go.


    In addition, iPhoto should, in theory, automatically import the email accounts information from the Mail program if that already has account information.


    Again, thanks, but still no luck.


    For the record, my account password does meet the criteria of min 8 characters with at least one capital letter, at least one lower case letter, at least one number and no three characters in a row.  To clarify, it works great using Mail, iTunes, and any other Apple product that requires email information.  Simply does not work in iPhoto...

  • Emile vande Griendt Level 1 Level 1 (80 points)

    Hi all, i'm also a migrated MobileMe user to iCloud. Encountered the very annoying iPhoto-mail-bug-refusal to email because the 'combination of login and password wasn't recognized'. After spending a completely useless hour trying every known combination of SSL, smtp, portnumber and the like in both Mail and iPhoto i decided to change my Apple ID. Indeed, my old password did not conform to the new rules, now it does: but still no luck!


    Then i noticed that somehow iPhoto creates an extra ghost-smtp within Mail. Looking up the list of smtp servers within Mail i noticed an extra iCloud smtp-server that appeared 'offline'. Tried to edit the smtp-list but the extra smtp simply didn't show up. Seems buggy to me.


    Lastly, i tried Sergei's tip to locate the smtp-settings using Mail's 'Mail Activity' gear icon. Amazingly, no smtp server was listed here under No SSL either. Puzzling to say the least...


    Finally i simply added 'p99-' in front of my smtp-settings in iPhoto's Mail-preferences. THIS WORKED! Sending a photo-email from iPhoto now works again after my migration to iCloud. I am not going to touch any email setting for a long time and spend some time outside in the sun.

  • Junebug172 Level 1 Level 1 (40 points)

    I unchecked use SSL in accounts pane of the preference in iPhoto and it worked.


    That's the only change I made.

  • davkyles Level 1 Level 1 (0 points)

    This is what worked for me



    My default smtp setting was vs what is posted in the article,

  • Sergei Gnezdov Level 1 Level 1 (5 points)

    I don't recall where I have seen this recommendation. Only recently I had a chance to test this solution.


    To fix iPhoto sending email someone recommended running Disk Utility permission verify and repair.


    Search for "Disk Utility" and click on it. Select "Macinto HD". You are likely to see Macintosh HD and then the same "Macintosh HD" under it. You care for the nested item. Click on nested Macintosh HD. Click on Verify Permissions. If utility detects there is an issue with permissions, then click on Repair Disk Permissions.


    If you have Mac with harddrive instead of flash based (retina display laptop), then it is worth it verifying that your disk is in top condition with "Verify Disk" button. You will be prompted to fix issues if there are any. If utility finds issues it is strongly recommended that you use repair procedure. However, repair procedure can take some time, so you better do it when you have time to wait.


    My Finder misbihaved a few days ago and I decided to very disk. There were issues with it, so I had to reboot into Cmd-R mode and then use repair option. After that I used verify permissions and repair permissions buttons as there were issues there as well.


    Today I tested my iPhoto ability to email via @me emal address and it worked. It did not work 2 or 3 weeks ago.


    I was not trying to address iPhoto issue, but the correlation is there and is worth mentioning.

  • Colin McClelland1 Level 2 Level 2 (355 points)

    I just went to iPhoto Preferences, then to accounts, and re-typed my iCloud password, and it worked.

  • hiterror Level 1 Level 1 (0 points)

    This is obnoxious. More and more these random and incredibly annoying problems are cropping. I am a diehard Apple fan, but they but less and less effort it to finding and working out bugs before they release things. All of a sudden, out of nowhere, I can't send pictures from iPhoto. Now I'm wasting hours sifting through comments trying to solve this ridiculousness. Lame.

  • Terence Devlin Level 10 Level 10 (135,565 points)

    Then why post your irritation into a 2 year old thread instead of creating a new thread and asking for help? That seems a better use of time.