Previous 1 2 3 Next 89 Replies Latest reply: Nov 16, 2012 2:21 AM by NoOneKnowMe
Marcus Muench1 Level 1 (5 points)

Hi there,

 

I recently upgraded my iPhone 4 to iOS5 and also migrated my MobileMe account to iCloud. I am not really shure if I should have done both, because now my mail on iOS has some problems:

 

First I could not log in into iClod mail on my iPhone, because it tould me that my password was wrong. Well, all other iCloud services as calender worked just fine, so I think my password was not really wrong. But mail on Lion also told me that the password was wrong, so I entered my password in mail on Lion and in the iCloud settings again and again, and finally I got it working.

 

So I get mails again, but what still is missing is the push notification of new emails. I checked the setting, it's "Push", but I have to enter the mail app on the iPhone to receive new mail, no notification. Switched the notification settings in the email settings to manual and back to push, but it does not work.

 

Anyone here with a solution?

 

Regards,

Marcus


iPhone 4, iOS 5
  • Frank Malloy Level 2 (350 points)

    Marcus, happening here too.

     

    The indication of an incorrect password was due to iCloud being down, it's not a real password issue. It happened to me on the first day, then disappeared after iCloud was working "reliably".

     

    Now, I'm seeing the same issue as you - no Push notifications for email, and you have to manually check the Mail client to receive the message. It's happening on my iPad and iPhone so it's not your specific device.

     

    What is strange is that if the iCloud Push notification service is down, why do I receive the email right away on my MacBookPro? ll three devices are on the same WiFi network.

     

    We ran into this failing push notification issue a few iOS releases ago, and I had hoped the problem was gone for good.

  • sooheeya Level 1 (0 points)

    I have same problem with you.

    Actually, the notification worked exactly yesterday, but now it  does not.

     

    I was wondering it is a problem of my phone.

  • rodfromtulsa Level 1 (0 points)

    After messign with 'push' for a couple of hours, i googled it.  The suggestions were all over the map including running the mail app on the phone.

     

    I powered off the phone, started it back up, and push is working.  It works even without the mail app on.

     

    i have a 3gs, ios5.

  • marcwiegelmann Level 1 (0 points)

    With my device push is not working even after reboot it...

  • jamie.feldman Level 1 (0 points)

    It appears to be a Wi-Fi problem as much as anything. I am getting exactly the same problem as you - however, if you take your iDevices out of range of Wi-Fi and connect to a 3G network, you will find that e-mails are pushed to your iDevice.

  • jason-konimod born Level 1 (0 points)

    after i moved to icloud the emails are also note pushed anymore to my iphone 4 ios5.

    I tryed differt thinks (reboot, settings to push,.....) without changes.

    It won´t push any emails - even i open the mail app than it reseved the mails :-(

  • NoOneKnowMe Level 1 (0 points)

    Same problem here. If app Mail is not active, do not get any push notification. If Mail is active in multitasking notification arrives.

     

    iPhone 4, iOS 5

  • erichwk Level 1 (0 points)

    Same problem. iOS 5 on iPhone 4 and ipad 1.

    No joy in push mails. Except for mails by apple themselves! I just received the confirmation email and that DID come pushed. ?????

  • rczurek Level 1 (0 points)

    It appears that the solution to the lack of push is leaving the app open, file a bug report with Apple and wait for OS5.1 version update.

  • Marcus Muench1 Level 1 (5 points)

    I tested this: Switch off WLAN, had no effect. Then restarted iPhone with WLAN still off, now it receives push email, even without starten mail app manually. Definately an issue Apple should fix. Where and how can I file a bug report on this?

  • erichwk Level 1 (0 points)

    Even with the app still in the background, on my iPad 1 still no push... Doesn't work for all then.

  • Frank Malloy Level 2 (350 points)

    For me, restarting the phone remedied the problem. I'm not sure if/when it will return, and it's not clear where the real source of the problem is.

     

    For everyone else - the first recommendation if you see this is to restart your phone. Hold the Power/Sleep switch on top until you see "Slide to Power Off", then slide and allow it to clean up and power off. Then, power back on and see if push is working.

     

    I do NOT recommend the force shutdown where you keep holding down the Power/Sleep switch. That has zero benefit and serves only to yank the power without giving the phone a chance to shut down completely first by flushing the caches, closing open files, etc. It's like pulling the power plug on a running computer. Don't do it unless your phone is completely hung and you cannot slide to power off.

  • grandifolian Level 1 (0 points)

    Same problem here. Recognise all your problems.

    I've transerred from MobileMe to iCloud.

    I'm running Mac OS 10.7.2, iPad and iPhone (both with iOS 5).

  • Catherine Arnold Level 1 (10 points)

    Reboot did the trick for me.

Previous 1 2 3 Next