Previous 1 2 3 4 Next 89 Replies Latest reply: Nov 16, 2012 2:21 AM by NoOneKnowMe Go to original post
  • Cab61 Level 1 Level 1

    I have the same problem. I have tried everthing, but it does not help, only if the mail app is running. I hope Apple will doe something about this problem.

  • Rich5481 Level 1 Level 1

    i am actually on the phone with apple support now, and the rep said he has never heard of this issue. he had me go into setting, check that push was on, then he asked me what my fetch setting was and told him manual, which was the default setting. the agent said that would be why push is not working. told him that is not the case, as its the same settings i had for MobileMe, now im waiting on hold for a senior advisor

  • Cab61 Level 1 Level 1

    Push switch is alwais on. The problem is not the switch.

  • redhead12 Level 1 Level 1

    Same problem here.  I haven't changed any of my settings since switching to iOS 5, so it's got to be something with iCloud. 

  • ian2828 Level 1 Level 1

    Found on a similar thread - I solved the problem of no iCloud push notifications on my iPhone by resetting network settings (Settings - General - Reset - Reset Network Settings). I just had to re-enter my wi-fi password, and now push works perfectly although mail must be running in the background.

  • Cab61 Level 1 Level 1

    I have try to resetting my network ( Setting-General-Reset-Reset Network Setings ) But i have still the same problem, ;0(

  • ian2828 Level 1 Level 1

    The only other step I performed was an iPhone reset (hold sleep/wake button and home button for about 10 seconds until the Apple logo appears). This alone didn't help but then I reset the network which solved the problem. Maybe you could try this additional step? Are you connected to a Wi-Fi network? If so, you could try switching off Wi-Fi and check if push works via cellular data.

  • Cab61 Level 1 Level 1

    Hi ian2828

    I have try to, am still the same. Thank you.

  • jamie.feldman Level 1 Level 1

    Resetting the network settings does not appear to solve the problem. I think it is a problem intrinsically linked with being connected to WiFi as at all other times I have not had a problem with push. I think it might be worth waiting for an apple update

  • jwoody3227 Level 1 Level 1

    I got mine to work!! It appears that you must set up a "cloud email account". Go to>Settings> iCloud. Then set up the free "me" email. This will allow you to turn ON "mail" under where you enter the account. Once I did this, my mail began to "push".

     

    Hope this works for you guys.

  • pablofromciudad de buenos aires Level 1 Level 1
    Solution to the problem:

    1 - go into mac www.icloud.com
    2 - enter with a different id mobileme, and create a new account for free
    @ me.com
    3 - On the iphone, go to mail and add the new account in icloud
    4 - Sync only emails
    5 - Results:
    The new icloud account registers our device and everything works fine
    6 - "Push" is working again on both counts

     

     

     

  • jwoody3227 Level 1 Level 1

    This is the solution. Kind of what I wrote (above), but in step by step form. This will solve the push problem. Thank you!!

  • 794hew Level 1 Level 1

    For some reason since my wife updated to iOS 5 she lost her ability to get push emails in iCloud (formerly MobileMe). We tried a few things like restarts, turning push on and off. Nothing seems to cure it.

     

    As a last resort before a full restore, I thought I would try and do a reset of the network settings. Basically you have to redo your wifi network logins and passwords. Anyway, worked right out of the gate. Now she is getting emails live rather than only when she opens mail or taps for updates.

     

    Hope that helps anyone else with that problem.

     

    Collierpress.com

  • Martina.A Level 1 Level 1

    I had a MobileMe account that was transferred to iCloud. Did as you say, but had to do it in this order:

     

    1. iPhone (iPad): Settings > Mail, Contacts, Calendar > Add Account > iCloud > create a new free @me.com account. Set it to sync email only.

    2. Go to icloud.com in your browser, sign in with the new @me.com account

    3. Sign out.

    4. All emails are being pushed. Also the MobileMe emails transferred to iCloud.

    5. Repeat on other devices (this time don't create a new account, just add the new @me.com account to iCloud (in Mails, Contacts, Calendar > Add Account > iCloud). Sign in to icloud.com in your browser again. Sign out.

     

    Everything is working now. Thanks for this fix.

  • Cab61 Level 1 Level 1

    Thanks Martina.A

    Now works, finally.

Previous 1 2 3 4 Next