Previous 1 2 3 4 5 6 Next 89 Replies Latest reply: Nov 16, 2012 2:21 AM by NoOneKnowMe Go to original post
  • Panzullo Level 1 Level 1 (0 points)

    This one worked for me! Thanks Cab61

     

    "resetting my network ( Setting-General-Reset-Reset Network Setings ) But i have still the same problem, ;0("

  • rexfrombirmingham Level 1 Level 1 (0 points)

    This worked for me on my iPhone 4, but your mileage may vary...

     

    1. Power off the phone (hold down top button, slide to power off (NOT hard reset))
    2. Power on phone
    3. Open mail app
    4. Close mail app, but leave running on phone (multitasking).

     

    Also had to:

     

    Settings > Notifications > Mail:

    1. Notification Center: ON
    2. Alert Style: Banners
    3. Badge App Icon: ON
    4. Show Preview: ON
    5. View in Lock Screen: ON

    I can now receive push mail on my .me account.  Also have my gmail account forwarding to the .me account and this works as well.  Good temporary fix for me, but Apple still needs to release an update to fix this...

     

    Message was edited by: rexfrombirmingham

  • rexfrombirmingham Level 1 Level 1 (0 points)

    Updated above.  Thx

  • Marcus Muench1 Level 1 Level 1 (5 points)

    Well, currently push notification works fine for me, without this not really Apple like network resetting procedure. I can restart my iPhone an still get notifications, even with out starting mail app. Seems like Apple fixed something silently.

  • Bigred69 Level 1 Level 1 (0 points)

    Im having the same problem but only with my Iphone 4S. Ipad is working fine.

  • AzWit Level 1 Level 1 (0 points)

    This is the case with mine too, wi-Fi problem, 3G is working fine. Thanks for the details.

  • Velgor Level 1 Level 1 (35 points)

    Tried all the solutions posted and no joy. Push is not working for me. Frustrating.

  • EdwinRamos Level 1 Level 1 (10 points)

    Solution:

     

    1 - On iPhone Go To Settings/Mail, Contacts, Calendars/Add Account/iCloud/Get a Free Apple ID

    2 - Creat a new .me account

    3 - Sync only emails

    4 - Results:  The new icloud account registers the device and everything works fine

          "Push" is working again on both counts

    -------------------------------------------------------------------------------- ---------------------

     

                      The solution above is the only thing that works for me, after creating a new iCloud account, on both my iPhone and my wife's, our old .mac/.me email accounts are working properly, and being pushed, can this problem only affect the old mac.com/me.com email accounts, prior to iCloud ??

                      I was a paid me.com customer, and the email accounts were created in me.com, but, when upgrading to iOS5, decided to convert the me email accounts to iCloud, so now I wonder if the old converted accounts are the only ones having this problem with push from iCloud ??

  • Munty Hoven Level 1 Level 1 (0 points)

    Working here so far (this is important but it's the furthest I've got). Thanks -very- much. Yours is the only non random suggestion (changing Apple ID passwords, keeping Mail running in the background and hoping, re-adding accounts etc.) that I've managed to find.

     

    This works on my iPhone and iPad; I created a new .me address in both instances. Not sure if I can now delete the superfluous accounts from both devices, but it doesn't matter. I'm not going to risk in the short term.

     

    Thanks again.

  • EdwinRamos Level 1 Level 1 (10 points)

    Glad it worked out, just to update you guys, I purchased the 4s, and this problem is also affecting the 4s.

    Apple, has to be aware of this problem, I just hope they find a fix for it soon !!!

  • Munty Hoven Level 1 Level 1 (0 points)

    Still working 100% after 24 hours by the way, thanks.

     

    The problem affected both my iPad 1 and iPhone 4 in identical fashion; seems to be iOS 5 and some (our!) MobileMe accounts specific?

  • arnoz Level 1 Level 1 (15 points)

    Tried MANY solutions but it still doesn't work for me. That .Mac/MobileMe to iCloud transition is the worst thing that happened to me as an Apple customer...

  • EdwinRamos Level 1 Level 1 (10 points)

    That's strange? It worked for me and several of my friends, you certain you did as to what I wrote?

     

    Maybe turning the phone off than on will get it going.

  • maxChile Level 1 Level 1 (0 points)

    Thank you, its work but if i desactive the new account, no more push working, so i have to leave 2 accounts ....

  • EdwinRamos Level 1 Level 1 (10 points)

                               i just got in contact with the Better Business Bureau, in my case its a paid service, since I was paid up with Mobile.Me when I converted to iCloud, I am totally dissatisifed with this NO PUSH issue, and when you contact support, they relate they haven't heard of this issue, and go through their scenario of setting up the iPhone, Reseting it, and even to completely restore it !! enough already, Apple has an issue with iCloud Not pushing email notifications, and I am tired of being treated as if the issue is on my end.