Previous 1 2 3 4 5 Next 1,021 Replies Latest reply: Jun 5, 2014 2:09 PM by chitwanX Go to original post
  • therealikt Level 1 Level 1 (10 points)

    It's not a hardware issue, it's software. For some reason, iOS is cycling the radio on and off, I'm guessing something mixed up with SIM pin permissions. What I had to do was turn on SIM pin, then off, at which point it demanded the PUK code. I was able to get it online through my ATT account. After I entered that PUK, then went back into settings and turned SIM pin off, I haven't had any problems.

  • JeffFromLO Level 1 Level 1 (5 points)

    Still having the same problem here.  I'm on Verizon in Porland, Oregon, USA.  My SIM PIN setting was never on.  I tried turing it on, it asked for a pin, I entered 1111, then turned it off, it asked for the pin again, 1111 entered, now its off.  This didn't fix the problem.  The only temporary solution I've found is to toggle airplane mode on and off.

  • rhysfromcape town Level 1 Level 1 (0 points)

    Thanks alot, I will try to hunt down my pin

  • Stuart Mchattie Level 1 Level 1 (25 points)

    Hi Jeff,


    Are you sure it was the SIM PIN you turned on and off and not the security lock? Normally when you turn on SIM PIN for the first time it doesn't ask you to enter a new code but instead to enter the one that's already set by default by your carrier. It may be coincidence that your carrier sets 1111 as a default and so then what you've said makes sense. Just checking in case you perhaps did the wrong thing to fix your problem. I've been problem free for over a week now so you may have another issue if this doesn't fix it for you.

  • JeffFromLO Level 1 Level 1 (5 points)

    Ya.  Pretty sure.  I go to settings, Phone, and the options on my screen read:

    My Number


    International Assist


    Verizon Services


    When I access SIM PIN, I am taken to a screen which as the following options:

    SIM PIN (on or off)

    Change PIN (disabled when SIM PIN is off)


    When I initially read through all these posts, I checked my SIM PIN and it was initially off (I just received the phone 2 days ago).  When I clicked ON, it asked for a pin.  Not knowing what to put in, I just put in 1111.  Keeping the SIM PIN on, did not solve the problem.  Turning it back off, it required me to enter the PIN again, so I put in 1111.  When off, the problem still persisted.

  • raff314 Level 1 Level 1 (0 points)

    Same issue here with AT&T in the U.S. midwest.  I just turned the sim pin on and off.  Hopefully this will fix it for now

  • JeffFromLO Level 1 Level 1 (5 points)

    Mine might actually be a different problem, now that I've dug into this more.  When I turn off WIFI, I don't seem to lose the connectivity to the internet anymore.  My wifi connection DOES work... its that is just STOPS working after 15 minutes or so.  Even when I'm right next to the wifi router.


    Oy vey.

  • lukbut Level 1 Level 1 (0 points)

    So disabling the PIN stops this from happening?

  • lukbut Level 1 Level 1 (0 points)

    It did indeed solve this problem! Turn it off for now guys!

  • rfc1437 Level 1 Level 1 (0 points)

    Same problem here (Germany). Got an exchange on the SIM card from T-Mobile, but same symptoms. Disabling PIN on the SIM card does help a little - it doesn't lock out completely anymore - but not fully solves the problem as it still randomly drops mobile data access. I can reenable mobile data access by going to settings and switching off mobile data and switching it back on, but it still is very cumbersome since I won't notice the dropped connection. And it looks like the system tries to reenable the dropped connection in the background and that is what eats up tons of battery juice - usually my phone drops from full to half battery during the night when it is just sitting in the cupboard.

  • therealikt Level 1 Level 1 (10 points)

    Apparently not. My phone did the same thing today, shut off, then switched back and forth dropping signal. Sim PIN on, off, doesnt matter. I'm trying a restory now, but this is pathetic.

  • PG Switzerland Level 1 Level 1 (0 points)

    I can confirm that I am seeing the same thing here in Switzerland with Swisscom. When the signal strength goes to zero (e.g in a tunnel), the phone then comes back asking for the PIN code. I also had the iPhone hooked up to my MacBook to make a debugging run of my app, and it looked like the 3G service never came back after signal loss. I know this as I log failed internet connections when retrieving background data (and I have never seen this type of failure before in my app).


    Additionally, google maps was not able to fetch data either. For now I have disabled the PIN code - I think I am voting software bug on this one. Battery life at the moment ***** as well....





  • therealikt Level 1 Level 1 (10 points)


    Went to the store, did another restore, and set up as new iphone.

    The guy's theory is there's a bad file/setting in the comcenter app (controlls the signals), and that by restoring from backup, its getting the same error.

    Guess we will see if it does it again.

  • M. Spock Level 1 Level 1 (0 points)

    Same problem for me with O2 (Germany). Turning off SIM-PIN solved the problem (for now). However, meanwhile I asked Apple to exchange Hardware (on it's way). Still curious to see if data connection will continue to work. Keep you posted.

  • dmaynard83 Level 1 Level 1 (5 points)

    So turning off the SIM - PIN did get it to work (for the most part). But every now and then I would get the "searching" mode, which is still very annoying because I would get missed calls at those time. So I went to the Apple store and had the phone replaced, and now it never goes into "searching" mode.

Previous 1 2 3 4 5 Next