Previous 1 2 3 4 5 6 Next 78 Replies Latest reply: Nov 26, 2012 7:09 AM by MuzMc Go to original post
  • jpainter Level 1 (10 points)

    Try this;

    1) Delete Exchange account.

    2) Create new Exchange account

    3) Fill in all information (do not leave Domain blank!  This is key.)

    Here's my brief video on this procedure

  • João Nogueira Level 1 (0 points)

    For those who tried almost every solution posted, i got it working just now.

    I have a Gmail account where i receive my most important emails, was having problems until i got it working through these following steps:


    1- Delete icloud account

    2- Reset network settings

    3- Add a MS Exchange account, no need to type Domain just email ( and username (same as email) and email password.

    4- In server field for Gmail accounts type

    5- When it asks for the password a second time, just go to type in something like "Iphone Exchange" and generate a password, type generated password on your Iphone.


    It worked for me hope it works for you all.



  • Darkpapa Level 1 (0 points)


    I am in the same case. Since one weeks, two of my users (Iphone 4S) couldn't synchronize anymore emails with Exchange server but before that was going. I need to tell that users (Iphone 3G, Iphone 3GS and Iphone 4) still working.

    I tried to remove 1 the icloud config 2 Resetting network config 3 removing exchange accoun and creating a new one (with domain) after a reboot of the Iphone.


    Without success, any other idea? Or is already Apple notified of the problems?


    Any help should be appreciate.


  • Finnish_Fox Level 1 (15 points)



    I've had my 4S since 10/21 with iCloud and Exchange working just fine. Recalibrated my phone last night (not the first time I've done so) and performed a soft reset earlier today (also not the first time I've done so) and I have had problems since.

  • alphabuild Level 1 (0 points)

    google posted a fix here

    and it worked for me




    Invalid Password Prompt. If you see an error message that reads "Invalid Password", it's likely that you'll need to unlock your account by solving a short CAPTCHA. Visit the appropriate link below and fill in your email address, password, and the letters in the CAPTCHA box:

    General users and Google Apps customers:

    Google Apps customers not yet on the new infrastructure: Be sure to with your actual domain name.

  • Finnish_Fox Level 1 (15 points)

    It fixed itself later that afternoon without following that process.

  • william jfromnewyork Level 1 (0 points)

    Hello, just today my Iphone 4s will not allow me to send emails via mircrosoft email address?
    Verizon, checked & said this is an IPHONE issue? Microsoft said the same? Apple is saying it is a Microsoft Hot email problem. Another agent at Verizon has the IPHONE, pluged in his Micro account & was not able to sen, only recieve, This is now happening on my IPAD.
    They have done everything to my phone, reboot, clear re-enter, disconnect ICLOUD.. Nothing has helped?
    This finger pointing is terrible............ Any suggestions or have you heard of this?
    THis is my 2nd Iphone & never had a problem with this or my ipad?
    Thanks for your help

  • RRSCJ Level 1 (0 points)

    I think is very simple: go to itunes - info and then you should do the syncs from there, even corporate email from outlook. no problem yet. good luck!

  • Etienne Low-Decarie Level 1 (0 points)

    Same proble with iPhone 4S and Exchange Server.  None of the solutions appear to work.

  • ALP_76 Level 1 (0 points)

    I was having similar issues setting up a MS Exchange email account for my work email - got the  "password incorrect" message too.  The fix for me was that I had to use the same login name as I would use for my company's webmail.  I left the Domain empty and used my webmail user name which is "domain\userid."  I also used the 3G network instead of wi-fi per our IT help desk but I don't know if that ultimately mattered or not.  Hopefully this helps someone who is setting up a similar type of email.

  • jensfromkumla Level 1 (0 points)

    The oddest thing... had problems witch new and changed passwords like above... seems like the bug occurs only when on corporate WLAN here!! DNS or NAT/firewall issue perhaps? sync works abs 100% apart from this.


    Mega annoying as it blocks all activities when asking for password. A true bug there, Apple.


    My solution - get out of wlan range or find a way to disable wlan (double klick - go to settings/WLAN)

    looks like the password already was changed to new .. just works again..


    SBS2003 all patches - iphone4 ios5

    25 iphone 3GS, 4, 4S all with latest IOS

  • dodgy_rodge Level 1 (0 points)

    I have the problem where all my two iPhones and iPad stopped receiving exchange email overnight on Sunday. I get the error "Checking for Mail" and the battery is drained quite quickly.  I have an iCloud account and two exchange accounts on the phones which have worked well since setting up up until first thing monday morning when I first had the problem. The phones are a 3GS, a 4S and the iPad 2. the 3GS was set up with exchange email in June 2011, the 4s in October 2011 and the Ipad about the same time too and all have worked brilliantly since. 

    Restarting the phone causes the Exchange email to synchronise on its first access, when the iPhone or iPad tries to sync the second time it hangs with the message "Checking for Mail" - leaving it checking for mail for 24 hours does not achieve anything - it is hanging, but strangely iCloud email will still come through (IMAP?)

    Googling this problem on the Apple forums shows that it has been around since June 2010, with a bulk of problems in October 2010 and November 2011 so the problem is pre IOS 5 - I have tried everything suggested: deleting the accounts and re inputting them, resetting the phone and setting it up as a new phone, setting up exchange without iCloud, resetting the network, resetting the exchange server, and nothing has worked.

    I have also tried my Exchange email on my daughters iPhone 4 (IOS 5) and it worked just fine.  I then also tried it on a friends brand new iphone 4s and it worked.  I have tried another work Exchange email address on my iPhone and it did not work either.  The two Exchange email accounts are on two different servers, one is our own email server and py prsonal email is hosed on

    The analysis is that it has to be something to do with either my iTunes set up or an application on my phone, but now I am stuck and am going to resort to going to an Apple store to see if one of their Genius people can solve it - I am really surprised that Apple have not come up with a solution on these discussions.

  • jsampson Level 1 (0 points)

    I have found the problem with exchange email not working (when connecting via WIFI) is that a specific wireless LAN is creating the problem. If I change from one wireless LAN to another it works again. If I reset the original wireless LAN (resetting the hardware) it works again. Seems to be an IP negotiation issue with WIFI and the Iphone 4. This problem only started when I use the iPhone 4.

  • canobeano Level 1 (0 points)

    This seems to be part of the problem. I deleted iCloud, reset my Network Settings and then re-added my work (Exchange) account. Now, everything works fine on wi-fi only. As soon as you turn off wi-fi and try using 3G, nothing comes through. I was told by IT, that this is due to AT&T's network, and that they've switched corporate accounts to Verizon because of it. Sounds dubious to me, but it doesn't seem like there's anything I can do about it. My iPhone is now completely useless to me as an "iDevice" when I'm on 3G. Fantastic.

  • linda147 Level 1 (0 points)

    I've been having the same issue now for a few weeks; I use a MS exchange account, and it will work fine, then start the spinning 'checking for mail' and it won't send or receive.  If I turn the phone on/off it will then push some email, then stop working.  Mine will work better when I'm in a wi-fi area, and then quit when I go to 3G.  I have tonight deleted all other accounts from my phone (using the gmail app to access that) and I'm going to see how it goes tomorrow.  I'm going to also delete the iCloud and see if that helps.


    I have an old original iPad where the email account is working just fine.


    I hope they can get this fixed, my tech support at my exchange server is flustered, too.  One thing he suggested is to turn OFF the "organize by thread" see if that helps someone.