Skip navigation

iOS 5 MS Exchange Problem on iPhone 4

140248 Views 78 Replies Latest reply: Nov 26, 2012 7:09 AM by MuzMc RSS
  • noodleheads Calculating status...
    Currently Being Moderated
    Jan 30, 2012 11:14 AM (in response to alphabuild)

    This worked and was exactly what the Google tech had me do when they called.  Thanks for sharing.

     

    Details:

     

    http://support.google.com/mobile/bin/answer.py?hl=en&answer=139635

     

    I removed the Exchange account, followed the step below, then added the Exchange account back in.

     

    From the above link, this is the portion I did:

     

    Invalid Password Prompt. If you see an error message that reads "Invalid Password", it's likely that you'll need to unlock your account by solving a short CAPTCHA. Visit the appropriate link below and fill in your email address, password, and the letters in the CAPTCHA box:

    General users and Google Apps customers: https://www.google.com/accounts/UnlockCaptcha

  • Webnerd-Dave Calculating status...
    Currently Being Moderated
    Mar 1, 2012 6:38 AM (in response to dodgy_rodge)

    Dodgy_Rodge, I'm having the same issue.  Did you figure out a fix yet?

  • canobeano Calculating status...
    Currently Being Moderated
    Mar 1, 2012 6:47 AM (in response to Webnerd-Dave)

    I don't think any of these solutions will actually work. I've been told numeous times now that this is another part of AT&T's attempts to salvage broadband. The City I work for has had to swich all of its accounts from AT&T to Verizon because of this. It's pretty useless to only be able to access your work email, contacts, calendar items and reminders while your AT work or on another wi-fi network, that's the entire point of MOBILE service.

     

    If anybody discovers a solution for AT&T iPhones, please share!

  • pedant Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 2, 2012 3:19 PM (in response to From Cape Town)

    I've been having the same problem:

     

    If I have an Exhgane account and iCloud account enabled, my Exchange mail and calendar don't sync/come through.

     

    Solution: I have found out than I can have my Exchange and iCloud email coming through--I just have to keep iCloud Contacts switched off.

     

    It is quite annoying.

  • Jimmyboriquo Calculating status...
    Currently Being Moderated
    Mar 16, 2012 2:08 PM (in response to lanie3261)

    ok guys this is the problem - its to do with 2-step verification with gmail.

     

    follow the directions here:

    https://support.google.com/accounts/bin/answer.py?hl=en&answer=185833

     

    when you generate a code, THIS is what u use on your iDevice as your log in email password, NOT your usual password.....trust me, ive just done it with my new iPad 3 ;-)

     

    good times.

  • huddyishere Calculating status...
    Currently Being Moderated
    Mar 20, 2012 9:20 PM (in response to lanie3261)

    Hey All,

     

    i am no genius, but this happened to me, so I read through the other comments and found that maybe registration of my gmail account had changed things.  So i changed my user name and my email account to my gmail account name and now everything works fine.

  • Steve Stoltz Calculating status...
    Currently Being Moderated
    Mar 23, 2012 10:17 PM (in response to huddyishere)

    IPad 2 with exchange,

    I thought I read an email but the I couldn't find it again.  I had it resent so I know the original was sent a 4:51 pm.  I checking and there were no emails at that time, just a suspicious 51-minute gap (I get 100 email per day).

    Then I tried a search for the keyword, "Trayvon, " and there it was, the missing 4:51 email with the original message. I cleared the search window and the email wet away.  I repeated this on my iPhone with the same results. 

     

    Then I turned them both off and on...No change.

    Then I turned the email account off and on,,,no change

    Then I loaded OS 5.1, no change

     

    I just doesn't work.

     

    Steve Stoltz

  • josh44 Calculating status...
    Currently Being Moderated
    Apr 24, 2012 8:22 PM (in response to noodleheads)

    Thank you thank you thank you.  FInally an answer that solved this issue for me.

     

    Thanks.

  • loveevaid Calculating status...
    Currently Being Moderated
    Apr 29, 2012 1:36 AM (in response to noodleheads)

    Yesssssssssssssssssss! it works.. Cheers!!!

  • pedant Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 29, 2012 4:19 AM (in response to loveevaid)

    The solution is an answer to those with Gmail problems, right? What about the Exchange problem (which is the subject of this thread)? What's the solution for that?

  • linda147 Calculating status...
    Currently Being Moderated
    Apr 29, 2012 7:35 AM (in response to pedant)

    I solved my Exchange problem by moving to a different Exchange host; I'm seeing differences in my download times (which I attributed to the phone) and other issues that have cleared up since moving...I went to Rackspace.  Their tech help is great, and they don't give up until they solve a problem. 

  • msjazzamatazz Calculating status...
    Currently Being Moderated
    May 4, 2012 10:26 AM (in response to lanie3261)

    Possible solution - worked for me:

     

    After spending hours playing around with 2 step verification:

     

    I don't know what made me try but when I first registered a google account, the address was @googlemail.com, and then turned into @gmail.com. For some reason I thought I'd try setting up the exchange on my iPhone with the address listed as googlemail rather than gmail. It has worked fine on my iPhone and iPad, in conjunction with the random password generated by 'authorised applications and sites'.

     

    This method is also working whilst I have another work exchange account synced with the same phone -  I've read that people have had issues using 2 exchange accounts simultaneously.

     

    Thanks

  • Mvandevender Calculating status...
    Currently Being Moderated
    May 7, 2012 2:29 PM (in response to msjazzamatazz)

    I have the problem of Exchange and AppleID passwords occasionally not being recognized by the iPhone 4 running IOS5.  In the case of the Exchange account it seems to occur when the password is changed by the user from another device.  And it doesn't always happen, and it doesn't matter if there are multiple Exchange accounts on the phone.

    The Solution I have found:  REBOOT THE IPHONE.  It works every time for both accounts.

    To reboot, press and hold the top button and the button on the face until the screen presents a slide bar to turn off the device.  Slide the bar.  Once the phone is powered off, press and hold the top button until the apple icon appears on the phone. 

  • Xzavier Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 16, 2012 1:57 AM (in response to lanie3261)

    Sadly, all I see in this thread and similar threads describing the same problem are a lot of temporary workarounds and no real solution. I've done extensive troubleshooting on this issue to isolate the problem and in our case the source of the problem was an account setting in Active Directory. But the actual problem is a bug in iOS Mail app, which has to be fixed.

     

    I discovered that the few affected accounts in my organization had a limited "Logon hours" setting applied in their Active Directory accounts, which prevented logon during the night. Their devices, both Android and iDevices, wanted to check the mail even during the nights. Users who didn't have "Logon hours" set in their AD profiles were not affected by the problem described. Android devices were also not affected in the same way as iDevices (many users have both iOS and Android devices, so this was easy enough to confirm). Sure enough, Androids couldn't recieve new mail during these hours, but they didn't complain about "wrong password" or anything, and just nicely fetched the mail when the allowed logon hours came around again. However, and this is the big thing, iDevices were all thrown into the infinite "incorrect password" loop.

     

    So this IS a bug in iOS, and it's been there since at least iOS 3.0, and it NEEDS to be fixed by Apple, and now we've found another confirmed triggering mechanism for this bug. My temporary workaround is to disable "Logon hours" limits for all users, but this is merely a trigger, so the bug in iOS itself needs to be fixed.

  • jg1969 Calculating status...
    Currently Being Moderated
    May 18, 2012 9:22 AM (in response to Xzavier)

    I am having exactly the same issue, I hope your AD idea works   I changed my Windows/Exchange password yesterday and now am getting the "incorrect password" pop-up that makes my iPhone useless.  Entering the correct password does nothing and I can't cancel the pop-up either.

     

    I found out that by power-cycling the phone I could get out of the infinite loop and the phone even remembered my new password.  Pretty annoying to say the least!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.