1 2 3 4 5 6 Previous Next 78 Replies Latest reply: Nov 26, 2012 7:09 AM by MuzMc Go to original post
  • 60. Re: iOS 5 MS Exchange Problem on iPhone 4
    ilovehateapple Level 1 Level 1 (0 points)

    What worked for me after many hours of frustration.

     

    1. Change gmail password via pc.

    2. Enable 2 step verification.

    3 while enabling 2-step use the option to generate "application specific password"

    a 16 character pw is generated for you on the pc.

    4 On Iphone delete old non working gmail account then create new gmail account using the 16 character pw generated earlier instead of your actual gmail account pw.

    5 enjoy finally an all singing dancing working gmail account on Iphone/ipad etc.

     

    phew!!!!

  • 61. Re: iOS 5 MS Exchange Problem on iPhone 4
    Xzavier Level 1 Level 1 (0 points)

    I am still surprised when reading this thread, to find suggestions relating to GMail. This thread is about iOS issues relating to internal corporate Exchange servers.

     

    Yes, GMail can use the ActiveSync connector, and it can trigger the same bug in iOS due to this "second password" thing they've got going, and the triggered behavior is the same: iOS doesn't understand what the server is saying, it only understands that the logon request was refused, so it assumes that it must be because of an incorrect password, and goes into an infinite loop asking for it (even though it does have the correct password on file, this bug persists until the device reboots even if the server would accept the logins again - you can confirm this by listening: when the logon is allowed again on the domain, the iDevice starts getting mail again and you get the notification sound, but the password dialog blocks the display). More people need to raise this bug with Apple Support so the iOS developer team can get around to fixing it.

     

    Now, in my case, the trigger really was the Logon Hours setting in AD. After setting all user accounts to allow logon to the domain 24/7, noone has had the password bug triggered on their iDevice. So if your environment is an AD domain, that's the first thing to check on any account that gets this problem.

  • 62. Re: iOS 5 MS Exchange Problem on iPhone 4
    ilovehateapple Level 1 Level 1 (0 points)

    Dooooh!!!!, sorry just skimmed the thread , guess I should pay more attention .

    Anyway someone may find it useful ..... or not.

  • 63. Re: iOS 5 MS Exchange Problem on iPhone 4
    Mattvic Level 1 Level 1 (0 points)

    Correct Steps to Follow:

    ===================

    1) Remove Apple iCloud account -- delete as appropriate after backup, etc.

    2) Add Microsoft Exchange account -- do *not* turn on sync contacts

    3) Add Apple iCloud account -- do *not* turn on sync contacts

    4) Test and verify account settings, etc.

     

     

    This one worked for me. Still a pain as my contacts are all in iCloud.

  • 64. Re: iOS 5 MS Exchange Problem on iPhone 4
    b4rt0s1k Level 1 Level 1 (0 points)

    This might be related,

     

    if you have Exchange password issues, try resetting the iPhone by holding home + power until the apple logo appears; this takes about half a minute, you will see the shut-down slider appear, then the device will shut itself off, then it will restart and the apple logo appears. This is safe and will not delete any of your data nor settings.

     

    I have 4 accounts, one iCloud, two Exchange accounts of which one is for GMail and the other for a corporate Exchange account, and one for a google calendar.

     

    When I change my Windows password (AD domain account password), the iPhone promptly requests me for a new password, which I give and the iPhone will happily continue to fetch new emails. Until a few hours pass, after which it will receive no more email. When trying to update that Exchange account, either it will try to update "forever" or sometimes give a pop-up "Cannot Get Mail - The connection to the server failed"

     

    This has happened multiple times after a password change. First time around I didn't get exchange email to my iPhone for about a week and much fiddling was done all over the place, passwords were changed on both Windows and in the iPhone, at some point after resetting the device the account worked again.

     

    Today I had the same issue, I changed my windows password, entered the new password into my iPhone when it requested for it, mail continued to work until late evening when it stopped to receive updates. This time the only thing we tried to do to resolve the issue was restart the phone, which did not help, and resetting the phone, which resolved the issue (I've also sent a bug report to Apple)

  • 65. Re: iOS 5 MS Exchange Problem on iPhone 4
    mjlee99 Level 1 Level 1 (0 points)

    I am having the same issue and it is frustrating.  I am unable to synchronize my google contacts because of it. Any updates on a fix?

  • 66. Re: iOS 5 MS Exchange Problem on iPhone 4
    peraza Level 1 Level 1 (0 points)
  • 67. Re: iOS 5 MS Exchange Problem on iPhone 4
    RobKendrick Level 1 Level 1 (0 points)

    For Exchange Admins:

     

    Double-check your users' account settings to include the full domain.  Instead of entering the domain as "mycompany," make sure you have it as "mycompany.com" or "mycompany.net"; whichever is applicable.

     

    This resolved the issue this morning with one of my end-users, and we did not need to remove or re-add either the Exchange or the iCloud account.

     

    I hope this helps!

    Rob

  • 68. Re: iOS 5 MS Exchange Problem on iPhone 4
    olegm Level 1 Level 1 (0 points)

    I have a similar problem.

     

    When on local WiFi connection in my home, the mail client asks me in the loop to re-enter the password.

    I disabled WiFi, then everything started to work fine.

     

    On occasion, I have a problem sending e-mail to the Microsoft Exchange server.  It would stay in my outbox for a few minutes, and then succeed.  This happens regardless if I am on the WiFi connection or 3G.

  • 69. Re: iOS 5 MS Exchange Problem on iPhone 4
    Tsukey Level 1 Level 1 (0 points)

    Great! That's all you need, thanks you solved my problem ;)

  • 70. Re: iOS 5 MS Exchange Problem on iPhone 4
    RobKendrick Level 1 Level 1 (0 points)

    Olegm, check to see if your router has a DNSMasq option turned on.  If so, disable it, save/commit (some routers need to reboot as well) and then try to reconnect.  DNSMasq helps protect other computers on your network from a DNS Rebinding attack, but if you're not already blocking client-side scripts in your browser, a DNS rebind is the least of your worries.

     

    I hope this helps.

    Rob

  • 71. Re: iOS 5 MS Exchange Problem on iPhone 4
    PRASHANT VATS Level 1 Level 1 (0 points)

    Have you got solution for your problem or not.

  • 72. Re: iOS 5 MS Exchange Problem on iPhone 4
    PRASHANT VATS Level 1 Level 1 (0 points)

    Will Not Have any problem do as i say or follow flow chart.

     

    1 Go To Settings

    2 Tap Mail, Contacts,Calander

    3.Tap Add Account

    4.Tap Microsoft Exchange

    5 Now Enter your email id for example- abc@gmail.com

    6. Leave the domian blank

    7.Re Enter your email id in Username tab instead of Username or in other words your user name would be similer  as your email id.

    8. Now enter your password in Password Tab.

    9.Tap the Next

    10. Enter your company server name into Server tab.

    11 Now you are ready to use your mail box.

     

    Looking for your Feed Back

     

    Bye

  • 73. Re: iOS 5 MS Exchange Problem on iPhone 4
    tysonnsilva Level 1 Level 1 (0 points)

    user@googlemail.com should be user@gmail.com seriously made that change and it worked for me.

    for safe measure go here first...

    http://support.google.com/mobile/bin/answer.py?hl=en&answer=139635

  • 74. Re: iOS 5 MS Exchange Problem on iPhone 4
    sailawayny Level 1 Level 1 (0 points)

    Confirmed. This just worked for me.