Previous 1 2 3 4 Next 53 Replies Latest reply: Jul 11, 2013 5:34 PM by jessefromsanta barbara Go to original post
  • oldmactom Level 1 (0 points)

    Hi there,


    Just wanted to chime in I had the same issues with the massive CPU usage that was illustrated in the ubiquity.log in the Console.  My process was given as 'securityd' in Activity Monitor.


    At the moment, I've stopped the process from starting up by moving the /Library/Preferences in my user folder out and then restarting.


    From there, I'm going to move back in all non-"*" related preferences since this seems to be MobileMe->iCloud related.  I will then incrementally add in Apple-related preferences into the folder again and see if I can nail down the offending file.

  • oldmactom Level 1 (0 points)

    From what I can see, it looks like '' was the offending file for me.  I was able to copy all my other preferences back in.


    What I did was log into iCloud via the System Preferences without the old '' file (Apple generates a new one automatically after you've moved it out).


    If you do a comparison of the two plists (short for 'property list'), mine was clearly different.   I only imagine it was causing the issues.


    For the curious...

    In Terminal, go to the old Preferences folder :

    cd ~/Desktop/Preferences (where I copied mine to)
    then view the plist file

    plutil -convert xml1 -o -


    then go to the new Preferences folder
    cd ~/Library/Preferences/
    then view the new plist file

    plutil -convert xml1 -o -


    The new one has a lot more keys and configuration for me once I logged into iCloud, which looks like it resolved the issue!


    So happy to have my battery life back...  yeow!

  • Z42 Level 1 (0 points)

    I developed the same issue when I did a software update last night.  ubd was cooking my cpu.  I only had about 6 ubiquity certificate entries in keychain and I made them all trusted.  There were a rapidly increasing  number of log files in  Library/Logs/Ubiquity/user/ that were 10MB each.  The rights on the directory were correct.  None of this fixed the issue, so I finally renamed ubd and rebooted.  No more cpu I just have to find out what doesn't work because I renamed ubd.

  • Ivar Hosteng Level 1 (15 points)

    I had the same problem on my macbook air on 7.3


    It turned out that the directory /Users/ivar/Library/Application Support/Ubiquity was owned by root and not me. Once i fixed the ownership everything settled down and my cpu is back to sub 60 (celcius).



  • xelag Level 1 (0 points)

    I know that I'm on a Mac forum, but I have exactly the same problem... but on my PC with Windows 7!


    The computer freezes, the fan turns quicker - the CPU is certainly around 100%, and after 60-90s, it comes back to normality with a few hiccups.


    Each time it occurs, in the event log, during this period of time, it's indicated that the app ubd.exe has crashed with a failing module ubd_main.dll (located in C:\Program Files\Common Files\Apple\Internet Services).



    I would really appreciate if someone could tell me how to solve this issue or to neutralize it by desactivating the automatic run of this app.


    Thank you very much,


  • James Hunkins Level 1 (0 points)

    Between all of the responses I found the fix for me too, which also fixed any programs that were trying to access iCloud getting stalled during start (such as textedit and Pages).

    Looking into the log file



    I found that permission to create a directory was being denied.  This was in:

         ~/Library/Application Support/


    The permissions showed read/write for me but for admin, it only showed read which did not make sense. I changed the admin for that directory and everything within it to be read/write also.  UPD usage immagedly dropped to < 1% and the different apps started opening and running as expected.


    I did also notice a slew of ubiquity.peer-uuid certificates so to be safe, I reset my keychain to the system default (had everything also stored in 1Password so no risk to that).


    Everything is running great now - thanks to everyone's tips.

  • hayaza Level 1 (0 points)

    i have the same problem and its driving me INSANE! the problem is however, i cannot open keychain access! when i open it it instantly freezes and i have to force quit, so i dont even have the chance to repair it or anything! can anyone help out or knows of a work around? thanks!

  • hayaza Level 1 (0 points)

    wait i got it working.... the rights of the folder ~/Library/Application Support/Ubiquity/ was incorrect. The owner was the root, I change it to me.... thanks to @diglin for this! you life saver!!!

  • waferbaby Level 1 (0 points)

    I, too, had the same issue crop up. I tried all the suggested options with Keychain Access without luck. I was seeing this in Console, over and over:


    [12/09/30 15:59:40.305] "id:0x0008000000000102" failed downloading from "iCloud" (0 bytes, id:0008000000000102, reason:"no peer available for transfer")


    The one thing that *did* fix my issue was actually disabling the 'Documents & Data' portion of my iCloud account - the second I did that, the errors in the log files went away and the CPU went back to normal. Hope that helps, since it was driving me crazy (I thought my laptop's battery was dying before I worked out what was going on!).

  • An Average User Level 1 (0 points)

    I have (hopefully "had") the same problem this question was describing, it was driving me insane with the fan turning max speed and the CPU super hot.


    After reading the entries here, I realized that the keychain might be a place to look at: in my case, I turned off wi-fi, so the Ubiquity would not make calls to the net.


    Then run Keychain Access and saw, as described in this thread, hundreds of entries that would make it super long. So I followed the procedure to reset the Keychain (I have my passwords stored in 1Password anyway):



    To reset your keychain in Mac OS X 10.4, Mac OS X 10.5, and Mac OS X 10.6 Snow Leopard or later:

    1. Open Keychain Access, which is in the Utilities folder within the Applications folder.
    2. From the Keychain Access menu, choose Preferences.
    3. Click General, then click Reset My Default Keychain.
    4. Authenticate with your account login password.
    5. Quit Keychain Access.
    6. Restart your computer.

    As Apple itself suggests it, I thought it could not be too dangerous, plus the old keychain is not deleted but only renamed.


    That did it.


    The crazyness stopped and all went back to normal.


    Incidentally, I checked in the Library/Application Support/Ubiquity and that folder was 4 Gb (Giga!), full of thousands of Ubiquity entries. I emptied it to see if I could recover the space (I copied it temporarely on my desktop to see if something goes wrong, then I'll delete it later), and all is well.


    So, bottom line, resetting the keychain fixed the problem on both my Mac (MacBook Air and MacBook Pro, both with Mountain Lion)


    Thanks to all for sending me in the right direction: hopefully this will help somebody else.

  • An Average User Level 1 (0 points)



    Unfortunately it did not work... the keychain file is still very clean and looking good, but the dreaded ubd process is back in the same way as before.


    I gave up and took the Mac to the Genius bar: they are running tests and see if they can conclude something more useful than I did.


    Sorry I could not report better news...

  • An Average User Level 1 (0 points)



    The Genius bar folks were not more knowledgeable than I about UBD and all the intricate details of this issue.


    But the person in charge of my case offered to keep my Mac (Book Air) and run some tests.


    He suggested that maybe something might have been gone wrong with some files in the Library: maybe forcing Mac Os to rebuild it might have some positive impact.


    After asking my permission, he did so (slightly annoying having to set again my preferences: he warned me and I accepted that downside) and let the machine run several hours. No bad behavior.


    I picked up the machine few hours later, took it home and until now all is good and working: no more crazy behavior in the Library/Application Support/Ubiquity folder (now there are two subfolders and that's it), no more ever-growing keychain file.


    Bottom line: forcing Mac Os to rebuild the Library folder fixed it for me. How he tactically did it I don't know, I just gave the ok to do it and at this point I am not interested in learning more details on that, but I am confident that procedure is detailed in the discussion forums.


    Hope this helps

  • An Average User Level 1 (0 points)



    one week in, all is good.


    Rebuilding the Library solved the problem for me: thank you to the Genius bar.

  • TomorrowPlusX Level 1 (0 points)

    Is there any way you can find out what was involved in "rebuilding" the library? I have been completely unable to fix this problem, and ultimately have had to disable syncing of documents/data.

  • D1234r Level 1 (0 points)

    Hi there the UBD process seems to be associated with iCloud and specifically iMessage. I have noticed that if iMessage is open but only running in the background (no window is open but the icon in the dock is illuminated underneath) this used to caused the UBD process to randomly use massive ammounts of my processor.


    1. To remedy this I signed out of iCloud, unticking all the sync boxes first and then signed back in.
    2. I then deleted all the messages off the iMessage inbox (they still remain on my iPhone and presumably will on other idevices).
    3. After this I closed and reopened iMessage and the UBD app does not abnormally use processor.


    If this does not work for you perhaps the issue is with another icloud app and I would try opening iCloud apps individually and monitoring UBD in system monitor to check for processing spikes and if the problem can't be isolated I would try deleting icloud data off your mac intially and then from icloud icloud itself completely as another potential fix if the processor usage is that great an issue. If deleting documents remember to make a back up!


    OSX 10.8.2


    Hope this helps