Previous 1 2 3 4 Next 289 Replies Latest reply: Oct 31, 2014 7:39 AM by danthe93 Go to original post
  • peter1983 Level 1 Level 1

    You guys are all welcome I honestly stumbled on that one by accident. I am glad it worked for you guys.

  • christopher175 Level 1 Level 1

    I now have it working on the Samsung Galaxy S2 in the native email app.

     

    I noticed a couple of people have posted about success after changing passwords. A password change has worked for me.

     

    The issue appears to be that the password requirements for Apple IDs have been tightened up since many of us originally set our passwords. They now need to be longer, with a capital letter and a number as well.

     

    Once you have a compliant password you will be able to set up the account. NB I didn't need to use the 'p07-' etc, I just used imap.mail.me.com. SSL and TLS settings as per Peter 1983's email

  • MyMac8MyPC Level 4 Level 4
    expertise.macosx
    Mac OS X

    Try:

     

    • Server name: imap.mail.me.com
    • SSL Required: Yes
    • Port: 993
    • Username: example@me.com (use your @me.com address from your iCloud account)
    • Password: Your iCloud password
  • J0eMacint0sh Level 1 Level 1

    The settings below worked for me in a variety of Android devices... Galaxy Tab, Galaxy S, Galaxy Tab, Galaxy S2, HTCs, Motorals, LGs and even on those chepos they sell here in Europe.... in Android 2.x - 3.x and 4.x -

     

    One thing though... the iCloud accounts I created with my Macs took a little longer to verify the SMTP server that the ones I created with my iPhones. But hey it worked... iCloud mail on iPhone works great... messages dont PUSH though so you gotta set it up to pull the mail every 5 minutes or so...

    iCloud Mail Android Settings - pic.jpg

     

    Joe Macintosh

  • RayfromElPaso Level 1 Level 1

    This one worked for me Great!

  • helosk Level 1 Level 1

    I'm on the Galaxy Nexus running 4.0.1 and I just can't seem to get iCloud working on this device.

     

    I get the message - "Can't safely connect to server (javax.net.ssl.sslprotocolexception: SSL handshake aborted" and a string of error codes...

     

    Anyone have any ideas?

  • shafty023 Level 1 Level 1

    Hey there I'm the developer of Enhanced Email. Just wanted to say THANKS for being an EE user. I stumbled across this thread while trying to help an Amazon appstore EE user which wrote a review (http://www.amazon.com/review/RWL5BMCP6F8WT/ref=cm_cr_rdp_perm?ie=UTF8&ASIN=B0052 TS8OY&nodeID=&tag=&linkCode=) saying EE didn't work with apple iCloud accounts. I directed the user to this thread in hopes Peter1983's solution fixes it for them. While I likely won't see your response (if you give one) since I don't peruse the Apple forums ever I just wanted to drop a quick post saying thanks for using EE

  • hector2012 Level 1 Level 1

    SUCCESS!!!!!! FINALY ON MY SAMSUNG NOTE AND K-9 EMAIL

     

    Hi all ,

     

    I have a Samsung Note Rooted and Unlocked ,had a lot of problems with the icloud mail on my Note .

    FIrst go to the system preferences and go to Internet and wireless ,

    then go to mobile me ....log in with your password and when thru clik upgrade to icloud.

    Thats it ..

    the settings working for me are

    incoming: imap.mail.me.com

    SSL (IF AVAILBLE)

    PORT 993

     

    OUT GOING

    SMTP.MAIL.ME.COM

    SECURITY :NONE

    PORT 587

    TICK REQUIRE SIGN IN .

     

     

    IT WORKS FOR ME .

  • theGERV Level 1 Level 1

    Hey Helosk... I have the Nexus as well and the tip from MyMac8MyPC works perfectly.

     

    Cheers.

  • cjohn Level 1 Level 1

    I have tried all the combinations and tried changing passwords but cannot get to work on Sony Xperia Arc S. Have used K-9 and Maildroid. Any ideas anyone?

  • hector2012 Level 1 Level 1

    Hi ,I finally got it to work i have a SAMGUNG NOTE and i use K9 ,here is what i had to do .

     

    1: go to the Apple system preferences .

    2:go to mobile me....and here i ticked the box saying tick to upgrade to icloud...

    3:go to mail,contacts&calandars .

    4:go to icloud and tick all the boxes u want for icloud .

     

    5: go to your android email app..i tried bothe the stock app and k9

    6:username  bob@mac.com  (eg)

    7:your password

    8: imcoming server is :   imap mail.me.com   ssl if available  port 993

    9:outgoing server    smtp.mail.me.com   port 587

     

    tick requires sign in and the worked for me ......the mistake i was making was not ticking the old mobile me upgrade tick box ...now it all works but i find the email does not push ..but i have to pull . hope this is a solution for you pls let me know how it goes .

  • cjohn Level 1 Level 1

    I tried it but still no luck. Running out of ideas now as all my settings seem correct.

  • SilentAbe939 Level 1 Level 1

    Just used this method on my Galaxy Nexus running 4.0.3 in the build in email client. Worked instantly. Thank you very much man.

  • hector2012 Level 1 Level 1

    so it was the mobile me tick boxright??? any way it worked for me .

  • hector2012 Level 1 Level 1

    however i have yet to get it to work like push mail ..which mobile me did ..at the moment i have to pull the mail by polling every 15 min .if you can figure out how to get push icloud mail would be great .

Previous 1 2 3 4 Next