Previous 1 2 3 Next 36 Replies Latest reply: Mar 20, 2013 3:13 AM by Tokyo
texasgal34 Level 1 Level 1

I have created a flyer using Pages and I'm using a font I downloaded called "Drift Type". I have used this font before several times with no problems but this time it won't print the O's. I have saved as PDF & JPG and the O's disappear there as well, but when I pull up the Pages file they are there (just won't show up when I print). I tried it with a different letter and it works fine. I tried using a zero, but the font does not have numbers. Can anyone help me??


MacBook Pro
  • fruhulda Level 6 Level 6

    Open Type Book and validate the font. You have to look in the menus as I can't remember in which menu the option is.

     

    Maybe you have to reinstall the font. Maybe you have to delete the font cache. Can be done with the eminent free application Onyx.

  • texasgal34 Level 1 Level 1

    I validated the font and it's good. I am now trying to delete the cache, but I can't figure out how to do it. I Googled it and can't find instructions for OS X 10.6.8, which is what I have.

  • texasgal34 Level 1 Level 1

    Also, tried to reinstall. Nothing has helped yet. BTW, thanks for the advice.

  • PeterBreis0807 Level 7 Level 7
    expertise.iwork
    iWork

    With free fonts you get pot luck as to the quality and whatever the designer has done to them.

     

    It is possible the design has included a screen character but not a postscript/truetype vector for the glyph.

     

    I had bought a set of fonts that cost me a complete reprint when it turned out it did not have @ character for use in emails on all the clients stationery.

     

    Having said that I DLed the font from http://www.dafont.com/drift-type.font and checked it in Adobe Illustrator and it seems fine. DL the latest version and check it in both Pages and some other software.

     

    Peter

  • texasgal34 Level 1 Level 1

    It works great in MS Word. I also downloaded it from dafont, so I don't know what the problem is. I got desperate and started playing around to see if I could come up with anything to fix it and I finally did. I had to turn the caps lock on and the O's magically appeared....some other letters then disappeared, so I turned them off and added them back in. It's crazy!! Thankfully, it's fixed though. I just hope I can remember what I did for next time! lol Thanks a bunch!!

  • PeterBreis0807 Level 7 Level 7
    expertise.iwork
    iWork

    DLed the same version? ie the latest? Fonts do get updated, in fact there is a note to that effect under the font.

     

    It sounds to me like you may have something like auto substitution set in preferences and it is using references to parts of the font that may not exist, although without seeing what you have done I can't tell why it appears on screen but does not print.

     

    What you have typed in MsWord and what you have typed in Pages may not be the same. You could try starting with a neutral input such as a complete alphabet typed, copied and pasted from say text only TextEdit and see what that produces.

     

    Very likely the error is in the font and not necessarily in Pages, although the settings in Pages may be revealing the font errors.

     

    Peter

  • Tokyo Level 1 Level 1

    I have the same problem.

    Pages corretly showed the letter O on screen.

    The letter O is missing when saved as PDF and when printing.

    I wrote text in TextEdit, then used Print, then Save to PDF, the O was missing.

    I opened the text file in Acrobat Pro and it has a tall rectangle where the O should have been.

    I created text in Pixelmator and saved as PDF. It displayed the O correctly.

     

    I was using Edwardian Scrip ITC, other similar fonts printed the O correctly.

     

    Any thoughts?

  • fruhulda Level 6 Level 6

    Yes, do some maintenance of you computer. Restart the computer, then use Onyx to delete cash files, repair permission etc..

  • Tokyo Level 1 Level 1

    Thanks for your help.

     

    I repaired permissions and deleted the Font cashe with OnyX, rebooted etc.

    But the O still does not appear when Exported to PDF.

    It displays correctly in Pages, the same for TextEdit.

  • fruhulda Level 6 Level 6

    That is weird as I can't reproduce the problem. This is in Preview

    Bild 2013-03-17 kl. 10.57.47.png

     

    My system is 10.6.8. Pages 4.0.5.

     

    Maybe you have a corrupt com.apple.iWork.Pages.plist. Have you deleted it from Users > your name > Library > Preferences

  • Tokyo Level 1 Level 1

    I have...

     

    com.apple.iWork.Pages.LSSharedFileList.plist

     

    com.apple.iWork.Pages.plist

     

    Should I delete both?

  • fruhulda Level 6 Level 6

    You can but the LSSharedFileList is only for opening recent documents

  • Tokyo Level 1 Level 1

    Thanks.

     

    I will delete Pages.plist and test.

  • fruhulda Level 6 Level 6

    I hope you test on a new blank document because saved documents will not change behaviour.

Previous 1 2 3 Next