2 Replies Latest reply: Jan 7, 2012 12:24 PM by Joscary9
acognato Level 1 Level 1 (0 points)

I was SO excited about iCloud. Nothing is more frustrating then going to my iMac to send an email message via Mail, then go to my macbook and remember I don't have access to this sent message!! I want all of my mail folders to sync on all of my Mac devices (MacBook, iMac, iPhone, iPad). This would seem like a common problem, but I cannot find an answer to this anywhere thus far. Can someone help?


MacPro, Mac OS X (10.4.8)
  • Csound1 Level 8 Level 8 (41,420 points)

    You do not synchronize in iCloud, your local account (mac/ipad/iphone) is a locally cached copy of the account stored on the iCloud server, whatever changes on the cloud is reflected on the clients (mac etc).

     

    You get all the folders your device can (or is set to) display, that certainly includes inbox / sent / trash etc

  • Joscary9 Level 1 Level 1 (10 points)

    I have been struggling with this issue as well and after reading a number of posts on various approaches to deal with it, I have found a solution that appears to work.  This assumes that you want to use your your current POP e-mail address as your primary e-mail address rather than switching to an @ me address. This also assumes you have already established an iCloud account, and in turn, have created an @me e-mail address which enables iCloud for mail.  Here's a summary of the steps.

     

    Enabling POP mail in iCloud using the Apple Mail application

     

    • Log into “My Apple ID” on the Apple support page and add and verifyyour POP e-mail address as a alternate ID.  (For example xxxxxx@comcast.net)
    • Log into your POP e-mail provider’s e-mail preferences screen and add forwarding rules to your POP account. The most important rule to add is one that will forward any e-mail received by that POP e-mail address to your @me e-mail address.  Over time, you may need to add a few others to ensure that all e-mail that otherwise would be received at the POP address is forwarded to your @me address.
    • Open the Apple Mail application and go into preferences.  Click on the accounts tab and take thefollowing actions:
      • Ensure that your POP account with your preferred e-mail address is setup as an account.  Follow the normal process for doing this. Leave the “Use only this server” box unchecked.
      • Go to your iCloud account, and in the box for e-mail address, add the POP e-mail address that you have now added as an alternate Apple ID on the Apple website in front of the @me address already there.  Then, go to the tab for outgoing mail server and choose the POP account server. Finally, check the “Use only this server” box.  You can now save and close preferences.
    • In the Mail application, you can now create iCloud folders and/or On My Mac folders as you like.  Once allthese steps are taken, e-mail sent to your POP e-mail address will enter your Inbox as iCloud mail, and thus will be visible on all computers set up thisway.  In addition, you will be able to see this e-mail on all your IOS 5 devices.  Mail you send, or responses to mail you receive will also become iCloud mail and will thus be visible on all your devices, but it will be sent from your POP e-mail address.   Any mail you move into an iCloud folder will now appear on all your devices (mail in an On My Mac folder will only be available on that computer), and finally, when you delete any iCloud message, it will be deleted on all your devices.

     

    Open issues and questions

     

    • You will note that after you take the aforementioned steps, if you go into your computer’s main preferences, and select iCloud, the “Mail and Notes” option will now be unchecked, even though you would have checked it when you first set up iCloud for mail.  Not sure why this happens, because mail synching occurs as it is supposed to.
    • In addition, if you go into the accounts tab in the Mail Application’s preferences, you will see that the iCloud account has been renamed iCloud MobileMe IMAP.  Again, not sure why this happens, but it seems to work correctly nonetheless.
    • When sending Mail from an IOS device (iPad, iPod, or iPhone), if you want to be certain that it sends from your preferred POP e-mail address, you will have to select that “from” address before you send the message.  Would be great if someone has figured out how to configure these devices so that happens automatically.   Finally, mail sent from these devices when your POP e-mail address is used will not show up in iCloud sent mail on your other devices unless you manually move the message to the iCloud sent mail folder.  Again, if someonehas figured out a fix for this, that would bring everything together.