1 Reply Latest reply: Dec 16, 2011 9:01 AM by ratbatblue
tommclaughlan Level 1 Level 1 (0 points)

I have several email addresses associated with iMessage, including my main personal address and my work address. I've marked my personal address as Caller ID in Message settings. However, whenever I send an iMessage - from my iPad or iPhone - my work address comes up as the identifier on the recipient's iPad/iPhone. How do I correct this?

 

Many thanks!

 

tom

  • ratbatblue Level 1 Level 1 (0 points)

    I wish I had a fix for you, but I have the exact opposite problem.  I have my Caller ID set to use an email address, yet every iMessage I send shows up at the other end as coming from my phone number.  No amount of turning iMessage on and off, and changing that setting back and forth, has worked to change this.  I can only conclude that this Caller ID "feature" doesn't work as intended, and whatever you choose when you initially set up your phone is what you're stuck with.  I've even read of others who have taken the step of restoring their phone, and gotten no joy from that, either.