4 Replies Latest reply: Nov 12, 2011 3:11 AM by stillworks
richmitc Level 1 Level 1 (0 points)

When I sync my iPhone 4S, it says "finishing sync" but it never says "OK to remove".  I can't find anything not properly synced.  Any ideas as to how I can get it to take this last step?


iPhone 4S, iOS 5
  • sbktex Level 1 Level 1 (0 points)

    I have same problem..  Sync hangs up on last step, whether it's 6th of 6 or 7th of 7.  I just tried Restore with no help.  Any else have this problem and maybe could share?  We're  gonna hate to have to go to store to have it replaced..

  • GavinHuey Level 1 Level 1 (0 points)

    I have the same problem and i have also tried restoring and that didnt help any. Someone please help!

  • richmitc Level 1 Level 1 (0 points)

    All right, my problem was voice memos.  I had been deleting them from my iPhone and on iTunes but not in the Voice Memos playlist which was automatically defined.  The sync went on forever as it tried to sync the 70+ voice memos on the list.  I tried turning off voice memo sync AND deleting the playlist on iTunes.  The playlist yet remained on the iPhone and it kept trying to sync it.  Finally, I had to restore.  Now it is gone and the sync concludes.   I don't think I will try to sync voice memos again.

     

    Interestingly, it still doesn't say "OK to remove".  That may have just gone away with the advent of wireless sync.

  • stillworks Level 1 Level 1 (0 points)

    I have the same problem. Tried Restore no change. Seems to be an issue with syncing apps as I tuned off music sync.