Previous 1 2 3 4 Next 51 Replies Latest reply: Oct 1, 2013 1:07 AM by mills70 Go to original post
  • Mitchell Group Level 1 Level 1 (5 points)

    in each of the instances above where it says in terminal /Volumes/UltraMax, you actually drag the icon of your external into terminal and hit return...

  • Bob Grove Level 2 Level 2 (200 points)

    Mitchell,

     

    Just tried this and found I had to enter 'sudo -s' first along with my password to come up with the the bash-3.2# prompt.  Assume same on your end..??

     

    After going through this, with /Volumes/Media as my external, I found my iTunes Folder is fine in terms of permissions but my iTunes Library.itl still shows with 'unknown access'.  Question, is your iTunes library on your external or is it on your internal within the Music Folder?

     

    --Bob

  • Mitchell Group Level 1 Level 1 (5 points)

    oops left that out.... sorry... My itunes library in on my macbook pro....

  • Bob Grove Level 2 Level 2 (200 points)

    In my case, no luck.  After going through what Apple had you do, problem initially was still there - that is the itunes Library.itl still showed unkown access.  Ran the Repair Permission Utility - whic his what I have to do 2-3 times a day to get things back working again, and was ok for a few hours.  Then as came abck this eveing to play some music - iTunes was open, saw a bunch of temp files building up and low and behold the itl file is showing unown access again.

     

    What is really strange  about this when I see the problem occuring, I looked at the permissions for this individual file using another utility I came across - TinkerTool System, and the permissions all show correct.  But using Get Info - I see 'unknown access'.  If I try and chaneg the permissions either using TinkerTool or via the Terminal, no difference.  It is only when I run the Repair Permissions from the Disk Utility that it goes back to what it should be.  But again the problem will come back for no apparent reason and haev to go through all this 2-3 times a day to get thigns back to nromal.

  • Mitchell Group Level 1 Level 1 (5 points)

    Bob, so to make a long story short... My itunes still was acting strange even after all the fixes.. I finally took the advice of our Mac network consultant and completely rebuilt my library from scratch... 123,000 songs, about a terrabyte of stuff... Took all day Fri.... My itunes library is probably as old as itunes itself and throughout the years and different versions of itunes had never been rebuilt.... so I bit the bullet and now itunes seems to be working fine... I think i got rid of a lot of unseen clutter... Previously my artwork screensaver would not work in additon to the error messages... I think my library was a victim of old age... I'm crossing my fingers but all seems good now...

     

    By the way if you have applecare and you've spoken to a product specialist that cannot figure it out, apple has a progarm they can send you called Capture Data in which you run locally on your system until the problem comes up..You then stop it,  the program creates a file, that is then sent to an engineer, who from what I am told will diagnose and get back to you within 3 days...

  • Bob Grove Level 2 Level 2 (200 points)

    Thanks for this Mitchell...I actually took the time to rebuild mine as well - have ~300,000 songs now so know the pain.  Problem still comes back randomly thorugh the day.  Interesting you mention here that the cover mode on the screensaver was not working before.  Had the same from the beginning with mine and just wrote it off that my library was too big,  Have a similar problem with Genius updating - after 1.2 TB of music, getting an error everytime I try.  Neither was fixed on mine with the rebuild of iTunes though.  Btw, have you had any problems with Genuis updates?

     

    I also started having some strange things occuring with my system overall.  For example woke up this morning and noticed the system kept hanging and could not turn off my bluetooth.  At same time found my iTunes Library file also lost its permissions again.  Not sure related.  Anyway, think my next step is from a clean Lion install with my system as a whole - something that will have to wait until this weekend.

     

    Btw, interesting to hear Apple has this capability.  Unfortunately though I did not by the extended warranty this time and living overseas - where Apple goes through a third-party company.  So I'm on my own with this one...

     

    Again thanks for taking the time for your feedback here...

     

    --B

  • Mitchell Group Level 1 Level 1 (5 points)

    In reference to genius updating.. Even after the rebuild I had the symptom of genius getting to a certain point on my external, then hanging... I would have to force quit and then restart to get itunes back.... What I came upon accidentally was that the last time i tried to update genius, the hang happened, meaning the progress wheel stopped,  then the music i was playing at the time stopped as well.. I wasnt in a position to restart at the time, but lo and behold about 20 minutes later, all of a sudden my music started playing and the genius started updating on its own.... In about 3 hrs genius had completed.... Only thing i can think of is that there was some huge file that genius was having a hard time indexing on my external... and eventually it was able to go past it and complete...

  • Bob Grove Level 2 Level 2 (200 points)

    Interesting - I'm getting a different error

    'Genius results can't be updated right now. There is not enough memory available ~ Please try again later.' which came exatly when I went over 1.208TB with my music.  Tried to rectify this sometime back but no luck.- https://discussions.apple.com/message/12584815#12584815 .  Anyway will see what happens after I rebuild my system this weekend.

     

    Thanks,

    --B

  • Bob Grove Level 2 Level 2 (200 points)

    Think I may have uncovered the problem with this.  To make a long story short, I found that although the iTunes Library.itl file was showing as 'unknown access' (again this problem was intermittant, lookign at the actual file using Terminal - "ls -al /Users/Bob/Music/iTunes/iTunes\ Library.itl" to be specific, the actual file had the correct permissioms -

    -rw-r--r--@ 7 Bob  staff  90429083 Nov 16 17:32 /Users/Bob/Music/iTunes/iTunes Library.itl .  So I ended up creating a new iTunes Folder and moved my existing iTunes files into it.  Problem has not returned since.  So believe something quirky with this Folder for some reason.

  • taffinito Level 1 Level 1 (20 points)

    Here's my history, fixes, and current thoughts on this problem.

     

    I'm using an external Drobo, not NAS, and have never experienced this problem before iTunes 10.5. But since then I've been plagued by the .itl permission issues. Reboots solved the problem, it would commonly come back on a daily basis.

     

    So, I solved the problem by creating a new admin account, moving all my library metadata files there, running with iTunes limitted to one simulataneous download at a time (to try to eliminate thread contention issues with updating the library file), and with Time Machine off.

     

    For the last week, I've been trouble free. BUT, yesterday I started Time Machine and let it run while iTunes was running. Within five hours of this new setup, I started getting the tmp files which are created once the permissions go wonky. Ugh...

     

    So, I turned off Time Machine, rebotted, cleaned up the tmp files, and have been running without permission issues for a day again.

     

    I'll keep monitoring, and if things stay clean maybe I'll open up multiple simultaneous download again. But as of now Time Machine interacting with iTunes seems to be a possible culprit...

     

    Tom

  • Bob Grove Level 2 Level 2 (200 points)

    Tom,

     

    Interesting about Time Machine.  I've had three instances now - most recent last night, where my Time Machine disk cannot be recognized.  First time I could not repair using Disk Utility so ended up swapping and rebuilding with another external I had.  Second time I was able to repair using disk utlility and last night had to reformat this disk and start again.  Btw, I'm on NAS with my externals.  Also, I've always had selected 'singular' rather than 'simultaneous' downloads.

     

    Also this morning, after about a week of working with what I did above, had the permission problem come back with iTunes.  What is really confusing me with this is that using terminal shows the permissions are correct, yet when I check with Get Info it shows "unknown access" and of course the resultant problems that it is not recongized (shown in my earlier post).  In my case, restart does not fix everytime - although running repair permissions via Disk Utility does.  And as mentioned earlier, the permissions that show corrected seem to have no correlation with with iTunes. 

     

    Just thought of one thing I'll give a go on.  Going to try backing up the iTunes lib separately and excluding it from the TIme Machine backup.  This may help isolate this.

     

    Bob

  • Bob Grove Level 2 Level 2 (200 points)

    Just a quick update.  I excluded the iTunes Library file from the Time Machine back up as mentioned I would try in my previous post but low and behold, I sat down tonight and tried to open iTunes but could not - the permission problem showed up.

  • don s. phoenix Level 1 Level 1 (0 points)

    I was having this exact problem (OS 10.7.2, before and after the latest iTunes update) on my '09 MPB: Library-writing errors, proliferating TMP files, permissions weirdness on the "itl" file. On Sunday I ran Verify Disk on my internal drive, and it found a bunch of errors. I had to run the Disk Utility from my original install disk in order to fix it. Ever since the repair, I have had no issues with iTunes. Seems almost too easy, but it might be worth a check. (I probably hadn't run Verify Disk since before I installed Lion.)

  • Bob Grove Level 2 Level 2 (200 points)

    Don S. - This is something I've been doing to get the same to work. 

     

    To all: Last night was fed up as problem kept coming back almost directly after Repairing Premissions.  So addressed this in a different thread focused on the permission issue and got a great suggestion to reset the permissions for the Home Folder (something was unaware on how to do).  Not only did this fix the immediate problem I was having with the permissions but also an ongoing problem with Genius I've had for almost a year now as well as made my iTunes snappier.  So this may be worth a try - https://discussions.apple.com/message/16809042#16809042

  • Bob Grove Level 2 Level 2 (200 points)

    So much for hoping this would tay fixed - permission prolem is back with a vengious.  Happening almost every hour now and having to run RP to correct it, which still does not make any sense as it should not even be touching this file as it is in the User directory.... At least I got Genius updating again though.  ****, not sure where to go next with this .