Previous 1 2 3 4 Next 51 Replies Latest reply: Oct 1, 2013 1:07 AM by mills70 Go to original post
  • Bob Grove Level 2 (200 points)

    Wonder if anyone has had any luck permanetly eliminating this problem???


    I still have this come up several times per week and end up either having to run Repair Permissions in the Disk Utility or reboot to repair.  The problem sometimes come when adding music, video, etc.  other times it comes when just playing a song and doing nothing else.


    What remains strange to me is that I'm losing permissions on my iTunes Library.itl file (shows as 'unknown access').  Yet when I use terminal to specifically check the file permission it shows correct as mentioned earlier. Also it remains a mystery to me on why when I run Repair Permissions (RP) this corrects this as from my understanding RP only corrrects those files installed with the Mac OSX.  This iTunes Library.itl is a User file and is not checked by RP. Using Console to view the system log shows no unusual activitiy or errors when the problem occurs.


    What I've done so far to try and correct:


    - Did a clean reinstall of Lion OSX 10.7.2

    - Completely rebuilt my iTunes Library from scratch

    - Updated to the most recent iTunes 10.5.2

    - Did a diagnistic check of all the external disks where my various media is stored

    - Tried eliminating one-by-one other apps that I sometimes use that have any sort of interface with iTunes (CoverScout, SongGenie, Billboard, TunesText and even Vuze - I use sometimes to convert videos into iPhone format)

    - Did a clean reinstall for my iPhone just in case.


    While I can correct the problem when it occurs, it can be a real pain in the A.


    Any other thoughts or update would be warnly welcomed....

  • Mitchell Group Level 1 (5 points)

    Bob, sorry you are still plagued by this problem.... After completely rebuilding my library (only 114,000 files)  and reinstalling itunes, my problem (knock wood) is gone... for the most part... still don't have itunes screensaver.... I know you did a complete and clean install but have you tried disk warrior? or cocktail to repair your permissions... Cocktail gets rid of alot of uneeded scrap...

  • Bob Grove Level 2 (200 points)

    Thanks for your reply here.  Good to here you got the problem licked.


    In addtion to the Disk Utility within the OSX, I regularly use OnyX as well as tried TinkerToolSystem to restore permissions.  I'll go ahead and give Cocktail a try first and then maybe take a look at Disk Warrior (as it looks to be a pay program).  Just was saw something about 10.7.3 in beta - maybe have a chance with this as the problem came immedately following the upgrade from 10.7.1 to 10.7.2.


    Thanks again and will let you know if I eventually find any releif.



  • lemppari Level 1 (5 points)

    I haven't had this problem since turning off local snapshots from Time Machine. I used Cocktail to do that.

  • Bob Grove Level 2 (200 points)

    Something I've not tried yet but possibly your onto something here.


    Had two cases where my Time Machine Disk (use a standard external disk connected via FW) would not be recoginzed when connecting it up and could not repair so had to reformat and start over. 


    Anyway just disabled the local snapshots and will give it a go.



  • Bob Grove Level 2 (200 points)

    Lemppari, many thanks for the advice on turning off local snapshots.  Looks like this was it!  So far no problems and based on the past frequency, should be home free now.  Again many thanks. This was a real frustrating one!

  • lemppari Level 1 (5 points)

    Looks like this is fixing the symptom. Let's hope that Apple will fix the real cause soon

  • Bob Grove Level 2 (200 points)

    Agree, but not sure how much attention this will get as it appears this was not wide spread problem (my guess it's only if you have a fairly large iTune Library where the program normally bogs down when you do anything and it is trying to make this backup).  Anyway, also submitted to Apple Support so at least it has another vote on a problem to rectify.


    Again, many many thanks for figuring out a fix for this   This one really drove me crazy...

  • jon.oliver Level 1 (0 points)

    been having this exact problem (62,000 songs). just downloaded cocktail and i'm going to give "turning off local snapshots" a try.  thanks for all the info.

  • Bob Grove Level 2 (200 points)

    You can also disable snapshots via Terminal with this:


    sudo tmutil disablelocal


    Good luck!

  • djlafem Level 1 (0 points)


    Did you ever find a permanent fix to your permissions issue in itunes? 


  • djlafem Level 1 (0 points)


    You were having a permissions issue with your XML file and turning off snapshots took care of it?

  • lemppari Level 1 (5 points)

    Yep, no problems with iTunes for 2 months now.

  • Bob Grove Level 2 (200 points)

    Likewise, I've had no problem since disabling the 'local snapshots' with Terminal back in Dec -


    sudo tmutil disablelocal


    In fact when I upgraded to 10.7.3 I tried to re-enable again to see if Apple fixed this and the problem returned almost immediately.  Went back and disabled and all fine again.  So in my case I definately would say this has fixed it.  Although at some point I would hope Apple would address this as it would be nice to have this cabability as I do work mobile a lot.

  • djlafem Level 1 (0 points)

    I was having a problem with my XML file.  I use a third party DJ softwear (Serato) that reads the XML file.  The XML file would change to "unknown access" when itunes was opened/closed.  Running disk permissions would fix it back to a normal permissions setting until you opened/closed itunes again.  All the while, itunes worked fine, but the third party program could not read the XML file and therefore not funtion properly.  If I ran disk permissions and fixed the problem the third party softwear would work fine until again I opened itunes for any reason. 

    We tried so many things- changing the permissions via reset, reinstalling the OS (Lion), but the problem never went away.

    Eventually, with the help of an advisor, I created a new XML file, keeping my playlists in tact, but it did change all of my "date added" information to all be dated the day of the new file created.  This is a bummer since I have been using itunes for many years.  But the file was origionally made on a pc, and moved accross five or so computers, so I thought it might somehow be corrupt.  At this point the problem changed slightly.  A simply restart could fix the problem, verses the long process of disk permissions.   And the permissions would change immediatley upon opening itunes, not from opening/closing it.  But the permissions still changed for an unexplained reason, and meant Serato wouldn't be able to read the XML file unless I restared the computer and left itunes closed.  Well, then I asked the advisor about your post here mentioning snapshots and asked what that was.  He said it had nothing to do with permissions, but at this point said let's give it a try.  We simply went into time machine preferences and turned time machine off.  (I can still use it whenever I connect the time machine extermal and just select  "back up now").  THE PROBLEM SOLVED. That simple.  The whole process has been going on for months and the fix was that simple!  I'm posting this here in hopes to maybe help another DJ who uses Serato, has switched to Lion and is now having problems with it reading the itunes library.  Feel free to write me if you have any questions.  Bob & Lemppari I don't know what I would have done without your posts!!!