Previous 1 55 56 57 58 59 Next 948 Replies Latest reply: Jan 1, 2015 6:37 PM by Ray122 Go to original post Branched to a new discussion.
  • Nick Page Level 1 Level 1 (85 points)

    Hi ilium 007 ~ this might help .....

     

     

    Go to System Preferences > User & Groups > Password > Apple ID (it should say Multiple next to it) select Change > on the drop down box you will see you're ID's > select + or - and make the changes you require > Done (this will give you your Primary ID xxx@mac.com) then Restart your Mac and double check that your ID has changed as described through System Preferences.

     

    It might also be worth noting that since I upgraded to Mountain Lion I have had no push issues whatsoever and iCloud works perfectly for me.

     

    Nick

  • lsjrlsjr Level 1 Level 1 (0 points)

    My iCloud Push Mail problem is still as bad as it's been since Ocober of 2011.   Pushes fine to my MBP...but only maybe 10% of the time to my iPhone.  The only sure way to get mail on my iPhone is by opening the Mail App.   Messages come in sometimes 2 1/2 hours after they've been sent to me.  All depends when I open the Mail App.  Pathetic.

  • ilium007 Level 1 Level 1 (0 points)

    I have the exact same symptoms. I agree -this is a disgrace. I was a paid .Mac customer and a paid MobileMe cusotmer for close to ten years - this *****.

     

    I am about a week off moving everything back to Google apps where push works perfectly. Apple continue to ignore this problem even though there are som many people experiencing the same issues. The worst part about it is that it seems to be hitting those who were paid MbnileMe customers who went through the iCloud upgrade process.

  • Gimbanzi Level 1 Level 1 (0 points)

    it's about two months now i'm using Gmail on my iPad and iPhone with the Google Exchange settings

    Now it never miss a sync and a notification in real time, that's impressive

     

    Just forward your emails to your Gmail address and configure the Gmail account on your iDevice:

    http://support.google.com/mobile/bin/answer.py?hl=it&topic=14252&answer=138740

     

    Then Google Sync allows you to enable "Send mail As"

    http://www.google.it/mobile/sync/

    Be sure to enter this url with your device

     

    Enjoy.

     

    Too bad Apple don't consider this problem as important!

  • brantwinter Level 1 Level 1 (0 points)

    Edited

  • Clif H Level 1 Level 1 (115 points)

    For those still having push email problems, try setting your "Mail Days to Sync" to something reasonable like 2-4 weeks vs "no limit.

     

    And be sure to have this setting across all your email accounts on the same device.

     

    Settings -> Mail, Contacts, Calendar -> YourEmailAccount -> Mail Days to Sync -> anything other than "No Limit"

     

    Same goes if experiencing slow calendar responsiveness:

     

    Settings -> Mail, Contacts, Calendar -> Calendars -> Sync -> anything other than "All Events"

  • weber.81 Level 1 Level 1 (0 points)

    Mail Days To Sync doesn't exist for iCloud accounts.  However, it does exist for Exchange accounts.

     

    Next?

  • Clif H Level 1 Level 1 (115 points)

    Many users have both work and personal email accounts on their iPhones/iPads. Given that one account mishaving affects all accounts' push capabilities on  the device, whether iCloud has mail days to sync is irrelevant. If you have Exchange or a Gmail account configured as Exchange, your push capabilities can be impacted.

  • weber.81 Level 1 Level 1 (0 points)

    Interesting.  I have three accounts:  one iCloud account, and two Exchange (configured as such for gmail push) and the gmail push has always and still does work flawlessly.  I have never once had any problem with the other accounts, but iCloud has NEVER worked as push.

     

    My "Mail Days To Sync" for my Exchange accounts are set at 1 week.  They work perfectly.  Apple has some work to do, that's all I'm saying.

  • Tudor Vedeanu Level 1 Level 1 (70 points)

    I know this is something many (all) of us tried and tried before, but... I just disabled and re-enabled iCloud email push on my iPhone 4S. Works fine now (was broken since a few days ago).

  • richard78 Level 1 Level 1 (0 points)

    Wow terrible this issue has been going on for so long. Problem is that Apple don't like to fix bugs once its released, Apple's lazy attitude towards support is to simply replace the whole hardware, usually at your cost.

  • FF0001 Level 1 Level 1 (0 points)

    8)))) FOR ME THE PROBLEM HAS BEEN SOLVED!

     

    Settings -> Mail, Contacts, Clalendars -> Fetch New Data ->

    (Here I list all my settings preventing any other possible variants)

    Push (On)

    Fetch (Every 30 Minutes) -Tick

    !!!

    Advanced -> iCloud -> Push - Tick (this is THE MAIN ONE and it at the very button of the screen)

    !!!

    Close all background applications (Double click home button, hold over any app icon and push at minus sign)

    Power off and on your iPhone

     

    Make a test.

     

    Hope, this will help!

  • romanserazhiev Level 1 Level 1 (0 points)

    Didn't help me

  • ralfz Level 1 Level 1 (0 points)

    THANKS A LOT, andrewita!!!

     

    Your tipp worked for me as well. Even when I can't imagine what's the magic behind the scenes...

     

    Thanks again!

    Ralf

  • caseystone Level 1 Level 1 (5 points)

    I have been having problems with Push for a long time -- I thought Apple had disabled it in the UK like they had to in Germany (due to legal complaint) but apparently not! I was just able to revive it by turning on notifications. In Settings --> Notifications be sure Mail is in the "notification center" and -- the vital one for me -- make sure "Alert Style" is set to Banners (though Alerts would probably work too). I previously was set to "None". Also possibly "view in lock screen" might need to be on.

     

    These are all work arounds for a problem of push email not being delivered. Even with notifications set to off Mail on the iPhone should still receive the mail when pushed, so the moment you open up Mail you see your new messages. Before (and maybe again if this 'fix' is not permanent) I would open the Mail app on the iPhone (4S btw) and just wait while it very slowly got the messages from Apple's servers. Let me know if this helps anyone!

Previous 1 55 56 57 58 59 Next