Previous 1 2 Next 27 Replies Latest reply: Dec 18, 2014 8:53 AM by bmxjumperc
bmxjumperc Level 1 (0 points)

This is a very simple question / bug. iCloud is not syncing the changes I am making with my Internet Explorer bookmarks. It has the origional database of bookmarks but I've deleted and moved around my bookmark files & iCloud has not made any changes to it's database?

Windows 7
  • vbtrek Level 1 (0 points)

    I had a similar problem with lots of duplicate bookmarks on my ipad. What I did was:

    • Remove all my Favorites from my PC to a backup folder
    • Remove all bookmarks from the ipad that I could (some folder would not delete, like the Bookmarks bar)
    • Disable bookmarks sync on the ipad (this deleted the duplicate bookmarks bar folder)
    • Re-enable bookmarks sync on the ipad (no duplicate folder created)
    • Enable IE sync using the Windows iCloud Control Panel
    • Add favorite folders 1 by 1 back from my backup to my real favorites folder and watch them appear on the ipad


    My next problem is my work PC. When I enable Bookmarks sync on the work pc nothing appears in my Favorites folder and eventually iCloud Control Panel says it couldn't sync bookmarks. I've tried numerous times uticking and reticking and rebooting inbetween but to no avail. Is there any config files or log files or anything useful to look at to determine what it's problem is?

  • seejoefish Level 1 (0 points)

    Same issue for me too. On launch day it did work, and double/tripled up my bookmarks on my iOS devices after a few hours. I did all the things vbtrek did and even then, several hours later, iPhones and iPads all had hundreds of dupes. I shut off iCloud on my PC, turned off Bookmark synching on all my iOS devices to delete all the dupes, and turned them all back on to receive the correct bookmarks from my Mac.


    Today I decided to try again as my PC's now have NO bookmarks as previously I was using MobileMe to keep everything in sync. The iCloud Control Panel says it is synching the bookmarks, but they never show up in my IE favorites.


    I suspect Apple has killed the feature on their end pending a fix for the duplication issue.

  • bmxjumperc Level 1 (0 points)

    I am still waiting to hear that it is working, I'm glad I've heared other people noticed iCloud bookmarks isn't up to par. I'll be patiently waiting ...

  • Jaeden in RR Level 1 (10 points)

    I had the same problem, then I turned off my AV. It was blocking the sync.

  • bmxjumperc Level 1 (0 points)

    where is AV in the menus?


    I can still confirm that any changes I make in IE do not effect the iPod bookmarks, I have the iCloud CP 1.0 I'm not sure what's wrong.

  • vbtrek Level 1 (0 points)

    I have managed to get both my work PC and home PC now syncing with iCloud. Here's what I did to get my Work PC working (in case it helps anyone, Windows 7 PC):

    • I setup Process Monitor to watch BookmarkDAV and iCloud processes
    • I signed out of iCloud, deleted everything
    • In "C:\Users\<me>\AppData\Roaming\Apple Computer" i renamed the folders BookmarkDAV, MobileSync, Preferences
    • In registry "HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\MenuOrder I right clicked and chose Permissions, Advanced, Replace all child object permissions...
    • In registry "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections" I renamed DefaultConnectionSettings, then ran IE and re-configured my internet connection
    • Then I re-enabled iCloud


    I'm not entirely sure which of these steps fixed the problem, but my hunch is that it was the Permissions of the MenuOrder key.


    Hope this helps someone.

  • lb1999 Level 1 (0 points)

    Glad to hear that I'm not the only one with this problem. Think I'll wait for an update to fix it.

  • Chris in Makati Level 1 (0 points)

    I had the same problem syncing Internet Explorer bookmarks, but once I had synced my MacBook Air bookmarks with iCloud also that seemed to resolve the problem, at least partially. Syncing the MacBook appears to trigger a sync to my desktop and laptop Windows machines. If I make any changes or additions to the IE bookmarks nothing gets updated, but if I make any changes on the MacBook then everything is brought into line again.


    I can only guess that Apple don't want people who only use Windows machines to be able to use iCloud for this purpose. As long as you introduce a Mac or iDevice into the sync then it works as expected.

  • lb1999 Level 1 (0 points)

    Would changing from IE to Safari on the PC solve the problem?

  • Chris in Makati Level 1 (0 points)

    I only have IE on my Windows machines, so not sure about that. It would be interesting to find out.

  • jonathan1412 Level 1 (10 points)

    I switched iCloud sync from IE to Safari on my Windows 7 x64 PC and my bookmarks started syncing between Safari and my iOS devices. Unfortunately I want to use the Windows Favorites folder for my bookmakrs, which Safari ignores.

  • Jaeden in RR Level 1 (10 points)

    Sounds like it might be IE being the punk.  Try in a new windows user and see if it works.

  • PDADoc Level 1 (0 points)

    For me, bookmark synch with iCloud and IE has been erratic, to say the least.  Sometimes the changes I make in IE is implemented on my iDevices within minutes or less.  Other times, it doesn't seem to sync at all.  Still buggy AFAIC.


    I wish it would sync with Firefox, as that's my everyday browser; I've been exporting my bookmarks out of Firefox and importing them into IE for the purpose of synching them.  Maybe I'll give Safari another try.


    Using a Windows PC with Windows 7 64-bit, IE 9, and Outlook 2010 32-bit

  • bmxjumperc Level 1 (0 points)

    Yah the only way to sync IE bookmarsk to to select sync bookmarks on the info tab of the iPod.

Previous 1 2 Next