Previous 1 7 8 9 10 11 Next 397 Replies Latest reply: Jul 21, 2015 5:31 AM by Symbiatch Go to original post
  • Natordog Level 1 Level 1

    Can you show me where I said I have Windows? I don't seem to remember getting a Windows computer or saying so. Must be getting old.

  • timjones79 Level 1 Level 1

    Considering the post is Re: Photostream is not syncing on my Windows 7 PC.  I thought it would be obvious that the reply wasn't for someone with a Mac.

  • Natordog Level 1 Level 1

    Advice from experience trying to help the OP  But, actually the Watts guy was the one I was replying to. No more notifs, I'm done now, bye.

  • dsieber Level 1 Level 1

    LOL. wats300 isn't even a good troll


    The hints and fixes mentioned so far haven't helped Photostream on my Windows 7 machine at work. It's just never worked at all. Well, it's annoying but not vital to me. And certainly not the biggest Apple problem I have at the moment.


    Just to be clear for the lurkers (hi, wats300! ), I have an iMac, a MacMini, and a Macbook at home. Five iPhones, one iPad, an Apple TV, and seven iPods. At work I have two MacMini's and two Windows PC's (I do both Mac and PC development). Photostream works on all the Macs. I put Bootcamp on the iMac and Photostream works there too.


    I don't doubt that there is something strange on this Windows machine that is tripping up Photostream. My complaint, which wats300 seemed incapable of understanding, is that Apple provides no help at all. Not even an error pop-up. Nothing that I can report to Apple support, except "it just doesn't work." THAT is annoying. And it's not Microsoft's fault that Apple won't help us out here.


    I am actually an Apple fan, but I don't give them any slack on bugs. As a professional developer myself for many years, I know that some bugs really are difficult or impossible to track down. Most all software companies keep a "won't fix" list of bugs they just can't figure out or justify spending time and money on. If Apple doesn't want to be in that camp (as per "it just works"), they have to put up or shut up   They have to relentlessly hunt down the bugs and FIX them. There should be someone who goes through these threads just looking for problems and getting them documented, getting them fixed. As I mentioned in an earlier post on this thread, I believe most of us do understand that "bugs happen." We don't get angry or become disloyal unless there are no updates and the bugs never get fixed. MobileMe was a good example of this. Apple never fixed iDisk's sync issues, and I switched to Dropbox in self-defense. That is Apple's fault, no one else they can blame that on. And they certainly had far, far more resources than Dropbox. The difference is that Dropbox had to fight to survive and they did, whereas Apple seemed willing to just write the whole thing off as a multi-million dollar failure.


    I said above that this Windows 7 Photostream issue isn't my worst Apple problem. My iMac, which was the most expensive purchase and which I expected to be the most reliable of all, has a really annoying problem that prevents me from connecting to it from work, and yes, there are long threads from people with the same problem, and no, Apple hasn't done anything about it. It's a 2009 iMac, so I guess they've moved on. My iPhone and my iPad also have problems that annoy me daily (and not some third party app, these are bugs either with IOS or with an Apple app). While the majority of things do work fine, it's the daily little nagging things that drive customers crazy.


    Imagine you bought a new luxury car. It's looks fantastic, it drives great, everything is amazing. Except... every other day the door lock won't work. You have to spend several minutes jiggling the key and messing around with it before you can get in the car. And you find that some others with this car have the same problem. And the manufacturer won't fix it or even acknowledge that it's a problem, perhaps because they have a reputation for "great German engineering" or something. You'd get rid of the car rather than put up with it, out of sheer annoyance, even though everything else works perfectly. That's how I feel right now with my Apple products. Every day I have problems that I just can't seem to get fixed. And that's why I'm sad to say that "it just works" really just seems like a marketing slogan.


    Anyway, thanks for reading

  • Burty123m Level 1 Level 1

    I had this same problem nothing changed but it stopped syncing to my lap top and pc, vista and windows 7. I did a rest on my iPhone 4, bottom button and top button hold, after I turned it back on, all works fine. Just a glitch in the matrix :-)

  • akherat Level 1 Level 1

    Try the following - in Windows 7, run the task manager (type: taskmgr in the search off of the start jewel), click the processes tab, and you should see ApplePhotoStreams.exe*32 and APSDaemon.exe*32 - if you don't sort by name by clicking the image name title in the column bar.  right click each one in turn, and check the security.  Make sure that the user account that contains the Uploads folder in question has full control turned on.  If you don't want to give a user account full control over a process, you can try other permission settings, but setting this and restarting the process corrected the problem for me.

  • Tom Callahan Level 1 Level 1

    So I may not have a solution but I do have one potential cause -- I had set up Picasa to use my Photostream folders. I was planning on importing to the Uploads folder using Picasa, then manually emptying that out once they appeared in the Photostream (and therefore back on my wife's Mac which is going to remain our main photo repository). I just wanted the ability to easily add photos to her computer remotely, and to have a constant fresh supply of photos of the kids just in case.


    Anyway, set it up, it worked great for a while, then after my son's birthday party I stuck the camera's memory card in and used Picasa to import. I had done this twice before, no problem. Suddenly started getting "can't upload photos" warnings from iCloud, and a yellow triangle error icon on the system tray iCloud icon. This is 64bit Windows 7 latest updates, etc.


    I got it working again by moving everything that was waiting to upload out of the Uploads folder, turning off Photostream, restarting, deleting the Photostream folders, and turning it back on. Downloads started right away but when I moved everything back to the Uploads folder it all stopped again.


    Finally wised up and looked at what was in the Uploads folder and one of the files was a 419mb ".MTS" file -- it's the video format my camera uses, apparently (Lumix GF2). Picasa imported it and dutifully put it in the Uploads folder, but iCloud seems to have been choking on it, not sure if because of size or file format (iCloud helpfully doesn't say). I repeated the delete/off/restart/on procedure and copied ONLY the JPEGs into the Uploads folder and it just finished uploading successfully.

    So short story -- don't put anything other than photos in Uploads. I assume Photostream doesn't handle video at all, or at least not .MTS format? Maybe I'll see if the camera can do MP4 but I doubt that will help.


    Apple, can't you check the file before attempting to upload and just skip incompatible files? Or at least say something like "Hey, unclean Windoze user, get your dumb videos out of my shiny Uploads folder!".


    And in case any Apple people read this, can you make Photostream optional, like let me take all the photos I want on my iPhone, then mark them the same way I do to email or delete and offer a "send to Photostream" option? I'm perfectly happy to do this manually, love the automatic IDEA but in practice it's too much.


    And on Mac/Win can you offer an option to treat it more like iOS in that it deletes photos older than 30 days/1000 photos? I don't really want my entire photo history on my laptop since I already have my wife's Mac handling that, but having the most recent photos would be nice even if just for my screensaver. I may set up a startup batch file that kills files in that folder older than 30 days but that's a pain.


    Also (sorry for the "Ands" and "Alsos" but I have a lot of ideas!) could you have it automatically delete everything in the Uploads folder as it uploads them? Seems silly to have to clear that out manually since after it uploads it just turns around and redownloads it to the My Photostream folder, duplicating all of my photos. At 5mb each that adds up quickly esp. on a laptop with only a 320gb HD! Better yet, upload, then MOVE the file to My Photostream instead of re-downloading it.


    Also, when's iOS 5.1 coming out, REALLY want that delete feature in Photostream -- apparenly Apple software architects have no small children -- 2/3 of my stream is photos of our dog's butt or grass. I could use time waiting in line at the coffee shop to delete those.


    (And seriously, why can't you even SEE the "reply" button in these forums until you're logged in? That's taking the minimalist thing too far, Apple.)

  • Bernbear Level 1 Level 1

    OK I've spent ages trying to get iCloud and Photostream working on Windows 7. I have followed all the suggested solutions and the one where it says about rights is correct!! just one small addition set the rights BEFORE you re-install and this should work has done for me.. I had installed and re-installed and managed to get photos on my iPad and iPhone to update to My Photostream but nothing I put into the Uploads folder went anywhere... So i uninstalled after turning off Photostream on my iPad and iPhone and deleted them folders then gave the EVERYONE group full rights to the My Pictures folder then installed this created the Uploads folder and as soon as I put photo's in that folder it updated the iPhone and iPad.... Just remember if you want to change photo's like rotate do this before you switch on Photostream on the iPad and iPhone as if you ghange it after the copy... you get 2 copies the original and the changed photo...


    And for all those who blame Apple and the Support guys... NO its Microsoft being Microsoft locking stuff down so you can't use it!!! I did'nt try running the install as Administrator.....


    Still cannot work out why on the original install the My Photostream worked and not the Uploads??

  • raven64 Level 1 Level 1

    Not working here....  have 1000 photos unable to get any of them

  • Solik Level 1 Level 1

    Hey, (spec:windowd7 64bit)

    Here is my problem:

    Uploads works fine. but, downloads to the "my photo stream" (folder that i manualy created) works only after i sign out and than sign in to icloud control panel.

    it's a hussle because for any new photo i take in need to sign out-sign in.


    another thing i can't find the process: applephotostreamdownloader.exe in task manager. you think it's part of the problem?



  • tgBoulder Level 1 Level 1

    Thank you for mentioning that signing out and then signing back into iCloud got it working again for you.  My Photo Stream on the Windows 7 machine had stopped updating.  I logged out of iCloud, logged back in, and immediately the new photos showed up in My Photo Stream.  I don't know if it will keep working, but this at least got the photos moved that I needed to keep going on my project.  Thank you!

  • ronnie_and_sandy Level 1 Level 1

    My experience was (for my Windows 7 PC, at work) that My Photo Stream downloaded the photos initially, several days ago, but last night's photos are not syncing. I tried giving Authorized Users access, as was suggested some posts ago. So, like many of you, I'm stuck.

  • eloneY Level 1 Level 1

    Here's my solution of this problem.


    1.check ur photo stream download path if any folder's name includes space.

    2.rename those folder and delete the space

    3.reset the photo stream path in icloud conctrol panel.

    4.reboot the pc or end ApplePhotoStreamsDownloader.exe

    5.take a photo with ur iphone and check your  download folder


    After I tried many solution and they didn't work,I finally found that the problem is the space of my folder's name.


    It works well on my laptop,try it~


    PS.English isn't my first language.If you can't understand what I say,reply me.

  • eloneY Level 1 Level 1

    "Log-off-log-back" can work is due to the default path without space,I guess.

  • DrJOnes666 Level 1 Level 1

    I have the same problem: first time install will sync. Then the day after, if I take new photos, they don't sync.


    My solution so far that works, but is not ideal, is to either:


    A) open icloud pannel, sign out, then sign in (this restarts the sync)


    B) open icloud pannel, untick "Photo Stream", click Apply, then re-tick "Photo Stream", click Apply (this restarts the sync).



    If I take photos on my iphone right after doing the above, photos sync automatically.

    But as soon as I reboot the machine, the automated sync stops and I have to revert to the above solution to restart sync.


    I have no idea why the sync is not being done automatically.

    I also have Win7x64

Previous 1 7 8 9 10 11 Next