Skip navigation

Photostream is not syncing on my Windows 7 PC

366299 Views 388 Replies Latest reply: Apr 19, 2014 10:31 AM by inQZtiv RSS
  • OKADA Tsuneo Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 17, 2012 5:18 PM (in response to Joe Siegler)

    Joe,

    I replied the message of apprometheus at 2011/11/02 12:34.(page 4)

    I have two account of iCloud, it seems that these accounts conflicted in the iCloud system.

    I tried sign in and sign out, with each account, and further sign in with a account which I want on PC and iPhone.

     

    Then I resolved the crash of ApplePhotoStream.exe.

  • anniebeagle Level 1 Level 1 (0 points)

    I have the exact same issue and this "solution" works on my computer:

     

    1. Close the iCloud control panel.

    2. Open the task manager and end all Apple and iCloud processes.

    3. Reopen the iCloud control panel. The photos in my iPhone photostream now automatically downloads to my dowload folder (which I had to create myself) on my PC.

     

    However, if I take new photos that are placed in my iPhone photo stream, they don't download to my PC unless I perform step 1 to 3 all over again. Kind of disturbing I must say...

     

     

    This worked!  Thanks!

     

    Photos from the Photostream on my iPhone only randomly appear in the Photostream folder on my computer.  Sometimes they show up right away; other times, I wait days, and they're never there (after making sure that I've closed the photos app on my phone and am connected to wifi).  I've been searching for a way to force it, and this finally worked! 

  • mjoshea148 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 18, 2012 3:03 PM (in response to WaterOz)

    I'm running Windows 7 x64 and have had the same issues.  Tried many of the proposed solutions and stumbled today across something noted earlier.

     

    I had Chrome running and had taken a few pictures.  No download.  Closed Chrome and almost immediately after, the photos downloaded.

     

    Coincidence, perhaps but did match the earlier observation that Chrome is somehow interfering with Photostream.

     

    Mike

  • mjoshea148 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 18, 2012 3:22 PM (in response to mjoshea148)

    Okay - perchance I spoke too soon.  I attempted to repeat the success and it did not work. I had to turn off/on Photostream before photos downloaded.

  • Romjke Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 26, 2012 2:29 AM (in response to WaterOz)

    Try to disable UAC in win7 and reinstall icloud control panel. this helped me.

  • wateron Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 28, 2012 4:47 PM (in response to Romjke)

    What's UAC?

  • wateron Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 28, 2012 5:03 PM (in response to EffEPi)

    How do you uninstall Photostream?

  • sbailey4 Level 1 Level 1 (5 points)
    Currently Being Moderated
    May 29, 2012 1:40 PM (in response to wateron)

    Its User Account Control. Open control panel then 'user accounts'. You will see it at the bottom. You can then change its settings.

     

    Also to remove Photostream you open control panel and select programs/uninstall a program. Look for icloud and remove (not actually called Photostream) That will remove the iCloud control panel then you can reinstall it

  • wateron Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 29, 2012 4:11 PM (in response to sbailey4)

    Done everything I could find on this forum, still doesn't sync photo's, no help from Apple, giving up

  • no1453 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 29, 2012 8:49 PM (in response to WaterOz)

    Don't know if this will help anyone, but I finally got ApplePhotostreamDownloader.exe to run and stay running, after a long period of having it exit almost immediately every time I ran it.  Here's what I did....

     

    In C:\Program Files (x86)\Common Files\Apple\Internet Services\, where ApplePhotostreamDownloader.exe is located, you will find another executable called ubd.exe .  I noticed that this program was blocked by my firewall even though when I got the alert I told the firewall to allow it (apparently ubd.exe doesn't try for more than a few milliseconds before it gives up.)

         So I told my firewall to trust ubd.exe, ran it manually, and it is still running as I type this.  Once ubd.exe was running and allowed to connect to the internet, suddenly ApplePhotostreamDownloader.exe (when executed manually) was able to keep running instead of exiting after a few seconds.  It is also still running at this time.

     

    No idea what ubd.exe is, but nothing I tried (every suggestion in this thread) would keep ApplePhotostreamDownloader.exe running until ubd.exe was running AND NOT EVEN TEMPORARILY blocked by a firewall.

     

    So now that I have that program (APsD.exe for short) running, I'm going to try all sorts of killing processes and checking and unchecking boxes and reinstalling and such to see if I can get Photostream to work.  (Currently no pictures yet).  I'll post if I find a solution.  BTW, my system is Win 7 64 bit.

  • no1453 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 29, 2012 9:38 PM (in response to no1453)

    I spoke to soon, I think.  I can't replicate my results.  APsD.exe is back to exiting almost immediately.     Last time I had a problem with a program that wouldn't run for more than a few seconds it turned out windows Data Execution Prevention was stopping the process.  But when I tried to exclude APsD.exe from DEP Windows says I can't do that for that file...

  • no1453 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 30, 2012 2:08 AM (in response to no1453)

    I finally have APsD.exe (for short) running, though again no pictures yet.  Here's what I did...

     

    I wanted to look for conflicts with other services and starup items, so I ran msconfig, diabled all non-microsoft services, and disabled all startup items except the thwo labeled "iCloud".  Rebooted.

    APsD.exe still wouldn't stay around, but then I read that iCloud depends on Apple Mobile Device, iPod Service, and Bonjour, so I renabled those services manually through msconfig, tried running APsD.exe again, and it stayed running.

        I took some time enabling every service and startup item, with rebotting all the time, to try to isolate the problem service or startup item.

     

        Finally I had them all enabled, and APsD.exe was still running.  Somehow the process I went through fixed whatever was wrong.

     

         But I still see no pictures in the download folder, and it doesn't upload either.   But I thought this info might help someone.

  • no1453 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 30, 2012 11:04 AM (in response to no1453)

    If by any chance someone from Apple is reading this, I've found that when I run APsD.exe (for short) and it exits almost immediately, it leaves a message in the log under AppData/RoamingApple Computer/MediaStream/ul of "Event ID: 501, Event Severity: 5", when I have a test picture waiting for upload.  The log in the dl folder is blank.  If I remove the test image so both directories are empty, it leaves an entry in the log of the dl folder with the same message.  Couldn't find anything on a Google search about event id 501.

     

    At this point I'm kind of sick of this problem.

  • mr-nik Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 30, 2012 11:16 AM (in response to no1453)

    At this point we are amazed by your detective work & persistence. My APSD.exe seems to work now (various reinstalls etc) but only when I open iCloud control panel, not when windows runs, despite being set to. 

     

    It is truly bizarre and seems to be one of the shoddiest most baffling tiny pieces of software known to man....  Are apple actually baffled by their own mystery or do they just not give a **** about customers?

  • no1453 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 30, 2012 9:04 PM (in response to mr-nik)

    In my last attempt to fathom what could be going wrong I created a 32 bit virtual Windows 7 machine that runs on the 64 bit machine where photostream doesn't work, installed 32 bit itunes and then icloud, and that one immediately worked, pictures appeared in folder as soon as I enabled photostream.   Which to me rules out all firewall and network issues, and apple id issues.  I may still have a conflicting program on my 64 bit machine though.

        As for my persistance, I have a lot of time on my hands and I become really p***ed off when some little minor thing refuses to work    I think I have finally laid my obsession with this problem to rest, though;  I now believe all I can do is wait for Apple to release an update for iCloud that works on 64 bit machines.

     

    (and no offense to "apple", but I think they really are baffled by this problem.  Apple software for Windows is always just a little buggy, it seems to me.  Kind of like it isn't their major priority.)

     

    Excelsior!

1 ... 10 11 12 13 14 ... 26 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (14)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.