Previous 1 18 19 20 21 22 Next 397 Replies Latest reply: Jul 21, 2015 5:31 AM by Symbiatch Go to original post
  • alexshore1982 Level 1 Level 1

    Hi. When I spoke to apple they had me make a new user account on my PC. That has worked for me. They also had me check the permissions for all the apple program's so it seems that could be an issue. I think the iCloud likes to have only one user as the administrator. Mine is set so all users (myself and my husband) have equal admin but every time I go to open the iCloud control panel I get a 'this program needs permission to continue' notice pop up and I have to click continue for it to open. I also find that every time I reboot my PC a program has blocked applephotostreams.exe from opening. I have to manually give it permission to run. I tend to leave my PC in sleep mode when I am not using it so it isn't a major problem for me as I only have to do it when I properly shut down and restart. I do have to manually run it on each user account though. Running it manually on my account will not start it in my husbands until he starts it himself. U have a ballon pop up in the bottom left of the screen which tells me windows had blocked a program from starting and tells me to click to run it. After running it manually it does work. I don't have to keep signing in and out of the iCloud control panel like I used to. Hope some of these points you in the right direction.

  • ben o underhill Level 1 Level 1

    Thank you for such detail in your response Alex. I'll experiment with this approach, although the last 5 hours of trying to get iCloud working on Windows has been absurdly frustrating and given me newfound interest in letting google drive or dropbox take care of my ipod touch photos. Both those apps "just work."

  • mr-nik Level 1 Level 1

    Here's the thing: there are lots of 'solutions' in this thread. Anything that 'resets' photosync somehow (reinstall, change of account, reset of folders) had a reasonable chance of working. Tried most and a few of them have worked for me. The question is: will they KEEP working, because for me at least, none of them have. That's just how it stopped working in the first place: mysteriously.


    I got iCloud 2.1 with iTunes 11 last night and hey presto - it started working. Not holding out hope for it to continue doing so though.  One thing I did notice when one of the apple .exe processes was running - it was guzzling memory. ; I suspect this might be why it eventually crashed/died. And I wonder if that is to do with how full your photo stream is?



  • Toad77 Level 1 Level 1

    I've found that if it's not syncing after the initial setup, taking a picture on an iOS device causes the sync to start.  YMMV.

  • Richardcn Level 1 Level 1

    LIke you Ben I spent far too long trying to get Photostream to work, briefly succeeding, only to have to find another solution the next day, week or month. I guess, like a lot of people here, it was the belief that it would all be worth the effort to have Apple software synching an Apple device but I was sooooo wrong. Got myself a Galaxy S3 which came with Dropbox installed and finally the reality hit home. Dropbox does, between my phone, iPad and pc more than Photostream ever could do even when it was working. It does it amazingly quickly, effortlessly and without skipping a beat. In the 3 months I have been using it I have been shown just how this technology is really meant to work. Photostream has now been deleted/put to rest everywhere it once resided. For the rest of you, good luck if you continue to soldier on with it but meanwhile the tech that you wish you could have is happily doing its job in another readily available form.




  • rraheja Level 1 Level 1

    Apple really needs to learn how to make their software work in the cloud!


    Dropbox works great with syncing photos, so its not an issue on the user's part but just poor software quality on Apple's part. I would gladly get rid of iCloud for Dropbox, however its only having pictures display on the Apple TV Photostream that has me wasting hours of my time trying to uninstall/reinstall/repair/grant admin access/run icloud updater/. Really wish someone from Apple takes a look at how cloud sync technology works and fix this once and for all.

  • Briefnotion Level 1 Level 1

    I did the latest iTunes update and its been working correctly during the past few days. Fingers crossed.

  • Arthur_P_Johnson Level 1 Level 1

    I am at my wit's end with this. The problems started this summer, even before iOS 6 was released. Photostream works okay on my Macs, but my main photo-editing setup is on my Windows 7 Pro 64-Bit machine, with Core i7 Sandybridge 2600k 3.4 GHz CPU 16GB Ram and 256GB SSD -- 30 inch 2560x1600 HP monitor -- and you would THINK this beast could handle Photostream for Windows just fine.


    But I'm getting a big ugly ERROR every time I startup. (See the PS.)


    I have tried all the stuff suggested in this thread -- uninstall and reinstall iCloud, turn off my antivirus (MSE), change my ID, yada yada yad, and it still won't work.


    HELP! Can anyone suggest something I HAVEN'T yet tried?


    I am seriously thinking of switching to Dropbox or even Google drive. However, I don't like Drobox security -- like it even less than iCloud. Yesterday I plugged in my iphone and copied its camera rolls into a folder on one of my storage drives -- but this shoul;d be happening regularly!


    Thanks in advance for your help,




    P.S. Here's the Statup Event, as recorded by Event Viewer:


    Log Name:      Application
    Source:        Application Error
    Date:          12/7/2012 1:27:31 PM
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      Arthur
    Faulting application name: ApplePhotoStreams.exe, version:, time stamp: 0x50a5a262
    Faulting module name: KERNELBASE.dll, version: 6.1.7601.17932, time stamp: 0x50327672
    Exception code: 0xe06d7363
    Fault offset: 0x0000c41f
    Faulting process id: 0x1520
    Faulting application start time: 0x01cdd4a8835a1867
    Faulting application path: C:\Program Files (x86)\Common Files\Apple\Internet Services\ApplePhotoStreams.exe
    Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
    Report Id: c293ca57-409b-11e2-96f1-00268315da41

  • kloquewerk Level 1 Level 1

    This definitely worked even after I fixed my first issue a while ago. I turned off Photo Streaming for the longest time and decided to make use of it again. Nothing worked when I dropped a bunch of new pics in my uploads folder UNTIL I took a new pic and it seemed to have kicked off the syncing process. Definitely a bug that needs to be worked out.

  • James Mitchell1 Level 1 Level 1

    that option does not appear in mine.

       Removed in a later version?

  • NastyNas Level 1 Level 1

    Still having this problem with a clean install of Windows 8 64-bit. PhotoStreamsDownloader.exe is taking up an entire CPU core and doesn't download anything. I installed the 32-bit version of Windows 8 in a virtual machine and PhotoStream ONLY works in the VM. Apple, please fix this.

  • Brian Wade Canfield Level 1 Level 1

    Hello NastyNas - (and a "hello" to anyone else that may come across this post):


    Below is a link to a forum thread that is (well, was) discussing this very same topic. I posted a solution that worked for me (and I have had no problem with iCloud every since on my PC). I had tried the whole "administrator" solution proposed way above, as well as checking for updates, etc. The solution I provide has 2 steps, of which I now believe the 1st may be the critical component - as I have not (as of yet) read a solution written by anyone that has proposed checking "something" that could potentially be throwing iCloud off. In and of itself, the change that I made in the 1st step did not fix the problem. I needed to repair it afterwards (which is the 2nd step).


    Regardless of what Windows Edition you are currently using, I hope that this works for you (and for anyone else in this forum thread who has been unsuccessful with getting iCloud to work properly).


    Following this line is the link itself, and beneath this is a short note about the post that it links to:



    Note: If you do not want to read the beginning part of the post, which essentially details my own set of problems with iCloud at the time, than it is perfectly okay to skip it. The 2 steps are listed as "Step 1" and "Step 2", and the core sequence of sub-steps within each step are underlined. It is fairly straightforward; and the overall task doesn't take long to do. However, it is written with the assumption that anyone could be reading it - and this includes persons that know very little about PC's.


    Again, I hope that this works for you!  ~ Brian

  • Joe Siegler Level 1 Level 1

    I've noticed a new thing since v2.?? came out (the one that supported shared photo streams).


    Basically, it will properly get any photo streams to my computer - I don't have to do anything special.  But my "primary" photo stream, it doesn't work.   At first I thought of creating a shared photo stream with myself, where I would copy the photos to, and it worked.  Still does.  Until I realized that the copies of images put in shared photo streams are of smaller size and lesser quality than the ones in the primary photo stream.  So I abandoned that idea.


    It's really frustrating that it doesn't work on a PC - I wish I knew WHY.  It's even more confusing that the shared streams work, but my primary one doesn't.  I've tried every repeated step here.  Repair, uninstall, reinstall, run as admin, upgrade software, reset photo stream, logout/in, changed directory permissions locally......  Nothing works.   It won't download my primary photo stream.


    Really frustrated as heck.  Don't know what to do about it.


    Also, this is a Windows 8 box - not the Win7 that's in my profile, I haven't changed that in the forums.  But it is the same computer, it got upgraded from Win7 to Win8.   If I had the cash, I'd just fix the flippin' problem by buying an iMac, but I can't afford that now. 

  • edfromminnetonka Level 1 Level 1

    It is definitely frustrating that Apple can't get this right and refuses to acknowledge the problem. The action that I have found works about 50% of the time. I simply open iCloud Control Panel and then Close it. Nothing else. Although it is slow to open. And slow to close. Photos do seem to begin to download and upload a couple minutes after this action.

  • paragontony Level 1 Level 1

    Ive read all through 20 pages and tried everything, even the issue that windows 7 makes folder read only and this maybe an issue but cmd prompt and attribute process doesnt work. Windows ignores the read only attribute supposedly maybe control panel doesnt? Anyhow wife had 2000 pics on ipad and somewhere along the line activated icloud and then noticed pictures gone from ipad. Icloud has the 2000 pictures but I cannot get them to come down. Using control panel, if I upload a new pic in upload folder it appears in my photo stream so it all works for new pics... How do I get the old 2000 pics... ??

Previous 1 18 19 20 21 22 Next