Previous 1 20 21 22 23 24 Next 397 Replies Latest reply: Jul 21, 2015 5:31 AM by Symbiatch Go to original post
  • Kristerpher Henderson Level 1 (0 points)

    Logging out and logging back in worked for me. I don't have any trouble with my Mac, but I've always had syncing issues with the PC.


    Here is my setup:


    Windows 8 64-Bit

    AMD Processor


    Don't think I need anymore details besides that. Also make sure you are placing the Photo Stream in a place that has read/write access. You can check this by right-clicking or option-clicking on your folder and checking the permissions.



  • anonnymous12345 Level 1 (0 points)

    I can't get this to work on my Windows 7 64 bit computer. Disappointed in this feature.

  • sbailey4 Level 1 (25 points)

    Try this. Uninstall iCloud control panel. Reboot the machine. Then right click on the iCloud control panel 2.1.1 installer file and select "run as administrator". See if that will help.  Also when you configure it leave the default upload and download folders (dont customize them). I used it on Windows 7 32bit and currently on Windows 8  64bit and its working fine.

    anonnymous12345 wrote:


    I can't get this to work on my Windows 7 64 bit computer. Disappointed in this feature.

  • wateron Level 1 (0 points)

    Tried re-installing as administrator, still doesn't work. These things are why Samsung is the new Apple

  • sbailey4 Level 1 (25 points)

    Yeah I guess Apple has no interest in making Windows work as well with it as a Mac. May generate some new sales for Macs that way. Sorry you cant get it going. Some have had success and others not so much. Seems the 2.1.1 version has a better track record. Guess not in your case though.

  • Stormvision Level 1 (0 points)

    Thank you, this solved the problem for me!!

  • Mandah. Level 1 (0 points)

    I did this and wasn't able to turn PhotoSteam back on because it was greyed out =/

  • schmidtfjs Level 1 (0 points)

    Using the Windows 7 iCloud control panel, I switched off the Photo sync and chose apply.  Then simply switched the Photo sync back on and chose apply -- pictures began arriving immediately.

  • Mobo40 Level 1 (0 points)

    I realised my photostream was not uploading over the last few weeks. After much playing about and then referring to the posts above we have uninstalled the iCloud panel and reinstalled the newest version. This seems to have worked and all photos are now showing on my PC. So thanks everyone who advised this route. I would recommend others try it.

  • AnthonyNC Level 1 (0 points)

    If you look back in the comments there are plenty with Macs that cant get this working.  I am one of them.  It just doesnt work.

  • Kristoffer R Level 1 (0 points)

    Thanks for all the good advice in this thread.


    I had to swich the HDD on my PC and needed to spend a lot of time getting iCloud up and running again both with the calendar sync and the photo stream.


    Reinstalled, repaired, switched Photo Stream on and off, ran as admin, ensure no write-protect of folders and probably had it fixed along the way, but the sync refuesed to happen.


    In my case, I think the advice  'take a new picture with your device ' was the final kick needed. Probably saved me a few hours.

  • nkgkim Level 1 (0 points)

    I had this same issue, and I didnt want to reinstall photostream or erase any of my photo streamed pictures. I tried turning it on and off, and logging on and off icloud and everything!

    I finally synced my photos again!!


    All i did was take a screenshot of my phone

    went to photostream on phone and waited for the load sign to finish (at the very top left next to time)

    and then in like 5seconds i checked my "photostream" folder and it worked!
    Easy as pie.

  • moody50 Level 1 (0 points)

    This discussion is pretty old and goes through several versions of the Icloud Control Panel and some possible fixes that are no longer available (like logging in to and using the advance option to reset photostream).


    I have Icloud Control Panel version installed on a Windows 7 PC. If I put a picture into the Photo Stream uploads folder the picture gets uploaded to both an iPad 2 and an iPhone 3gs. If I take a picture on either the iPhone or the iPad it gets shared with the other I device. No pictures seem to be downloading from either the iPhone or the iPad to the windows 7 PC (they should download to the Photo Stream "My Photo Stream" folder.


    At one point all the photo's had a lock icon on them but I have released them and reset the permissions to default. The downloads had been working until recently. I have uninstalled and reinstalled the Icloud Control Panel multiple times. I have taken new pictures with each device. I have logged out of and into the Icloud Control Panel. i have toggled Photo Stream off and on in the control panel.


    Uploads work, downloads don't.


    Any suggestions would be appreciated.

  • sbailey4 Level 1 (25 points)

    If you changed/customized the download folder reset it to default. That seems to have corrected for several users. For whatever reason (probably a permissions thing) the control panel likes the default folders and seems to work more reliably when they are selected. Next option is to uninstall the control panel and be sure to delete any left over folders pertaining to it. Especially the database that keeps track of what has been downloaded. Reboot then reinstall iCloud control panel and accept defaults.

  • mr-nik Level 1 (0 points)

    Here's the thing folks.. almost all of these strategies work some of the time for some of the people. Kicking the system to restart, whether by resetting, changing permissions, re-installing, trashing all your old photos etc. gets the thing going.




    I've not seen anyone come on here and say the fix is permanent - (nor to be fair that it broke again - except I'm doing that now... it broke again... and again and again... )


    you know what I think? I think it's a memory problem. I've seen this kind of thing in my software engineering past, and I've seen the way the apple processes seem to grow and grow in size and chew up memory. I think that once you get to 1000 images in your photostream and then more and more are added, the whole sync process just blows up because it needs or uses too much memory...   well, just a thought..


    That's why, whenever you fix it, it eventually fails again... (in my experience)

Previous 1 20 21 22 23 24 Next