Previous 1 2 3 4 5 6 Next 397 Replies Latest reply: Jul 21, 2015 5:31 AM by Symbiatch Go to original post
  • JZMac7 Level 1 Level 1

    I think it might a combination of things and this is why.  When I am using my only windows PC (Domained for work) it will only open the Icloud Control Panel if I am at home without starting VPN.  When I finally can get the control panel open I can select Photostream and set the folders.  It still will not upload or download anything.  I have tried all of the suggestions except for buying a Mac since I already have one. 

  • bwsailor Level 1 Level 1

    Photostream is also not working for my PC running Windows 7. Pictures placed in the upload folder get uploaded to my iPhone, but no photos are downloaded to my computer.  Has anyone solved this yet? It's driving me crazy.  Apple??? Are you out there??

  • twin_mom Level 1 Level 1

    So I figured out what the problem is (at least for my computer).  I had the same problem that the uploads were working but not the downloads.  After installation, I selected a different download folder (so that it is with the rest of my pictures).  I think someone on this thread mentioned about keeping them together, so I created a "download" folder in the same dir as the upload folder (where apple created it and it works).  Then....nothing happened.  I went to bed so frustrated that I couldn't get this working.  When I woke up in the morning, I checked again and my photostream pictures were in the download foler!!  After a few days, it seems like the sync to your computer happens once a day, even though they talk about "instant pushing".  I wish they had an indicator of when it's going to sync.  That would be helpful.


    I hope this helps at least one person....

  • Jonny Borris Seed Level 1 Level 1

    So I reinstalled windows and now photostream works fine. So as I suspected it is not a hardware issue. Had previously tried everything else without success. I installed iCloud CPanel immediatly after windows then began installing software and testing to see if photoStream would fail thus identifying the culprit. I have installed most of the original software and it is still working so am guessing its a deeper issue then just a software clash. Apple rang me too but I am never home when they ring however at least it seems they are taking this issue seriously.


    all the best efforts


  • cdn-tallguy Level 1 Level 1

    Well, I'm sure there is a solution that won't require me to reinstall Windows...

    [For another thread. How come on my wifes XP-MS-Outlook a lot of contacts got ruined, empty fields...
    iCLoud off but "Find my iPhone" back to USB cable sync and it's working.

    Feels like being a banana, products finished at the customer].

  • Jonny Borris Seed Level 1 Level 1

    If photostream not working check if the following processes are running

    - AppleMobileDeviceHelper.exe

    - ApplePhotoStreams.exe

    - APSDaemon.exe



  • cdn-tallguy Level 1 Level 1

    All of this is running.

    You forgot:



    Still it's not downloading...

  • WaterOz Level 1 Level 1

    I had the other things running... but I don't have ApplePhotoStreamsDownloader.exe



    Is that a real file?  Where should it be installed on the computer - I'll run it if I can find it and see if that helps on mine.

  • WaterOz Level 1 Level 1

    Searched for it and found it... But it doesn't seem to be helping... oh well

  • edfromminnetonka Level 1 Level 1

    Request to Apple:


    We know we have a problem on this topic. We know that you are aware based on the unsolicited phone calls you have made to several of us.


    How about providing an update on the status of a solution? We know you are working the issue, when can we expect a result.

  • andyfromlynwood Level 1 Level 1

    hi everyone i found the solution for Windows 7 users. It is actually a sharing issue with the wireless network. you have to go to your

    1. network and sharing center


    2.then go to advanced share settings.


    3.then go to media streaming


    4. choose media streaming options. then click on allow all


    5. finally make sure that your wireless connection is on the home network (as there are 3 options, home work, public). your settings will be updated and it should work.


    note also make sure you make an additional subfolder inside the photo stream folder and call it my photo stream. direct the icloud to put the downloads in that subfolder.

  • Rndmzr Level 1 Level 1

    I don't have a wireless network (never have) on my machine and still had the problem.  But I checked the settings you mentioned anyway, and they were already set like that anyway, so this wasn't the solution to the problem for me, I'm afraid.

  • WaterOz Level 1 Level 1

    I acutally didn't have all that on with my computer... so I have turned it all on... and it doesn't seem to make any difference.  Granted, right now I'm on the 4th choice (domain) so when I get home and connect my computer off of my works domain, I'll see if being on my home network will make any difference.


    I'm guessing not... but it's worth a try.  Thanks for coming up with a new suggestion

  • DragonRus Level 1 Level 1

    I have absolutely the same problem!

    Russian language Windows 7 32

    It doesn't work in neither direction! Neither uploads, nor downloads.


    My computer is in a workgroup, not a domain. I've tried it in the office and at home with different Wi-Fi routers.


    When installed iCloud created TWO subfolders in the Photo Stream folder - My Photo Stream and Uploads. I've tried to change the My Photo Stream subfloder to Downloads - no result... ((


    And I don't and never did have Kaspersky Antivirus...




  • apprometheus Level 1 Level 1

    (This solution was mentioned by others but I missed it earlier so it may help some...)


    iCloud was not syncing my photos and applephotostreams.exe crashed with an error on Windows Vista.

    I fixed it by using the correct AppleID on my Windows iCloud Control Panel.


    • Check your device iCloud account AppleID
      • Your AppleID is the email address,, you use for iTunes and other Apple services
      • On your iPhone/iPad/iPod Touch, tap Settings/iCloud from the Home screen to see the AppleID in use on your device
    • Check your Windows iCloud account AppleID
      • Click on the iCloud icon in the system tray
      • The AppleID is displayed under your name on the left side
    • If the AppleIDs are different on your device and your iCloud Windows then you can fix the problem by making them match
      • Sign out of Windows iCloud by clicking the "Sign out" button on the bottom left and sign back in with the matching AppleID
    • If the AppleIDs are the same on both then check the rest of this thread for other possible solutions


    I had accidentally changed my Windows iCloud to my address and my device was using my old iTunes AppleID. After I changed them I was able to start applephotostreams.exe and my photos started syncing immediately.


    I'm sure there are other causes for some users but this is one confirmed solution. Hope it works for you.

Previous 1 2 3 4 5 6 Next