Previous 1 2 3 4 5 6 Next 86 Replies Latest reply: Dec 16, 2013 5:39 AM by RangerRickMN Go to original post
  • BuffCrone Level 1 Level 1 (0 points)

    Yes, I understand all of that. And indeed, that's what I've always done.

    But imagine that you are sitting on the plane in Phx, trying to figure out whether your long-delayed flight to Chicago is going to get you there in time to catch your 2:00 flight to NY. The departure time for the flight to NY will not appear at the correct interval on your phone if you have manually set the phone to reflect Arizona time.

  • Kevin Geiss Level 1 Level 1 (0 points)

    It'll work; try it and see. Sitting in Phoenix, if they tell you the new arrival time is 1:45pm (Chicago time), say, edit the first leg of the flight: subtract two hours from 1:45 and set the new arrival time to 11:45am since that event on your calendar is set to Phoenix time.

     

    Then, no matter what time zone you pick in Mail, Contacts, Calendars, the calendar app will always display the same interval between the two events.

     

    The trick is that each event can only have one timezone for both start and end times. As long as you set those & the event's timezone correctly, everything will be correct. Events will move as you pick different display times in Mail, Contacts, Calendars, but the intervals will be correct. It's just annoying we have to do the conversion ourselves on one end of all flight events when entering them.

  • LnGwStX Level 1 Level 1 (0 points)

    That is an awful lot of legwork to do something that should happen automatically. I don't often fly in somewhere on a tight schedule (I travel but generally for long stays that don't involve tight airport schedules or flight changes). I was thinking that changing to Denver wasn't really a problem as long as the time is right (and I assumed it would change back to Cupertino in the spring). But I can see how it could cause a problem should I ever depend on it for any fancy footwork. For now I guess I will make sure to have copies of itineraries to refer to instead of depending on my phone to do its job. Sad, because I generally love Apple products, and I do have great affection for my phone. :-(

  • pascho Level 1 Level 1 (0 points)

    I recently got the same problem and noticed that it only started after I'd downloaded a particular app which used the location feature.  It was the free version of the Weather Channel that started it off and, since I've deleted it, I've not had the problem of being in Singapore or China since!

     

    I expect there will be other apps that cause the same issues - probably a bad piece of code being used to pick up the location function.  It might be worth trying to turn individual apps off that feature in location services to pinpoint which other apps may causing your problem.

     

    Hope this helps!

  • BuffCrone Level 1 Level 1 (0 points)

    No, it's the iOS5 that messed it up. Wish it were only an app!

    Don't forget that if you make an appointment on your iPhone for after March 11 while it is set to Denver, the time will be off by an hour. I had set my phone to Phoenix time by turing Autormatic Time Setting off, but when I went to NY last month, I turned it back on (so I would know what time it was!) I forgot to reset it to Phoenix when I got home.

    As a result, the time on all the appointments that I set there and since are wrong. I had to go in and change all of them to Mountain STANDARD time on the computer, and then let it resync to the phone.

    From now on, when I fly, I am setting an alarm to go off on landing to remind me to turn Automatic Time Setting back off.

  • GlennW Level 3 Level 3 (625 points)

    And, guess what: STILL not fixed in 5.1

  • James Bucanek Level 1 Level 1 (55 points)

    If it helps anyone, the solution that I've adopted (until this bug is fixed) is:

     

    1. In Settings > General > Date & Time, turn Set Automatically to Off.
    2. Change the Time Zone to Phoenix.
    3. Create a reminder that repeats about once a month or so.
    4. Over the next month the time on my iPhone gets a little bit off, but not enough to worry about.
    5. After a month, go back into the Date & Time and turn Set Automatically back on. This re-synchronizes the time so it's correct again, but also sets the wrong Time Zone.
    6. Go to step 1.
  • boychump Level 1 Level 1 (0 points)

    hey guys. my wife had this problem with her iPhone 4s but mine was fine. i've hunted high and low on the web but nothing. i think i found a fix. well, it worked for my wifes fone anyway.

     

    * Go to Settings / Location Services

     

    * hiding right down the bottom is System Services. open this.

     

    * there is a "Setting Time Zone" setting. turn to on

     

    this fixed my issue. let me know if it fixes yours too

     

    cheers

  • boychump Level 1 Level 1 (0 points)

    hey guys. my wife had this problem with her iPhone 4s but mine was fine. i've hunted high and low on the web but nothing. i think i found a fix. well, it worked for my wifes fone anyway.

     

    * Go to Settings / Location Services

     

    * hiding right down the bottom is System Services. open this.

     

    * there is a "Setting Time Zone" setting. turn to on

     

    this fixed my issue. let me know if it fixes yours too

     

    cheers

  • boychump Level 1 Level 1 (0 points)

    hey guys. my wife had this problem with her iPhone 4s but mine was fine. i've hunted high and low on the web but nothing. i think i found a fix. well, it worked for my wifes fone anyway.

     

    * Go to Settings / Location Services

     

    * hiding right down the bottom is System Services. open this.

     

    * there is a "Setting Time Zone" setting. turn to on

     

    this fixed my issue. let me know if it fixes yours too

     

    cheers

  • boychump Level 1 Level 1 (0 points)

    hey guys. my wife had this problem with her iPhone 4s but mine was fine. i've hunted high and low on the web but nothing. i think i found a fix. well, it worked for my wifes fone anyway.

     

    * Go to Settings / Location Services

     

    * hiding right down the bottom is System Services. open this.

     

    * there is a "Setting Time Zone" setting. turn to on

     

    this fixed my issue. let me know if it fixes yours too

     

    cheers

  • boychump Level 1 Level 1 (0 points)

    hey guys. my wife had this problem with her iPhone 4s but mine was fine. i've hunted high and low on the web but nothing. i think i found a fix. well, it worked for my wifes fone anyway.

     

    * Go to Settings / Location Services

     

    * hiding right down the bottom is System Services. open this.

     

    * there is a "Setting Time Zone" setting. turn to on

     

    this fixed my issue. let me know if it fixes yours too

     

    cheers

  • James Bucanek Level 1 Level 1 (55 points)

    I've always had this setting turned on, so that's clearly not the solution for my phone.

  • boychump Level 1 Level 1 (0 points)

    bummer. did you try turning off automatic settings when you turned it on then turned it off? the process i did was also hard reboot of the fone with the auto settings off, then turned location setting on then off. sorry if it didnt work.

  • MacLombie Level 1 Level 1 (0 points)

    AlexFromNogales wrote:

     

    @Diesel vdub

     

    There is a new option (I think) under Settings/Location Services/System Services called Setting Time Zone... Seems that it suppouse to grabe the time zone using the GPS....

    Turning this off worked instantly for me, though I'm not sure if there are any other implications that I should worry about.  Thanks, Alex!