Previous 1 2 3 4 Next 48 Replies Latest reply: Dec 3, 2015 7:47 AM by Firemanbill44 Go to original post
  • Tyke999 Level 1 Level 1

    As far as I can tell, you get a second alert when you haven't opened / read the first.

  • cheeriosoul Level 1 Level 1

    The same thing was happening to me so i rebooted my phone. Just hold the lock and home button down until the screen goes blank. Keep holding until the apple logo appears and voila erythings all good.

    Preferences
    §
    1
    2
    3
    4
    5
    6
    7
    8
    9
    0
    -
    =
    Backspace
    Tab
    q
    w
    e
    r
    t
    y
    u
    i
    o
    p
    [
    ]
    Return
    capslock
    a
    s
    d
    f
    g
    h
    j
    k
    l
    ;
    '
    \
    shift
    `
    z
    x
    c
    v
    b
    n
    m
    ,
    .
    /
    shift
    English
    alt
    alt
    Preferences
  • pccllc Level 1 Level 1

    I don't know if this is the problem in the previous cases, but there is also a "Repeat Alert" for Messages (under Notifications). Mine was set at "1", so I was getting a repeat of every notification.  I switched it to None and now I get only 1 alert.

  • LCollingridge Level 1 Level 1

    Go to settings, notifications, messages - scroll down to Repeat Alert and change it to none (or however many times you want the text to repeat) - my was defaulted to Once. 

  • zoo76 Level 1 Level 1

    My repeat was set to NEVER, so that wasn't the problem. Contrary to posts in this thread, this is a bug.

     

    The procedure liste worked for me (we'll see for how long), thanks.

  • ramck Level 1 Level 1

    lephunk was in the right area and I am sure it has changed due to new iOS but go to

    Settings -> Notifications Center> Messages, scroll down to Repeat Alerts and select Never

     

  • paddyaodea Level 1 Level 1

    I am having the same issue but at least i understand whats wrong finally.

     

    Look at the imessage as it appears in your text screen. it says "imessage". then.... (and heres the genius part) Look at the duplicate message underneath. do you notice the difference. it says "Message". (text message)

     

    What this indicates is that it is NOT your phone issue. The senders/receivers phone is  in a poor cellular coverage area. When this imessage thinks it is not being received it is resent as a text message. resulting in 2 identical messages appearing on your phone. Poor coverage on your receiving end results in the same result.

     

    You will find some inbound friends messages are duplicating more than others.and other times, not at all. it fluctuates because 3G/ Edge coverage either on yours or your senders end has been compromised.

     

    If both sender and receiver are on WIFI, no problems occur and message is not duplicated. Unfortunately it cannot be helped as it is not a phone issue rather a cellular network issue. Try the WIFI test and let me know.

    Cellular Paddy

  • Firefly_Apollo Level 1 Level 1

    Go to Settings --> Notifications --> Messages --> Repeat Alert and set to Never. This is how you fix your iphone repeating text message alerts. Try it out.

  • MacThijss Level 1 Level 1

    @Firelfy_Apollo: You're right; that is the setting. It is a silly setting

  • hjoyg Level 1 Level 1

    Here's how to fix it:

     

    > go to Settings.

    > go to "Notification Center"

    > scroll down to "Messages"

    > click on "Repeat Alerts"

    > select "Never"

     

    That's it!

  • Maulik Fireboy Level 1 Level 1

    This is the FIX

    Settings/Notifications/Messages/Repeat Alert and set to never

  • rc_oz Level 1 Level 1

    Wow, thanks.  Just changed repeat to none.  It worked! 

    I had put up with this for 2 years, lol.

     

    who the heck had set repeat to 1 to begin with though.  I sure didn't.  Gremlin ? 

     

    OH well.

  • TaraLeeSav Level 1 Level 1

    This is a "text tone" issue. If you have a text tone set up for a specific contact, when you get a text message you can not stop the tone from going off. It will continue to go off even after you press the home key or silence the phone. This can be particularly annoying at work. Before ios8 came out I'd gotten it to stop doing this, but with the recent update it has reverted back and I can not seem to figure out how to fix it. Turning off the banner will probably help, but I like the banner notification. In all this defeats a purpose of  having the "text tone" option. Much like having the "Health" app that does nothing unless you download multiple third party apps. Why do you give us these things if they can not be used properly?

     

    Everyone keeps saying to set alert to "never". This is not the issue. That has been done already.

  • Mista Snazzy Level 1 Level 1

    That had been bothering me for ages but I never got around to Googling a solution before now. Thanks for the clear explanation. Apple Support should elevate your fix to top of page.

  • mattmayer Level 1 Level 1
    expertise.macosx
    Mac OS X

    thanks robozak!