Skip navigation

Why do iMessage texts repeat twice?

109503 Views 38 Replies Latest reply: Apr 10, 2014 1:27 PM by MacThijss RSS
1 2 3 Previous Next
p0l4rchris Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 17, 2011 2:48 PM

Whenever I receive a text via iMessage, I get two alerts.  My iPhone 4S buzzes once to alert me to the message, and then the screen lights up and the buzz repeats a few minutes later.  I have double checked my Notification settings and message alerts are set to "never repeat."  There are two possibilities here:

 

1.  The alerts appear twice because I am receiving the messages at two addresses (phone number and e-mail address).

2.  There is a bug in iOS 5 that is causing my Notification settings to be ignored.

 

Is anyone else experiencing this problem?

iPhone 4, iOS 5, iPhone 4S
  • dannyfromconverse Calculating status...
    Currently Being Moderated
    Oct 18, 2011 9:34 AM (in response to p0l4rchris)

    I'm having the same problem. The double message alert tones are really annoying. I have yet to figure out what the fix is. When I find out, (if I find out), I will post.

  • kmx78 Calculating status...
    Currently Being Moderated
    Oct 18, 2011 7:19 PM (in response to p0l4rchris)

    I am also being alerted twice after receiving a text and not reading it immediately.  I have my repeat alert settings set to "never."  I know for sure that I am alerted twice when receiving a text via the standard text messaging system, but I can't recall if I am alerted twice when I receive a text message via iMessage.

  • WicksBon Calculating status...
    Currently Being Moderated
    Oct 18, 2011 7:38 PM (in response to p0l4rchris)

    I, too, am also having this problem.

  • maestrotim Calculating status...
    Currently Being Moderated
    Oct 19, 2011 1:39 PM (in response to p0l4rchris)

    This is happening to me too...very frustrating

  • dannyfromconverse Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 19, 2011 3:02 PM (in response to p0l4rchris)

    Okay... I figured this out. Kind of...

     

    On my phone (iPhone 4s) I went to Settings > Messages > Received At

    I have my phone number and my email address listed. I tried to remove the email address, but it would not let me do it. The REMOVE THIS EMAIL button would not respond.

     

    So...

    I then went to Settings > Sounds > New Mail

    I selected 'None' for the alert tone. Problem fixed! No more double alert tones!

     

    But...

    This could be a problem for people who like alert tones for incoming email. It's not a problem for me, because I don't have my email pushed to me (I check it manually when it is convienent to me). I do this because I did not like my phone constantly 'binging' everytime I get an email, and helps conserve battery.

     

    The real problem is why the REMOVE THIS EMAIL button will not respond under the Messages Settings.

     

    Hope this will help some of yall.

  • apstoronto Calculating status...
    Currently Being Moderated
    Oct 26, 2011 3:19 PM (in response to p0l4rchris)

    I am receiving (all of a sudden) every imessage as a SECOND IDENTICAL text message.  This has only started happening today...no other settings changed.  I receive the imessage first and then the identical message as a text message.  Please help resolve this.  It is not an alert.  Same problem, cannot delete the email setting in messages.

  • jefish Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2011 10:09 AM (in response to dannyfromconverse)

    re dannyfromconverse, that didn't work for me.  I only have my ph# listed as an iMessage deliery point on my phone, so can't remove any email addresses. I did disable all mail notification sounds, but I still get alerted twice for each iMessage and SMS.

     

    It did occur to me earlier that I have iMessage enabled on my iPad using only an email address (an address which is in use on my iPhone), so I disabled iMessage on my iPad completely.  I dunno, I figured if Apple was trying to push the same message to the iPad via email, the phone may have picked it up too, doubling the alerts.  Alas, no change, I still get two alerts for every incoming message.

     

    My next step is to disable that email address on my phone, but I don't have high hopes.

  • NFH. Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 6, 2011 10:42 AM (in response to p0l4rchris)

    Is this caused by the settings in Notification Centre? In the Notification Centre for Messages, I have "Alert Style" set to "Banners", "Repeat Alert" set to "Never" and "View in Lock Streen" set to "OFF". Whenever I receive a text message, my iPhone makes the text tone sound without appearing on the lock screen as expected, but when I then unlock the screen and the banner appears at the top of the screen, it immediately makes the text tone sound a second time. It seems to be sounding the text tone sound for the banner in case you miss it, which is very annoying. It's the same for SMS or iMessage.

  • jefish Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2011 10:49 AM (in response to NFH.)

    I have Messages set to NotCenter On, Style Alerts, Badge On, Preview On, Repeat Never, View in Lock On.  For me, if I get a message it'll light up the phone and display a preview of the text in the middle of the screen (old school style).  After a few seconds the screen will go dark.  A minute or so later, the same event happens, same message.  Note that I'm not actually receiving a separate message, just being alerted twice.

  • Sal_008 Calculating status...
    Currently Being Moderated
    Nov 11, 2011 11:04 AM (in response to p0l4rchris)

    Did anyone try disabling iMessage, rebooting the phone, then re-enabling iMessage? That fixed it for me.

  • NFH. Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 11, 2011 11:39 AM (in response to Sal_008)

    Sal_008 wrote:

     

    Did anyone try disabling iMessage, rebooting the phone, then re-enabling iMessage? That fixed it for me.

    I'm on iOS 5.0.1, and it's still not fixed, so I tried your suggestion but it made no difference.

  • GencoYang Calculating status...
    Currently Being Moderated
    Nov 12, 2011 4:24 PM (in response to p0l4rchris)

    Hi, I have the same problem.

    Not only the iMessage/SMS, but also some other notifications from apps.

    They just always sound twice back to back...

  • robozak Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2011 11:15 AM (in response to p0l4rchris)

    Fixed - go to Settings/Notifications/Messages/Repeat Alert and set it to never.  This will stop the dual alerts.

  • NFH. Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 18, 2011 11:17 AM (in response to robozak)

    As I said above, I already have this set to "Never" and I still get the dual alerts.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.