Previous 1 2 Next 26 Replies Latest reply: Jan 20, 2013 11:31 PM by K0001 Go to original post
  • S G S B Level 1 Level 1 (0 points)

    This is also happening to my iPhone 4, 4S & iPads 2.

    I have a phone appointment with Apple Care on Monday & I will talk to them about the issue. My guess is this will be resoved with the next OS update.


    This is Apple Supports online response to this issue.


    "iCloud Backup requires that you verify your password."It is necessary to enter your password to allow restoring of or adding to existing encrypted backups. Enter your password when prompted to resolve this issue.

    So basiclly, this is no help!!!

  • KingNewbs Level 1 Level 1 (0 points)

    I'm curious... This issue just began happening with my iPhone 3GS on Friday where the "iCloud Backup requires that you verify your password." message pops up about twice a day (so far).


    On Thursday I jailbroke it.


    Previously it ran without ever popping up this particular message. Coincidence? You guys tell me.

  • Chris D Searle Level 1 Level 1 (0 points)

    Did you get any more from the phone call? Have to admit that I'm curious - my iPhone and iPod touch backup to iCloud just fine - but my iPad (first gen) has this issue. Same account, same wifi network, same everything.

  • S G S B Level 1 Level 1 (0 points)

    Sorry for the delay with the response.

    After talking to multiple people at support, I really didn't get any straight answers.

    I did delete the iCloud accounts from all of my devices and then added them back. I also cleaned up my Apple I.D.'s at the same time.  I do have multiple, so I figured it might help.  Go to to manage your I.D's.


    After all that it clear it all up.  Not sure what part of it did but I have yet to have this issue again.

  • KingNewbs Level 1 Level 1 (0 points)

    I was able to fix it as well. The only thing I did was, in iTunes I changed my backup settings from iCloud to My Computer, to avoid seeing the prompt anymore.


    Then, a few days later, I decided to try iCloud again and see what happened. Worked fine and I haven't seen the prompt since.



  • S G S B Level 1 Level 1 (0 points)

    It is weird. I have always done my backups on both from the start of icloud. It doesn't seem like there has been one thing that has been figured out to resolve this. Eventually, if you keep trying it will be fixed.


    Thank you for a good discussion on this topic. 

  • satyrica Level 1 Level 1 (0 points)

    Better fix than that:  Turn your phone completely off, and leave off.  I tried this twice and it works 100%!!!

  • Roland King Level 1 Level 1 (45 points)

    After reading a load of 'fixes' posted in various places this is what worked for me. Go to 'settings->iCloud->Storage and backup' and press the 'Backup Now' button, if it asks you to verify, do so. Check that the backup completes. After I'd done that, it worked.


    My theory here is that the iCloud backup tries to run whilst you aren't using the device, it decides for some reason it needs the extra on-screen verification but of course, you're not using the device and can't type the password in, the backup eventually gives up. However when you pick the phone back up the next day that queued popup still pops up, you type the password in but the backup is no longer running. After a few minutes, just as with the iTunes store, the device authorization you just did expires and the next time the backup runs .. same problem. By forcing a backup when you are using the device, you can get it to complete once and then it's happy.

  • tim_mcs Level 1 Level 1 (0 points)

    Hi, All,

    Drat! The procedure didn't work for me.  For several weeks I've also been getting the message "iCloud Backup requires that you verify your password" in the morning, after disconnecting from charging overnight.  The iPhone is connected to power, locked, and connected to WiFi overnight.  I dutifully entered the password.  Thanks to Ronald King's post, I followed the path to "Backup Now" button.  There was a notice that the last backup was several weeks ago.  I performed backup manually.  Last night I connected the iPhone to power to charge overnight, locked it and left it alone.  This morning I navigated to the iCloud "Backup Now" button and saw that the last backup was still the one I performed manually yesterday morning.  Today, the quest will continue.



  • tim_mcs Level 1 Level 1 (0 points)

    Voila, apparent success!  For the past two mornings the iCloud backup message indicated it backed up just after 7 am each morning.  Except for the day following the manual backup, the automatic backup is taking place, as Roland K described. 


  • K0001 Level 1 Level 1 (0 points)

    Wow!!!  A Year Later and  they STILL haven't sorted this stuff out!!!

    My wife bought an iPad 3 weeks ago.  a Week ago she had to fly internationally on a 10 hour flight, so I downloaded the latest 3 books she wanted to read.


    15 minutes into the flight the "your iPad Has not been backed up in more than 2 weeks" poppped up.


    AND IT STAYS UP.  I guess the fix Apple has come up with for people disabling iCloud Backup is to make the device USELESS until it is backed up.


    This is ludicrous.  No wonder the Galaxy is selling so well. 


    We both have worked with computers for over 20 years... NEITHER of us can figure out how to even get back to the setup menu to even try and connect to the iCloud, much less turn it off.  The stupid dialog box simply will not go away.

Previous 1 2 Next