Previous 1 2 Next 18 Replies Latest reply: Dec 18, 2015 5:18 PM by Lawrence Finch
Loveyz Level 1 (0 points)

Everyone says I show up as an email address. Is anyone else havin this problem or know how to fix it?


iPhone 4, iOS 5
  • Micbarry Level 1 (0 points)

    Hey there,

     

    Try this. Go to settings, messages, then click on 'receive at', scroll to the bottom, click on 'caller ID', then choose your phone number instead of your email address.

     

    That should do it.

  • SSJAK Level 1 (10 points)

    This happened to a contact to me. The texts and iMessage were coming up as separate contacts. The people you are messaging should save your email address to your contact.

     

    On my phone iMessage and text worked seamlessly for every contact bar this particular one.

     

    I deleted all my messages and towards the end of the day it just started working properly.

  • Loveyz Level 1 (0 points)

    I don't have the option of "caller id," how do I get that?

  • Micbarry Level 1 (0 points)

    When you go to settings, messages, receive at - what do you see on the screen?

  • Loveyz Level 1 (0 points)

    All I have is apple id, email address, and add another email address

  • Micbarry Level 1 (0 points)

    That's interesting. Under 'add another email address' I have another 'caller ID' button. Perhaps it doesn't appear with all carriers. I'm with Vodafone, Australia.

     

    If you go to Settings, Phone - what does it say in the 'My Number' area? Maybe yours needs to be filled in.

  • joeythepuppy Level 1 (0 points)


    im having the same problem and my number is filled in. I had an ipod touch first that has the new software with the imessage and I am wondering if that could contribute to the problem?

  • shelbyfromkyle Level 1 (0 points)

    I was having the same problem! Go to Settings > Messages > Then turn iMessage OFF. Now turn it back on, and it should say "activating", then your phone number should be in the "Receive At" line. Worked for me- hope it helps!

  • Oli martin Level 1 (0 points)

    is there a way of doing that on an ipod touch changing the email to a number

  • zacheeface Level 1 (0 points)

    THANK YOU shelbyfromkyle!

    THIS WAS REALLY EASY AND QUICK!

    Definately easiest way to fix iMessage! (:

  • nfitz104 Level 1 (0 points)

    I was having the same problem and I just figured it out!  You have to go to where it says your apple user id and sign out and then it uses your phone number.

  • livinlife Level 1 (0 points)

    I did a reset due to poor battery life and have been informed that my email address instead of phone number is showing up.,,,,,,,,am on iphone 4s.

    I have tried the above fix and it did not work.  Messages show receive at 2 Addresses one of which is phone number and the other is email address.  The phone number is grayed out and the address is highlighted. It does not provide me with the option to change it from email to phone.

    Anyone have any ideas?  Thanks.  Right now I am very frustrated.  Had no issues with phone until upgrade.  Now battery does not last a full day and even with reset am now having battery issues plus this one.

     

    Thanks

  • peapod1980 Level 1 (0 points)

    Use the fix suggested by nfitz104. Where your AppleID shows up, click on that and sign out. You will then be getting messages only through your phone number. I tried all suggested fixes, and that is the one that worked.

  • SSJAK Level 1 (10 points)

    It seems that this is a well known feature and is apparently being looked at with the new OS coming out this year.

     

    If someone has an ipad and iphone for example it will show the contact twice in your messages list should you recieve an iMessage from the phone number and the email address.

     

    If you iMessage said person's phone number they won't necessarily get it on the ipad. They will get it on both assuming the devcies are set to recieve at both phone number and email address. You can't set to both on your ipad yet

Previous 1 2 Next