Previous 1 2 3 4 Next 57 Replies Latest reply: Oct 23, 2014 1:44 AM by kikiveliki
stretch15 Level 1 Level 1 (0 points)

Running the latest version of Lion and Imovie 9.0.4


I keep getting the following error.  I don't know what file is causing the trouble. i have everything else closed while compiling the movie.  None of the files I am aware of are copyrighted.  I am using video shot from Go Pro cameras along with some still photos that show no copyright information in Aperature. Also music from my itunes library  Unfortunately I do not get a specific error code listed in the dialouge box



"The project could not be prepared for publishing because an error occurred. (File already open with with write permission)"

MacBook, Mac OS X (10.7.2)
  • mb2010 Level 1 Level 1 (0 points)



      I am getting the same error, surprisingly for a project that I have exported successfully in the past.


      I too am unsure of any solutions/workarounds.


      If you find something that works for you, please do share.



  • stretch15 Level 1 Level 1 (0 points)

    No sucess thus far.

  • tobias78 Level 1 Level 1 (10 points)


    I am getting the same error as well and so far I haven't found any solution.

    I can export in iMovie in "Large" size but as soon as I switch to HD it gives an error code -49.

    Thanks for any help!

  • Karsten Schlüter Level 7 Level 7 (31,760 points)

    stretch15 wrote:


    ...  music from my itunes library  ...


    "The project could not be prepared for publishing because an error occurred. (File already open with with write permission)"

    I assume, your iTunes Lib is on some external network drive/NAS, right?


    copy music you need in iM to your locale/internal drive, use this version ...

  • mb2010 Level 1 Level 1 (0 points)

    I have found that breaking the video project into smaller chunks and then creating HD videos for each is able to go through successfully. Then, I burn a DVD with these videos as multiple items on the same disc.

  • stretch15 Level 1 Level 1 (0 points)

    That has been my problem too. I can go up to 960x540 it seems but no bigger


    Files are on a different partition bit the same drive...  Per apple support I set that partition to ignore user permissions to see of that helped. It let me export the large file size but not hd for some reason.


    Is there a file size limit for iMovie?  The large file was just north of 500 mb

  • roberson antequera Level 1 Level 1 (0 points)

    Same problem here. I live in Brazil and there is no apple suport here. Does anybody tried talk to apple to solve this problem ?

    I tried to instal Lion again. Erased imovie and instaled ilife again. tried restore permitions etc... nothing works. Cant´export HD movies with more than 10 minutes. Also having the same error .49 message when trying share an iphoto presentation with movies.

    Thanks for any help.

  • Phydeaux Level 1 Level 1 (0 points)

    I'm experiencing the same error. It just started two weeks ago. I wonder how many in this thread use CleanMyMac? My errors started after I ran that app.

  • roberson antequera Level 1 Level 1 (0 points)

    Nop. I didn´t used cleanMyMac....


  • Phydeaux Level 1 Level 1 (0 points)

    Was there a System Update during that time period that broke something in iMovie? I never had this problem until two weeks ago, and now it's every week.


    I regularly export large videos (~ 400 - 500 MBs). This behavior just started. I was able to 'fix' my problem last week by cutting the video in half, but that's no solution (unless there's some way to generate two .mov files and then stitch them back together again post-processing).

  • mb2010 Level 1 Level 1 (0 points)

    I started using iMovie only since 10.7.1, so can't comment on what was the case before that.


    I have had similar experience as Pyhdeaux. If a movie does not finalize, we chop it in half and then finalize the two separately. Sometimes, one of these chopped pieces finalizes and the other does not, so we chop the other into two separate halves.


    All this is kind of silly, but I have not found a workaround.


    The problem is that there does not seem to be a way to add separate videos in iDVD and have all of them play sequentially, automatically. (there is this thing called slideshow in iDVD, where you can add videos too, but that messes up the aspect ratio of the video) Silly again.


    So, I use quicktime to fuse all of the chopped-finalized videos into one piece and then add them to iDVD as a single video. To do this, Quicktime has to be reprocess the entire movie. Silly again.


    All in all, I am terribly disappointed with Apple's iMovie. At the pretext of simplifying things, they are making it more difficult. To me, it seems like the error in iMovie is something very trivial, and should be quickly fixable by the Apple engineers. Only if they are listening... Well, maybe one of us will choose to file a bug-report....



  • hagbard86 Level 1 Level 1 (0 points)

    I have the same -49 Error,


    with an 34 Minute Project. I successfully exported it yesterday. Today i cut 30 seconds off so I have to export it again, after 4h rendering it says -49 error. Dried twice!


    This is a big Problem I think, the next problem is that my free disc space is getting smaller and smaller because of the temporary rendering files, and i can not find them on my mac.


    I don't know if iMovie saved some parts of my project on my external harddrives, so I decided to consolidate all files to my intern HD (Menu File ==> Consolidate Files) iMovie tells me that some Clips used in the project are not on my intern HD, but consolidation doesnt work.


    Can anybody please help!!!

  • Phydeaux Level 1 Level 1 (0 points)

    It gets worse - I tried to export a file a quarter the size of the full size, and it's /still/ throwing the same error. I have no idea what's going on.

  • roberson antequera Level 1 Level 1 (0 points)


    I found a way to turn around.

    1- download Houdini

    2- start imovie and let the project ready

    3- start movie encode

    4- with Houdini and erase all quicktime hidden files on desktop, documents and movie folders. There were big files bigger than 6 GB, I erased all.


    Tried this way to times and everything goes ok. I could export my movies complete in HD 720p !!!

    I hope it works for you to.


    Lets wait apple launch a definitive solution.

Previous 1 2 3 4 Next