14 Replies Latest reply: Apr 13, 2012 2:14 AM by MeganMD
gary frommansfield Level 1 Level 1 (0 points)

I received an iPhone 4S last week and ever since then, I have been unable to set up my Exchange email account, which is my corporate email account.

 

I know I am not locked out of my account, because I can access my email on my laptop. I also know that I am entering the correct information, because I set email up on people's iPhone's as part of my job. 

 

One of the messages I got said that Exchange wasn't trusted, and it gave me the opportunity to accept it, and I tried to do that, but nothing happened. I only saw that once. Most of the time it says that my account cannot be verified or the server cannot be reached or something like that.

 

Does anyone know why the iPhone 4S is the only phone in our company that is having this problem, and that I didn't have this problem until I got the iPhone 4S?

I want my mail. :-(


iPhone 4S, iOS 5, No Mail
  • gary frommansfield Level 1 Level 1 (0 points)

    Oh, and I have tried deleting and recreating the account several times. I can view my gmail, but not the exchange.

  • jouss Level 1 Level 1 (0 points)

    I don't know if you had an iPhone 3 before and if it was working.

    You should check with the tech guy of your company to see if it is compatible, I know it  does not work with exchange server 2003 ( protocol issue).

    good luck.

  • gary frommansfield Level 1 Level 1 (0 points)

    I had an iphone 4 before, and it worked.

     

    we are running Exchange 2010. Im in the tech dept and no one knows why this suddenly wouldn't work. everything is the same on our end as it was before.

  • jouss Level 1 Level 1 (0 points)

    do not know what causes the problem.

    It worls for me on exchange 2007.

    Looks like you haver to call apple.

    You could  delete the accoiunt, do a reset and then create a fresh account..., wish I could help.

  • CericL Level 1 Level 1 (0 points)

    Our situation is similar except we're on Exchange 2003.

     

    The CEO had/has an iPhone 4 which connected fine to Exchange 2003. His new iPhone 4s has the same settings but gets an authentication error (e.g. bad password) when trying to connect.

  • gary frommansfield Level 1 Level 1 (0 points)

    I tried that a little bit ago, still got the error

  • gary frommansfield Level 1 Level 1 (0 points)

    That password errors is also one of the errors that I have received. So it isn't just me. That is nice to know. It must be something with the 4S then, but what? does it not trust exchange? and it is odd that we have different servers(years) too.

  • CericL Level 1 Level 1 (0 points)

    Solution:

    I disabled then re-enabled User Initiated Syncronization along with Up-to-date Notifications via Exchange Tasks in Active Directory Users and Computers.

     

    After waiting a few minutes, we tried again with success.

     

    To clarify, here's what I did for the affected user:

    1. Log onto your Exchange server as an admin

    2. Launch Active Directory Users and Computers

    3. Locate the user, right click and select Exchange Tasks

    4. Configure Exchange Features> Next

    5. Highlight and disable these two Mobile Services:

         a. User Initiated Syncronization

         b. Up-to-date Notification

    6. Hit Next to get to the confirmation that the changes were made and then close the window.

    7. Go to step 3 and repeat through step 6, but this time, ENABLE the mobile services.

     

    I'm not sure how long you may have to wait for the changes to take effect. The user over here was in a meeting for about an hour and it was working by the time he was back.

     

    I hope this helps!

  • jim127 Level 1 Level 1 (0 points)

    Hello Gary,

     

    I've set up people on Exchange 2007 and Exchange 2010 SP1 servers and no one is having an issue on the servers that I set up with there new iphone 4s's.   It could be something specific to your server such as out of date patches or policy restrictions.  Here are step by step instructions for setting up your email account just in case - http://www.completesystemsdesign.com/set-up-tips/how-to-connect-your-iphone-or-i pad-to-ms-exchange-for-email-sync.html

  • rasman59 Level 1 Level 1 (0 points)

    I'm having the same issue this device and exchange don't mix. I went to black berry its too easy with blackberry. I think this may be another class action against apple. Nothing work good on this device.Battery is crap, no flash support, exchange don't work, calendar does not work nothing on this device is worth the money. Never purchased a device with that many problems. Idon't think they test this crap before they start selling it. Great concept but bad execution. Go to BB or Android they don't have these problems.

  • Jmac D Level 1 Level 1 (0 points)

    I know this thread is a few days old, but this solution worked for me. I was having a similar issue when I brought the first iOS 5 phone (iPhone 4S) into our domain and tried connecting it to our Exchange (2003) server. What I did was, instead of putting in 'mail.mycompany.com' for the server address, I used the interal IP. This is the same one we use to connect to the server via WebMail in-house, and you can obtain the IP (like 192.168.x.x) from your IT department.

  • boe_d Level 1 Level 1 (0 points)

    You need to contact your IT department.   You are using an internal DNS server or a double natted wifi and they can correct that for your web server - e.g. mail.mycompany.com - if they put that in, you can use the same address both internally and externally.

     

    www.completesystemsdesign.com for more info.

  • Jmac D Level 1 Level 1 (0 points)

    Thanks boe_d, this was actually a setting on our server that was causing the problem. I only used the internal IP temporarily (which wasn't really that useful anyway, since I get email through Entourage in the office and the internal IP doesn't work outside of our domain-should have made my original post more clear). We're getting ready for a migration from WS 2003/Exchange 2003 to MS Server 2008/Exchange 2010 and a transitional setting was messing up the syncing of mobile devices. Working great now with mail.mycompany.com as the server setting both internally and externally on iOS5 devices (iPad and iPhone) and Droid, BB, et al.

  • MeganMD Level 1 Level 1 (0 points)

    Hi, I know this is a few months late but I just came across your post. I was having the same problem with my Microsoft exchange account on my iPhone 4s. I had the 3GS prior to this one and my email worked fine until the upgrade. I finally got it to work by choosing a gmail account instead of the Microsoft exchange account, which I was instructed to do in the past. The gmail account allows me to access my email on my iPhone whereas I still have to use the Microsoft exchange account on my iPad in order to access the same emails. Hope this was helpful.