5 Replies Latest reply: Nov 30, 2012 11:10 AM by quesengar
Cron Master Level 1 Level 1

Xserve with 2.26 GHz Quad-Core Intel Xeon with 10.6.8


Lately I've been seeing this error message a lot:


You are unable to log in to the user account "XXXXX" at this time


Logging in to the account failed because an error occurred.



Everytime when the above error occurred, I would see the below error in the system.log:


Oct 18 15:03:00 office /usr/sbin/AppleFileServer[191]: CloseFork: fOpenForks[1] is Null!


Hope someone out there can shed some light.

Xserve, Mac OS X (10.6.8)
  • Cron Master Level 1 Level 1

    Additional clues:




    Oct 28 15:30:48 7123L16 edu.mit.Kerberos.CCacheServer[5159]: launchctl start error: No such process

    Oct 28 15:31:24 7123L16 authorizationhost[4844]: afp home directory mount failed in theEnumerator->Count in AFP_OpenSession: status = Unknown error: -5023




    Oct 28 14:58:39 ust1 mDNSResponder[35]: PenaltyTimeForServer: PenaltyTime negative -72787, (server penaltyTime 589340768, timenow 589413555) resetting the penalty

    Oct 28 15:01:39 ust1 servermgrd[60]: -[AccountsRequestHandler(AccountsOpenDirectoryHelpers) openLocalLDAPNodeIfNeeded]: dsLocalLDAP = (null), error = Error Domain=com.apple.OpenDirectory Code=2000 UserInfo=0x106a10f60 "Unable to open Directory node with name /LDAPv3/"

  • sscholle Level 1 Level 1

    This usually happens when the clients cant resolve your servers hostname.
    Therefore their DNS config must somewere be able to resolve the servers hostname.
    I got that error all the time before I fixed my DNS config, so in my DHCP server config the Primary DNS is pointing at my server (Open Directory/xserve). This might fix it, try that.

  • ClassicII Level 3 Level 3

    You can also do a quick thing on the users side. Select the user that you have picked to log and you are getting this error. Open Workgroup Manager and select the user then click the advanced tab. Switch "user pasword type" to crypt password and then type in any password. Click save, then select another user and then go back to the user where you switched the password. Now switch it back to Open Directory.

    This has worked for us with users getting that same error.

  • Dreyfuzz Level 1 Level 1

    This didn't work for me.

  • quesengar Level 1 Level 1

    I was having the same problem and what I ended up doing was adding my server ip to hosts file with the correct lookup value.  Solved the problem immediately. 


    hosts file is located in /etc/hosts


    open terminal

    elevete permissions to root

    i.e. sudo vi /etc/hosts

    enter password

    add your server/name to file by

    hitting i

    then add a new line at the bottom of the file

    enter your ip address and a few spaces and then enter your server name, mine was     minimac.server.private

    hit escape key

    enter :wq


    Login  with the user you were having problems with...